summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-12-05 10:44:35 +0000
committerRoy Marples <uberlord@gentoo.org>2006-12-05 10:44:35 +0000
commitcbeac485102fdf5ec8be6201906a2ead8fdbc021 (patch)
tree9deeebd48f85603caf1515bd5cf0d32530234f66 /app-laptop/tp_smapi
parentFix digest (diff)
downloadgentoo-2-cbeac485102fdf5ec8be6201906a2ead8fdbc021.tar.gz
gentoo-2-cbeac485102fdf5ec8be6201906a2ead8fdbc021.tar.bz2
gentoo-2-cbeac485102fdf5ec8be6201906a2ead8fdbc021.zip
New version, fixes #157185 thanks to Anton Bolshakov.
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'app-laptop/tp_smapi')
-rw-r--r--app-laptop/tp_smapi/ChangeLog7
-rw-r--r--app-laptop/tp_smapi/files/digest-tp_smapi-0.303
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.30.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index 56b7f279d65a..69b1acc5f405 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tp_smapi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.14 2006/08/14 12:04:15 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.15 2006/12/05 10:44:35 uberlord Exp $
+
+*tp_smapi-0.30 (05 Dec 2006)
+
+ 05 Dec 2006; Roy Marples <uberlord@gentoo.org> +tp_smapi-0.30.ebuild:
+ New version, fixes #157185 thanks to Anton Bolshakov.
*tp_smapi-0.27 (14 Aug 2006)
diff --git a/app-laptop/tp_smapi/files/digest-tp_smapi-0.30 b/app-laptop/tp_smapi/files/digest-tp_smapi-0.30
new file mode 100644
index 000000000000..175ef48c182f
--- /dev/null
+++ b/app-laptop/tp_smapi/files/digest-tp_smapi-0.30
@@ -0,0 +1,3 @@
+MD5 06e15345276d8389950bd89c8bd96717 tp_smapi-0.30.tgz 36980
+RMD160 fdb808a33b6c2b6251e344e89bde38afd6a5da3c tp_smapi-0.30.tgz 36980
+SHA256 6f1d16bffb2bb7fec6aa607b193d5a844a1342fa4004549997033b2107c48285 tp_smapi-0.30.tgz 36980
diff --git a/app-laptop/tp_smapi/tp_smapi-0.30.ebuild b/app-laptop/tp_smapi/tp_smapi-0.30.ebuild
new file mode 100644
index 000000000000..e6e87c5fe949
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.30.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.30.ebuild,v 1.1 2006/12/05 10:44:35 uberlord Exp $
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="http://tpctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="hdaps"
+
+RESTRICT="userpriv"
+
+# We need dmideode if the kernel does not support DMI_DEV_TYPE_OEM_STRING
+# in dmi.h
+DEPEND="sys-apps/dmidecode"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 15; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.15 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KSRC=${KV_DIR}"
+ BUILD_TARGETS="default"
+
+ if use hdaps; then
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Ug, sudo in a Makefile
+ sed -i 's,sudo ,,' Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc CHANGES README
+}