summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-08-18 21:11:49 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-08-18 21:11:49 +0000
commit0432a7dd5ecae1df77ed48cba8b95bee6107d9e1 (patch)
treedd4e3e74d9e106e227fcdddb5059e371c984898d /app-misc/abook/abook-0.4.17.ebuild
parentWrong category (diff)
downloadgentoo-2-0432a7dd5ecae1df77ed48cba8b95bee6107d9e1.tar.gz
gentoo-2-0432a7dd5ecae1df77ed48cba8b95bee6107d9e1.tar.bz2
gentoo-2-0432a7dd5ecae1df77ed48cba8b95bee6107d9e1.zip
Moved from net-mail to app-misc. abook is a curses based address book.
Diffstat (limited to 'app-misc/abook/abook-0.4.17.ebuild')
-rw-r--r--app-misc/abook/abook-0.4.17.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/abook/abook-0.4.17.ebuild b/app-misc/abook/abook-0.4.17.ebuild
new file mode 100644
index 000000000000..eb66116a607a
--- /dev/null
+++ b/app-misc/abook/abook-0.4.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/abook-0.4.17.ebuild,v 1.1 2002/08/18 21:11:49 mcummings Exp $
+
+DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client."
+HOMEPAGE="http://abook.sourceforge.net/"
+SRC_URI="mirror://sourceforge/abook/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+DEPEND="sys-libs/ncurses"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ cd ${S}
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}