summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 03:13:16 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 03:13:16 +0000
commit66282e6b46661dbecd6ecee478bd409dd11985c8 (patch)
treef35de1ac6ad6c448b1e4d9c9769c7ba8eb5e5f75 /app-misc
parentChanged src_install () to src_install() (diff)
downloadgentoo-2-66282e6b46661dbecd6ecee478bd409dd11985c8.tar.gz
gentoo-2-66282e6b46661dbecd6ecee478bd409dd11985c8.tar.bz2
gentoo-2-66282e6b46661dbecd6ecee478bd409dd11985c8.zip
Changed econf||die to econf
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/bonnie++/bonnie++-1.02a.ebuild13
-rw-r--r--app-misc/bonnie++/bonnie++-1.02c-r1.ebuild7
-rw-r--r--app-misc/bonnie++/bonnie++-1.02c.ebuild13
-rw-r--r--app-misc/cmatrix/cmatrix-1.2a.ebuild20
4 files changed, 14 insertions, 39 deletions
diff --git a/app-misc/bonnie++/bonnie++-1.02a.ebuild b/app-misc/bonnie++/bonnie++-1.02a.ebuild
index 2e3920545f8f..25ed0ca74d11 100644
--- a/app-misc/bonnie++/bonnie++-1.02a.ebuild
+++ b/app-misc/bonnie++/bonnie++-1.02a.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/bonnie++/bonnie++-1.02a.ebuild,v 1.8 2002/10/20 18:40:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/bonnie++/bonnie++-1.02a.ebuild,v 1.9 2002/11/30 03:08:31 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Hard drive bottleneck testing benchmark suite."
SRC_URI="http://www.coker.com.au/bonnie++/${P}.tgz"
HOMEPAGE="http://www.coker.com.au/bonnie++/"
@@ -11,15 +10,9 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
-DEPEND="virtual/glibc"
-
src_compile() {
- if [ "$DEBUG" == "true" ]
- then
- myconf="--with-debug --disable-stripping"
- fi
-
- econf ${myconf} || die "./configure failed"
+ [ "$DEBUG" == "true" ] && myconf="--with-debug --disable-stripping"
+ econf ${myconf}
emake || die "emake failed"
}
diff --git a/app-misc/bonnie++/bonnie++-1.02c-r1.ebuild b/app-misc/bonnie++/bonnie++-1.02c-r1.ebuild
index 87582a06b429..744c29759bec 100644
--- a/app-misc/bonnie++/bonnie++-1.02c-r1.ebuild
+++ b/app-misc/bonnie++/bonnie++-1.02c-r1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/bonnie++/bonnie++-1.02c-r1.ebuild,v 1.1 2002/10/14 19:53:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/bonnie++/bonnie++-1.02c-r1.ebuild,v 1.2 2002/11/30 03:09:38 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Hard drive bottleneck testing benchmark suite."
SRC_URI="http://www.coker.com.au/bonnie++/${P}.tgz"
HOMEPAGE="http://www.coker.com.au/bonnie++/"
@@ -11,13 +10,11 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
-DEPEND="virtual/glibc"
-
src_compile() {
local myconf=""
[ "$DEBUG" == "true" ] && myconf="--with-debug --disable-stripping"
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
emake || die "emake failed"
emake zcav || die "emake zcav failed" # see #9073
}
diff --git a/app-misc/bonnie++/bonnie++-1.02c.ebuild b/app-misc/bonnie++/bonnie++-1.02c.ebuild
index 537af16a54fc..ad55ef265d92 100644
--- a/app-misc/bonnie++/bonnie++-1.02c.ebuild
+++ b/app-misc/bonnie++/bonnie++-1.02c.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/bonnie++/bonnie++-1.02c.ebuild,v 1.4 2002/10/04 04:54:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/bonnie++/bonnie++-1.02c.ebuild,v 1.5 2002/11/30 03:11:00 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Hard drive bottleneck testing benchmark suite."
SRC_URI="http://www.coker.com.au/bonnie++/${P}.tgz"
HOMEPAGE="http://www.coker.com.au/bonnie++/"
@@ -11,15 +10,9 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
-DEPEND="virtual/glibc"
-
src_compile() {
- if [ "$DEBUG" == "true" ]
- then
- myconf="--with-debug --disable-stripping"
- fi
-
- econf ${myconf} || die "./configure failed"
+ [ "$DEBUG" == "true" ] && myconf="--with-debug --disable-stripping"
+ econf ${myconf}
emake || die "emake failed"
}
diff --git a/app-misc/cmatrix/cmatrix-1.2a.ebuild b/app-misc/cmatrix/cmatrix-1.2a.ebuild
index db088b208d88..acbf5c65dbc7 100644
--- a/app-misc/cmatrix/cmatrix-1.2a.ebuild
+++ b/app-misc/cmatrix/cmatrix-1.2a.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cmatrix/cmatrix-1.2a.ebuild,v 1.4 2002/10/20 18:40:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cmatrix/cmatrix-1.2a.ebuild,v 1.5 2002/11/30 03:13:16 vapier Exp $
-IUSE="X"
-
-S=${WORKDIR}/${P}
DESCRIPTION="An ncurses based app to show a scrolling screen from the Matrix"
HOMEPAGE="http://www.asty.org/cmatrix"
SRC_URI="http://www.asty.org/${PN}/dist/${P}.tar.gz"
@@ -12,12 +9,12 @@ SRC_URI="http://www.asty.org/${PN}/dist/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="X"
DEPEND="X? ( virtual/x11 )
sys-libs/ncurses"
src_unpack() {
-
unpack ${A}
# patch Makefile.am to make sure the fonts installations don't violate the
@@ -28,27 +25,22 @@ src_unpack() {
}
src_compile() {
-
- econf || die
+ econf
emake || die
}
src_install() {
-
dodir /usr/share/consolefonts
dodir /usr/lib/kbd/consolefonts
- use X && ( \
+ if [ `use X` ] ; then
dodir /usr/lib/X11/fonts/misc
dodir /usr/X11R6/lib/X11/fonts/misc
- )
+ fi
make DESTDIR=${D} install || die
-
}
pkg_postinst() {
-
- if [ "`use X`" ]
- then
+ if [ `use X` ] ; then
if test -d /usr/lib/X11/fonts/misc; then
einfo ">>> Running mkfontdir on /usr/lib/X11/fonts/misc"
mkfontdir /usr/lib/X11/fonts/misc