summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-12-30 21:57:36 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-12-30 21:57:36 +0000
commitaa7f3806b2af5875597509226ce5e5f9becdd6d7 (patch)
tree68e8240a31cf8f1cae06cb44a6fc06dc125b0406 /app-office/gnucash
parentChange encoding to UTF-8 for GLEP 31 compliance (Manifest recommit) (diff)
downloadgentoo-2-aa7f3806b2af5875597509226ce5e5f9becdd6d7.tar.gz
gentoo-2-aa7f3806b2af5875597509226ce5e5f9becdd6d7.tar.bz2
gentoo-2-aa7f3806b2af5875597509226ce5e5f9becdd6d7.zip
added a check for whether bitmap-fonts support exists in xorg-x11. Closes bug #75910 by Volkov Peter <torre_cremata@mail.ru>
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/ChangeLog7
-rw-r--r--app-office/gnucash/gnucash-1.8.10.ebuild15
-rw-r--r--app-office/gnucash/gnucash-1.8.8.ebuild16
-rw-r--r--app-office/gnucash/gnucash-1.8.9.ebuild15
4 files changed, 49 insertions, 4 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index 84e23795de20..13d870094f09 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.57 2004/12/30 20:56:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.58 2004/12/30 21:57:36 seemant Exp $
+
+ 30 Dec 2004; Seemant Kulleen <seemant@gentoo.org> gnucash-1.8.10.ebuild,
+ gnucash-1.8.8.ebuild, gnucash-1.8.9.ebuild:
+ added a check for whether bitmap-fonts support exists in xorg-x11. Closes
+ bug #75910 by Volkov Peter <torre_cremata@mail.ru>
30 Dec 2004; Seemant Kulleen <seemant@gentoo.org> gnucash-1.8.10.ebuild:
changed hbci dependency from aqhbci to aqhbci-wizard-kde, closing bug #75961
diff --git a/app-office/gnucash/gnucash-1.8.10.ebuild b/app-office/gnucash/gnucash-1.8.10.ebuild
index caf2895e34e6..f456ca777463 100644
--- a/app-office/gnucash/gnucash-1.8.10.ebuild
+++ b/app-office/gnucash/gnucash-1.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.10.ebuild,v 1.5 2004/12/30 20:56:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.10.ebuild,v 1.6 2004/12/30 21:57:36 seemant Exp $
inherit flag-o-matic libtool eutils
@@ -60,6 +60,19 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+pkg_setup() {
+ if built_with_use xorg-x11 bitmap-fonts
+ then
+ einfo "bitmap-fonts support is enabled in xorg-x11, continuing..."
+ else
+ eerror "Please rebuild xorg-x11 with bitmap font support!"
+ eerror "To do so: USE=\"bitmap-fonts\" emerge xorg-x11"
+ eerror "Or, add \"bitmap-fonts\" to your USE string in"
+ eerror "/etc/make.conf"
+ die "Will not build gnucash without bitmap-fonts support in xorg-x11"
+ fi
+}
+
src_compile() {
elibtoolize
diff --git a/app-office/gnucash/gnucash-1.8.8.ebuild b/app-office/gnucash/gnucash-1.8.8.ebuild
index 9bb0ce1f1d04..9475a78aeff2 100644
--- a/app-office/gnucash/gnucash-1.8.8.ebuild
+++ b/app-office/gnucash/gnucash-1.8.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.8.ebuild,v 1.9 2004/10/18 07:13:27 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.8.ebuild,v 1.10 2004/12/30 21:57:36 seemant Exp $
inherit flag-o-matic libtool
@@ -54,6 +54,20 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ if built_with_use xorg-x11 bitmap-fonts
+ then
+ einfo "bitmap-fonts support is enabled in xorg-x11, continuing..."
+ else
+ eerror "Please rebuild xorg-x11 with bitmap font support!"
+ eerror "To do so: USE=\"bitmap-fonts\" emerge xorg-x11"
+ eerror "Or, add \"bitmap-fonts\" to your USE string in"
+ eerror "/etc/make.conf"
+ die "Will not build gnucash without bitmap-fonts support in xorg-x11"
+ fi
+}
+
src_compile() {
elibtoolize
local myconf=""
diff --git a/app-office/gnucash/gnucash-1.8.9.ebuild b/app-office/gnucash/gnucash-1.8.9.ebuild
index 9be4d4b46f71..b2165a1445da 100644
--- a/app-office/gnucash/gnucash-1.8.9.ebuild
+++ b/app-office/gnucash/gnucash-1.8.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.9.ebuild,v 1.11 2004/12/26 17:52:30 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.9.ebuild,v 1.12 2004/12/30 21:57:36 seemant Exp $
inherit flag-o-matic libtool eutils
@@ -59,6 +59,19 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
+pkg_setup() {
+ if built_with_use xorg-x11 bitmap-fonts
+ then
+ einfo "bitmap-fonts support is enabled in xorg-x11, continuing..."
+ else
+ eerror "Please rebuild xorg-x11 with bitmap font support!"
+ eerror "To do so: USE=\"bitmap-fonts\" emerge xorg-x11"
+ eerror "Or, add \"bitmap-fonts\" to your USE string in"
+ eerror "/etc/make.conf"
+ die "Will not build gnucash without bitmap-fonts support in xorg-x11"
+ fi
+}
+
src_compile() {
elibtoolize