summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-07-24 21:32:43 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-07-24 21:32:43 +0000
commitf40888c48a741fe1ad28686d0d18f87fcebe127d (patch)
tree8971a624f0db4b833a6e64a2f56584f69e92f645 /app-office
parentStable on amd64 wrt bug #375921 (diff)
downloadgentoo-2-f40888c48a741fe1ad28686d0d18f87fcebe127d.tar.gz
gentoo-2-f40888c48a741fe1ad28686d0d18f87fcebe127d.tar.bz2
gentoo-2-f40888c48a741fe1ad28686d0d18f87fcebe127d.zip
Quick&Dirty hack to fix svx build crash i observed on my desktop (definitely not a solution for upstream).
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog7
-rw-r--r--app-office/libreoffice/files/libreoffice-svx.patch28
-rw-r--r--app-office/libreoffice/libreoffice-3.4.2.2.ebuild3
3 files changed, 36 insertions, 2 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 2a361e316deb..f41da87ec057 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.44 2011/07/24 16:40:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.45 2011/07/24 21:32:42 scarabeus Exp $
+
+ 24 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ libreoffice-3.4.2.2.ebuild, +files/libreoffice-svx.patch:
+ Quick&Dirty hack to fix svx build crash i observed on my desktop (definitely
+ not a solution for upstream).
24 Jul 2011; Tomáš Chvátal <scarabeus@gentoo.org>
libreoffice-3.4.2.2.ebuild:
diff --git a/app-office/libreoffice/files/libreoffice-svx.patch b/app-office/libreoffice/files/libreoffice-svx.patch
new file mode 100644
index 000000000000..d25d19257f5f
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-svx.patch
@@ -0,0 +1,28 @@
+--- libreoffice-bootstrap-3.4.2.2/svx/AllLangResTarget_svx.mk.old 2011-07-24 21:49:06.000000000 +0200
++++ libreoffice-bootstrap-3.4.2.2/svx/AllLangResTarget_svx.mk 2011-07-24 22:02:11.000000000 +0200
+@@ -106,11 +106,11 @@
+ # hack !!!
+ # just a temporary - globlmn.hrc about to be removed!
+ ifeq ($(strip $(WITH_LANG)),)
+-$(WORKDIR)/inc/svx/globlmn.hrc : $(realpath $(SRCDIR)/svx/inc/globlmn_tmpl.hrc)
++$(WORKDIR)/inc/svx/globlmn.hrc : $(SRCDIR)/svx/inc/globlmn_tmpl.hrc
+ echo copying $@
+ -mkdir -p $(WORKDIR)/inc/svx
+- cp $< $@
+- $(call gb_Deliver_deliver, $@, $(OUTDIR)/inc/svx/globlmn.hrc)
++ cp $(SRCDIR)/svx/inc/globlmn_tmpl.hrc $(WORKDIR)/inc/svx/globlmn.hrc
++ cp $(SRCDIR)/svx/inc/globlmn_tmpl.hrc $(OUTDIR)/inc/svx/globlmn.hrc
+ rm -f $(WORKDIR)/inc/svx/lastrun.mk
+ else
+ -include $(WORKDIR)/inc/svx/lastrun.mk
+@@ -125,8 +125,8 @@
+ $(call gb_Helper_abbreviate_dirs_native, \
+ $(gb_SrsPartMergeTarget_TRANSEXCOMMAND) \
+ -p svx \
+- -i $< -o $@ -m $(realpath $(gb_SrsPartMergeTarget_SDFLOCATION)/svx/inc/localize.sdf) -l all)
+- $(call gb_Deliver_deliver, $@, $(OUTDIR)/inc/svx/globlmn.hrc)
++ -i $< -o $@ -m $(gb_SrsPartMergeTarget_SDFLOCATION)/svx/inc/localize.sdf -l all)
++ cp $(WORKDIR)/inc/svx/globlmn.hrc $(OUTDIR)/inc/svx/globlmn.hrc
+ endif
+
+ .PHONY : $(WORKDIR)/inc/svx/globlmn.hrc_clean
diff --git a/app-office/libreoffice/libreoffice-3.4.2.2.ebuild b/app-office/libreoffice/libreoffice-3.4.2.2.ebuild
index 04907540a37f..317017a328f7 100644
--- a/app-office/libreoffice/libreoffice-3.4.2.2.ebuild
+++ b/app-office/libreoffice/libreoffice-3.4.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.2.2.ebuild,v 1.4 2011/07/24 16:40:34 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-3.4.2.2.ebuild,v 1.5 2011/07/24 21:32:42 scarabeus Exp $
EAPI=3
@@ -214,6 +214,7 @@ PATCHES=(
"${FILESDIR}/${PN}-libdb5-fix-check.diff"
"${FILESDIR}/${PN}-3.4.1-salfix.diff"
"${FILESDIR}/sdext-presenter.diff"
+ "${FILESDIR}/${PN}-svx.patch"
)
# Uncoment me when updating to eapi4