summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-05-08 02:04:28 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-05-08 02:04:28 +0000
commit47d1b32da8da3605849d5f38cba11140cc94ee70 (patch)
treeea370dcca481dd2ac5d5d74187107437e8112e16 /app-sci/babel
parentMerging in changes from default-1.0. (diff)
downloadgentoo-2-47d1b32da8da3605849d5f38cba11140cc94ee70.tar.gz
gentoo-2-47d1b32da8da3605849d5f38cba11140cc94ee70.tar.bz2
gentoo-2-47d1b32da8da3605849d5f38cba11140cc94ee70.zip
moved app-misc/{babel,netcdf} and dev-lang/{iverilog,octave} into app-sci
Diffstat (limited to 'app-sci/babel')
-rw-r--r--app-sci/babel/ChangeLog13
-rw-r--r--app-sci/babel/babel-1.6.ebuild47
-rw-r--r--app-sci/babel/files/10babel1
-rw-r--r--app-sci/babel/files/babel-1.6-gentoo.diff28
-rw-r--r--app-sci/babel/files/digest-babel-1.61
5 files changed, 90 insertions, 0 deletions
diff --git a/app-sci/babel/ChangeLog b/app-sci/babel/ChangeLog
new file mode 100644
index 000000000000..a6c2fb7333aa
--- /dev/null
+++ b/app-sci/babel/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-sci/babel
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/babel/ChangeLog,v 1.1 2002/05/08 02:04:28 george Exp $
+
+*babel-1.6 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-sci/babel/babel-1.6.ebuild b/app-sci/babel/babel-1.6.ebuild
new file mode 100644
index 000000000000..d405999b93fa
--- /dev/null
+++ b/app-sci/babel/babel-1.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $ Header: $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Babel is a program to interconvert file formats used in molecular modeling."
+
+SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
+
+HOMEPAGE="http://smog.com/chem/babel/"
+
+#Doesn't really seem to depend on anything (?)
+DEPEND="virtual/glibc"
+
+PROVIDE="app-misc/babel"
+
+src_unpack() {
+
+ unpack ${P}.tar.Z
+ cd ${S}
+#Patch the Makefile for gentoo-isms
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D}/usr/bin install || die
+
+ insinto /usr/share/${PN}
+ doins ${S}/*.lis
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/10babel
+
+ dodoc README.1ST
+
+}
+
diff --git a/app-sci/babel/files/10babel b/app-sci/babel/files/10babel
new file mode 100644
index 000000000000..69f3397638dd
--- /dev/null
+++ b/app-sci/babel/files/10babel
@@ -0,0 +1 @@
+BABEL_DIR=/usr/share/babel
diff --git a/app-sci/babel/files/babel-1.6-gentoo.diff b/app-sci/babel/files/babel-1.6-gentoo.diff
new file mode 100644
index 000000000000..77e2cb47ef03
--- /dev/null
+++ b/app-sci/babel/files/babel-1.6-gentoo.diff
@@ -0,0 +1,28 @@
+--- Makefile.orig Tue Oct 23 00:20:54 2001
++++ Makefile Tue Oct 23 00:33:36 2001
+@@ -1,11 +1,15 @@
+-CFLAGS = -O
++#Commented out to pull CFLAGS from make.conf
++#CFLAGS = -O
+
+ LIBFLAGS = -O -DLIBRARY
+
+-CC = cc
++#Probably not necessary to specify gcc
++CC = gcc
+
+ PROGRAM = babel
+
++DEST = ${DESTDIR}/$(PROGRAM)
++
+ LDFLAGS =
+
+ LIBS =
+@@ -334,6 +338,7 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
++ install -d ${DESTDIR}
+ install -s $(PROGRAM) $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
diff --git a/app-sci/babel/files/digest-babel-1.6 b/app-sci/babel/files/digest-babel-1.6
new file mode 100644
index 000000000000..118db2b06dc9
--- /dev/null
+++ b/app-sci/babel/files/digest-babel-1.6
@@ -0,0 +1 @@
+MD5 101a5dc4858ecacac123571db52b272e babel-1.6.tar.Z 242341