summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2003-04-24 00:09:45 +0000
committerJon Portnoy <avenj@gentoo.org>2003-04-24 00:09:45 +0000
commit01fb254dac91a6d67f24fa5cc4bc0b6c2e1c06ed (patch)
tree58eb3311216ac62180afae89f97d3e7417186acc /app-sci/phylip/phylip-3.5.ebuild
parentInitial import of phylip - thanks sediener! (diff)
downloadgentoo-2-01fb254dac91a6d67f24fa5cc4bc0b6c2e1c06ed.tar.gz
gentoo-2-01fb254dac91a6d67f24fa5cc4bc0b6c2e1c06ed.tar.bz2
gentoo-2-01fb254dac91a6d67f24fa5cc4bc0b6c2e1c06ed.zip
Initial import of phylip - thanks sediener!
Diffstat (limited to 'app-sci/phylip/phylip-3.5.ebuild')
-rw-r--r--app-sci/phylip/phylip-3.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-sci/phylip/phylip-3.5.ebuild b/app-sci/phylip/phylip-3.5.ebuild
new file mode 100644
index 000000000000..44032a816af0
--- /dev/null
+++ b/app-sci/phylip/phylip-3.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/phylip/phylip-3.5.ebuild,v 1.1 2003/04/24 00:09:33 avenj Exp $
+
+DESCRIPTION="PHYLIP (the PHYLogeny Inference Package) is a package of programs for inferring phylogenies (evolutionary trees)"
+
+HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
+SRC_URI="ftp://evolution.genetics.washington.edu/pub/phylip/${PN}.tar.Z"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+
+src_compile() {
+ cd ${WORKDIR}
+ # uses only makefile.
+ EXTRA_EMAKE="-e ${CFLAGS}"
+ emake || die
+}
+src_install()
+{
+ cd ${WORKDIR}
+ dobin clique consense contml contrast dnacomp dnadist dnainvar
+ dobin dnaml dnamlk dnamove dnapars dnapenny dollop dolmove dolpenny
+ dobin drawgram drawtree factor fitch gendist kitsch mix move neighbor
+ dobin penny protdist protpars restml retree seqboot
+
+ dodoc README clique.doc dnadist.doc dolmove.doc
+ dodoc kitsch.doc protml.doc consense.doc dnainvar.doc
+ dodoc dolpenny.doc main.doc protpars.doc contchar.doc
+ dodoc dnaml.doc draw.doc makeinf.doc restml.doc contml.doc
+ dodoc dnamlk.doc drawgram.doc
+ dodoc mix.doc retree.doc contrast.doc dnamove.doc drawtree.doc
+ dodoc move.doc seqboot.doc discrete.doc dnapars.doc factor.doc
+ dodoc neighbor.doc sequence.doc distance.doc dnapenny.doc fitch.doc
+ dodoc penny.doc dnacomp.doc dollop.doc gendist.doc protdist.doc
+}