summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-01-06 05:17:09 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-01-06 05:17:09 +0000
commita7b8391465b6e1140b5faacb715c6195b91fe6ce (patch)
tree6fa3b4ada78e80d72f06e5fc9b88d600ad34cb53 /app-sci/xcircuit
parentkeymasked the ebuild (diff)
downloadgentoo-2-a7b8391465b6e1140b5faacb715c6195b91fe6ce.tar.gz
gentoo-2-a7b8391465b6e1140b5faacb715c6195b91fe6ce.tar.bz2
gentoo-2-a7b8391465b6e1140b5faacb715c6195b91fe6ce.zip
version update. Seems to fix a few glitches in previous version.
Diffstat (limited to 'app-sci/xcircuit')
-rw-r--r--app-sci/xcircuit/ChangeLog10
-rw-r--r--app-sci/xcircuit/files/digest-xcircuit-2.5.51
-rw-r--r--app-sci/xcircuit/xcircuit-2.5.5.ebuild36
3 files changed, 45 insertions, 2 deletions
diff --git a/app-sci/xcircuit/ChangeLog b/app-sci/xcircuit/ChangeLog
index 1eab6c797e3a..06a8b3f460b9 100644
--- a/app-sci/xcircuit/ChangeLog
+++ b/app-sci/xcircuit/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for app-sci/xcircuit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/ChangeLog,v 1.7 2002/11/06 06:23:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/ChangeLog,v 1.8 2003/01/06 05:17:09 george Exp $
-*xcircuit-2.5.4 (5 Apr 2003)
+*xcircuit-2.5.5 (5 Jan 2003)
+
+ 5 Jan 2003; George Shapovalov <george@gentoo.org> xcircuit-2.5.5.ebuild :
+
+ version update.
+
+*xcircuit-2.5.4 (5 Apr 2002)
15 Oct 2002; George Shapovalov <george@gentoo.org> xcircuit-2.5.4.ebuild
diff --git a/app-sci/xcircuit/files/digest-xcircuit-2.5.5 b/app-sci/xcircuit/files/digest-xcircuit-2.5.5
new file mode 100644
index 000000000000..d234949b4c86
--- /dev/null
+++ b/app-sci/xcircuit/files/digest-xcircuit-2.5.5
@@ -0,0 +1 @@
+MD5 d96cf74f3d39245bf711e67d77b06d49 xcircuit-2.5.5.tar.bz2 523555
diff --git a/app-sci/xcircuit/xcircuit-2.5.5.ebuild b/app-sci/xcircuit/xcircuit-2.5.5.ebuild
new file mode 100644
index 000000000000..936cab3d398a
--- /dev/null
+++ b/app-sci/xcircuit/xcircuit-2.5.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/xcircuit-2.5.5.ebuild,v 1.1 2003/01/06 05:17:09 george Exp $
+
+IUSE=""
+
+inherit flag-o-matic
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://xcircuit.ece.jhu.edu/archive/${P}.tar.bz2"
+HOMEPAGE="http://xcircuit.ece.jhu.edu"
+
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/x11
+ dev-lang/python
+ app-text/ghostscript"
+
+#looks like -O3 causes problems at times
+replace-flags -O3 -O2
+
+src_compile() {
+ econf || die "./configure failed"
+
+ #Parallel make bombs on parameter.c looking for menudep.h
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "Installation failed"
+ dodoc COPYRIGHT README*
+}