summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-12-18 14:34:11 +0000
committerMike Frysinger <vapier@gentoo.org>2002-12-18 14:34:11 +0000
commit25c906cb44da34e08a6ce69a54352488ea002714 (patch)
treebfba41c834dccb953e7b4483b3491c5c5ef6e352 /app-sci
parentChanged econf||die to econf (diff)
downloadgentoo-2-25c906cb44da34e08a6ce69a54352488ea002714.tar.gz
gentoo-2-25c906cb44da34e08a6ce69a54352488ea002714.tar.bz2
gentoo-2-25c906cb44da34e08a6ce69a54352488ea002714.zip
Changed econf||die to econf
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/netcdf/netcdf-3.5.0-r2.ebuild12
-rw-r--r--app-sci/oregano/oregano-0.23-r1.ebuild25
2 files changed, 17 insertions, 20 deletions
diff --git a/app-sci/netcdf/netcdf-3.5.0-r2.ebuild b/app-sci/netcdf/netcdf-3.5.0-r2.ebuild
index ebd638a74ad9..84391aecaadc 100644
--- a/app-sci/netcdf/netcdf-3.5.0-r2.ebuild
+++ b/app-sci/netcdf/netcdf-3.5.0-r2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r2.ebuild,v 1.1 2002/11/20 07:50:45 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r2.ebuild,v 1.2 2002/12/18 14:29:29 vapier Exp $
-S=${WORKDIR}/${P}/src
DESCRIPTION="Interface for array oriented data access"
SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.Z"
HOMEPAGE="http://www.unidaa.ucar.edu/packages/netcdf/"
@@ -11,6 +10,8 @@ LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
+S=${WORKDIR}/${P}/src
+
src_unpack() {
unpack ${A}
cd ${S}
@@ -25,17 +26,14 @@ src_unpack() {
src_compile() {
export CPPFLAGS=-Df2cFortran
- econf || die
+ econf
make || die
make test || die
}
src_install() {
dodir /usr/{lib,share}
-
- einstall \
- MANDIR=${D}/usr/share/man || die
-
+ einstall MANDIR=${D}/usr/share/man
dodoc COMPATIBILITY COPYRIGHT MANIFEST README RELEASE_NOTES VERSION
dohtml -r .
}
diff --git a/app-sci/oregano/oregano-0.23-r1.ebuild b/app-sci/oregano/oregano-0.23-r1.ebuild
index 1a062ec95e96..b0880bb2d946 100644
--- a/app-sci/oregano/oregano-0.23-r1.ebuild
+++ b/app-sci/oregano/oregano-0.23-r1.ebuild
@@ -1,28 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/oregano/oregano-0.23-r1.ebuild,v 1.3 2002/10/20 18:40:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/oregano/oregano-0.23-r1.ebuild,v 1.4 2002/12/18 14:34:11 vapier Exp $
-S=${WORKDIR}/${P}
-SRC_URI="ftp://ftp.codefactory.se/pub/CodeFactory/software/oregano/${P}.tar.gz"
DESCRIPTION="Oregano is an application for schematic capture and simulation of electrical circuits."
+SRC_URI="ftp://ftp.codefactory.se/pub/CodeFactory/software/oregano/${P}.tar.gz"
HOMEPAGE="http://oregano.codefactory.se/"
-DEPEND="=x11-libs/gtk+-1.2*
- >=gnome-base/gnome-libs-1.4
- >=gnome-base/libglade-0.17 <gnome-base/libglade-2.0.0
- >=gnome-base/gnome-print-0.30
- >=dev-libs/libxml-1.8.17
- >=app-sci/spice-3.5.5"
-
SLOT="0"
KEYWORDS="x86"
LICENSE="GPL-2"
+DEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4
+ >=gnome-base/libglade-0.17 <gnome-base/libglade-2.0.0
+ >=gnome-base/gnome-print-0.30
+ >=dev-libs/libxml-1.8.17
+ >=app-sci/spice-3.5.5"
+
src_compile() {
- econf || die
+ econf
emake || die
}
-src_install () {
- einstall || die
+src_install() {
+ einstall
}