summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-04 11:14:20 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-04 11:14:20 +0000
commit2e3d7da9f1689120a246c528890ac25d9b4a0f73 (patch)
treeb0dde1d720dd1cf6a8bbe216858d299f3cdbe6e4 /app-shells/autojump
parentdev-python/pandas: Version Bump, #468498; add support for py-3; correct PYTHO... (diff)
downloadgentoo-2-2e3d7da9f1689120a246c528890ac25d9b4a0f73.tar.gz
gentoo-2-2e3d7da9f1689120a246c528890ac25d9b4a0f73.tar.bz2
gentoo-2-2e3d7da9f1689120a246c528890ac25d9b4a0f73.zip
Version bump (thanks Oliver Freyermuth, bug 468056), fix python-r1 support.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/ChangeLog8
-rw-r--r--app-shells/autojump/autojump-21.3.0-r1.ebuild12
-rw-r--r--app-shells/autojump/autojump-21.5.8.ebuild58
-rw-r--r--app-shells/autojump/files/autojump-21.5.8-eprefix.patch13
4 files changed, 82 insertions, 9 deletions
diff --git a/app-shells/autojump/ChangeLog b/app-shells/autojump/ChangeLog
index 07bd29f007a8..e7836bd0747b 100644
--- a/app-shells/autojump/ChangeLog
+++ b/app-shells/autojump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/autojump
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.11 2013/05/04 10:43:19 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/ChangeLog,v 1.12 2013/05/04 11:14:20 xmw Exp $
+
+*autojump-21.5.8 (04 May 2013)
+
+ 04 May 2013; Michael Weber <xmw@gentoo.org> +autojump-21.5.8.ebuild,
+ +files/autojump-21.5.8-eprefix.patch, autojump-21.3.0-r1.ebuild:
+ Version bump (thanks Oliver Freyermuth, bug 468056), fix python-r1 support.
*autojump-21.3.0-r1 (04 May 2013)
diff --git a/app-shells/autojump/autojump-21.3.0-r1.ebuild b/app-shells/autojump/autojump-21.3.0-r1.ebuild
index eae2567bf342..6fd533cf4a4b 100644
--- a/app-shells/autojump/autojump-21.3.0-r1.ebuild
+++ b/app-shells/autojump/autojump-21.3.0-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.3.0-r1.ebuild,v 1.1 2013/05/04 10:43:19 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.3.0-r1.ebuild,v 1.2 2013/05/04 11:14:20 xmw Exp $
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
-inherit eutils python-r1 vcs-snapshot
+inherit eutils python-r1 python-utils-r1 vcs-snapshot
DESCRIPTION="change directory command that learns"
HOMEPAGE="http://github.com/joelthelion/autojump"
@@ -47,14 +47,10 @@ src_install() {
fi
if use python ; then
- install_python() {
- insinto "$(python_get_sitedir)"
- doins tools/autojump_ipython.py
- }
- python_execute_function -q install_python
+ python_foreach_impl python_domodule tools/autojump_ipython.py
einfo "This tool provides \"j\" for ipython, please add"
- einfo "\"imporrt autojump_ipython\" to your ipy_user_conf.py."
+ einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
fi
doman docs/${PN}.1
diff --git a/app-shells/autojump/autojump-21.5.8.ebuild b/app-shells/autojump/autojump-21.5.8.ebuild
new file mode 100644
index 000000000000..0048e8169f90
--- /dev/null
+++ b/app-shells/autojump/autojump-21.5.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/autojump/autojump-21.5.8.ebuild,v 1.1 2013/05/04 11:14:20 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
+
+inherit eutils python-r1 python-utils-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="http://github.com/joelthelion/autojump"
+SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion python test zsh-completion"
+
+RDEPEND="bash-completion? ( >=app-shells/bash-4 )
+ python? ( ${PYTHON_DEPS} )
+ zsh-completion? ( app-shells/zsh app-shells/zsh-completion )"
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-eprefix.patch
+}
+
+src_compile() {
+ true
+}
+
+src_install() {
+ dobin bin/autojump
+
+ insinto /etc/profile.d
+ doins bin/${PN}.sh
+
+ if use bash-completion ; then
+ doins bin/${PN}.bash
+ fi
+
+ if use zsh-completion ; then
+ doins bin/${PN}.zsh
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+ fi
+
+ if use python ; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+
+ einfo "This tool provides \"j\" for ipython, please add"
+ einfo "\"import autojump_ipython\" to your ipy_user_conf.py."
+ fi
+
+ doman docs/${PN}.1
+ dodoc README.md
+}
diff --git a/app-shells/autojump/files/autojump-21.5.8-eprefix.patch b/app-shells/autojump/files/autojump-21.5.8-eprefix.patch
new file mode 100644
index 000000000000..3daec004b32c
--- /dev/null
+++ b/app-shells/autojump/files/autojump-21.5.8-eprefix.patch
@@ -0,0 +1,13 @@
+--- autojump-21.5.8/bin/autojump.sh
++++ autojump-21.5.8/bin/autojump.sh
+@@ -11,8 +11,8 @@
+ source ~/.autojump/etc/profile.d/autojump.${shell}
+
+ # check global install
+-elif [ -s /etc/profile.d/autojump.${shell} ]; then
+- source /etc/profile.d/autojump.${shell}
++elif [ -s "${EPREFIX}"/etc/profile.d/autojump.${shell} ]; then
++ source "${EPREFIX}"/etc/profile.d/autojump.${shell}
+
+ # check custom install locations (modified by Homebrew or using --destdir option)
+ #custom# elif [ -s destdir_install/autojump.${shell} ]; then