summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-10-29 22:08:09 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-10-29 22:08:09 +0000
commita3d134fdca012c1445ea908e73116367377e418f (patch)
tree2e5bfc6d3b4d3e081e452f439f3f4cab19fd4f8d /app-shells/bash-completion-config
parentStable on AMD64. (Manifest recommit) (diff)
downloadgentoo-2-a3d134fdca012c1445ea908e73116367377e418f.tar.gz
gentoo-2-a3d134fdca012c1445ea908e73116367377e418f.tar.bz2
gentoo-2-a3d134fdca012c1445ea908e73116367377e418f.zip
Initial release.
Diffstat (limited to 'app-shells/bash-completion-config')
-rw-r--r--app-shells/bash-completion-config/ChangeLog10
-rw-r--r--app-shells/bash-completion-config/Manifest4
-rw-r--r--app-shells/bash-completion-config/bash-completion-config-0.1.ebuild42
-rw-r--r--app-shells/bash-completion-config/files/digest-bash-completion-config-0.11
-rw-r--r--app-shells/bash-completion-config/metadata.xml9
5 files changed, 66 insertions, 0 deletions
diff --git a/app-shells/bash-completion-config/ChangeLog b/app-shells/bash-completion-config/ChangeLog
new file mode 100644
index 000000000000..c977457b6726
--- /dev/null
+++ b/app-shells/bash-completion-config/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-shells/bash-completion-config
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion-config/ChangeLog,v 1.1 2004/10/29 22:08:09 ka0ttic Exp $
+
+*bash-completion-config-0.1 (29 Oct 2004)
+
+ 29 Oct 2004; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+ +bash-completion-config-0.1.ebuild:
+ Initial release.
+
diff --git a/app-shells/bash-completion-config/Manifest b/app-shells/bash-completion-config/Manifest
new file mode 100644
index 000000000000..bbc43c12c13f
--- /dev/null
+++ b/app-shells/bash-completion-config/Manifest
@@ -0,0 +1,4 @@
+MD5 b7a4d1c91c5e378e0c5b3d294148542a bash-completion-config-0.1.ebuild 929
+MD5 1329675d5386af7b53715c9cefec73b0 ChangeLog 299
+MD5 99ce5509db4b50f28a1f6675f8c09b2b metadata.xml 258
+MD5 e5116912f70d20f0f57922751de8922e files/digest-bash-completion-config-0.1 71
diff --git a/app-shells/bash-completion-config/bash-completion-config-0.1.ebuild b/app-shells/bash-completion-config/bash-completion-config-0.1.ebuild
new file mode 100644
index 000000000000..8704ded568c0
--- /dev/null
+++ b/app-shells/bash-completion-config/bash-completion-config-0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion-config/bash-completion-config-0.1.ebuild,v 1.1 2004/10/29 22:08:09 ka0ttic Exp $
+
+MY_PN="bashcomp-config"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Utility to easily add/remove bash-completions to your environment"
+HOMEPAGE="http://developer.berlios.de/projects/bashcomp-config/"
+SRC_URI="ftp://ftp.berlios.de/pub/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=app-shells/bash-2.05"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf || die "econf failed"
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1 || die
+
+ insinto /usr/share/bash-completion
+ newins completion ${PN}
+
+ dodoc AUTHORS TODO ChangeLog README
+}
+
+pkg_postinst() {
+ echo
+ einfo "To enable command-line completion for bash-completion-config,"
+ einfo "run the following as root:"
+ einfo
+ einfo " bash-completion-config --global --install bash-completion-config"
+ echo
+}
diff --git a/app-shells/bash-completion-config/files/digest-bash-completion-config-0.1 b/app-shells/bash-completion-config/files/digest-bash-completion-config-0.1
new file mode 100644
index 000000000000..2aed2f0db8d2
--- /dev/null
+++ b/app-shells/bash-completion-config/files/digest-bash-completion-config-0.1
@@ -0,0 +1 @@
+MD5 5940dbe2ac2d4136e922ee0007ed89e2 bashcomp-config-0.1.tar.gz 102504
diff --git a/app-shells/bash-completion-config/metadata.xml b/app-shells/bash-completion-config/metadata.xml
new file mode 100644
index 000000000000..1bd09b7fe2c3
--- /dev/null
+++ b/app-shells/bash-completion-config/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>ka0ttic@gentoo.org</email>
+ <name>Aaron Walker</name>
+ </maintainer>
+</pkgmetadata>