summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-08-18 16:39:17 +0000
committerAron Griffis <agriffis@gentoo.org>2004-08-18 16:39:17 +0000
commit5263d10f33546aad035235ae6e390b78e6e0d410 (patch)
tree7a48bf58d6110c45841ada26ce38237710407bf9 /app-shells/bash
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-5263d10f33546aad035235ae6e390b78e6e0d410.tar.gz
gentoo-2-5263d10f33546aad035235ae6e390b78e6e0d410.tar.bz2
gentoo-2-5263d10f33546aad035235ae6e390b78e6e0d410.zip
Fix array stripping with patch from Chet #60127
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/ChangeLog9
-rw-r--r--app-shells/bash/Manifest3
-rw-r--r--app-shells/bash/bash-3.0-r5.ebuild (renamed from app-shells/bash/bash-3.0-r4.ebuild)9
-rw-r--r--app-shells/bash/files/bash-3.0-array-stripping.patch14
-rw-r--r--app-shells/bash/files/digest-bash-3.0-r5 (renamed from app-shells/bash/files/digest-bash-3.0-r4)0
5 files changed, 32 insertions, 3 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 1597b023f0a0..2fc1448df87a 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.48 2004/08/14 03:10:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.49 2004/08/18 16:39:17 agriffis Exp $
+
+*bash-3.0-r5 (18 Aug 2004)
+
+ 18 Aug 2004; Aron Griffis <agriffis@gentoo.org>
+ +files/bash-3.0-array-stripping.patch, -bash-3.0-r4.ebuild,
+ +bash-3.0-r5.ebuild:
+ Fix array stripping with patch from Chet #60127
13 Aug 2004; Aron Griffis <agriffis@gentoo.org> files/bashrc:
Don't export PS1. Continuation of bug 26951, comments 60-62
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index b6a85457e755..2b7f955c509e 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -1,5 +1,6 @@
MD5 a3a5f5e1cfbb02d35f055dae074bf237 bash-3.0-r4.ebuild 4119
MD5 9b26b6899167a29ee4e9c1ad0d39b5a1 bash-2.05b-r9.ebuild 2909
+MD5 1313689f9d680b87e209f860a5a17bdb bash-3.0-r5.ebuild 4387
MD5 74109346a9d73cfcbdc241f97e154c97 ChangeLog 10247
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 6a2f5ace1a2dd30b1bee55eba1509027 bash-2.05b-r10.ebuild 3041
@@ -9,8 +10,10 @@ MD5 694b8b1e47e4743e78ee5f7515f76542 files/bash-3.0-posixtrap.patch 789
MD5 bf31cdbb653a9ad17112633172d243be files/bashrc 948
MD5 4383b25cd54b24b9f459e338f06d096c files/bash-2.05b-parallel-build.patch 459
MD5 582fb9ed0ca44627978ce6836a5000dc files/config-top.h.diff 487
+MD5 96238e7d942d091ca71574ba7392e847 files/bash-3.0-array-stripping.patch 294
MD5 0392b634a7a02302d24ccc4a4b349423 files/bash-3.0-local-array.patch 275
MD5 30a9ff1b688e79f59376a47d882f3419 files/digest-bash-3.0-r4 128
+MD5 30a9ff1b688e79f59376a47d882f3419 files/digest-bash-3.0-r5 128
MD5 28c9d7407d5332c29dddb656a4a1f1ce files/bash-3.0-invisible.patch 705
MD5 1894aaae72806c410d851d046d13dd32 files/digest-bash-2.05b-r10 461
MD5 1894aaae72806c410d851d046d13dd32 files/digest-bash-2.05b-r9 461
diff --git a/app-shells/bash/bash-3.0-r4.ebuild b/app-shells/bash/bash-3.0-r5.ebuild
index 9cbff2de90d9..926cd4b4a2a3 100644
--- a/app-shells/bash/bash-3.0-r4.ebuild
+++ b/app-shells/bash/bash-3.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r4.ebuild,v 1.1 2004/08/02 19:23:44 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r5.ebuild,v 1.1 2004/08/18 16:39:17 agriffis Exp $
inherit eutils flag-o-matic gnuconfig
@@ -54,7 +54,8 @@ src_unpack() {
epatch ${FILESDIR}/${P}-posixtrap.patch
# Patch display.c so that only invisible characters actually on the first
- # line are counted in it
+ # line are counted in it. (This patch doesn't fix everything and Chet says
+ # he has a better patch... so watch for it in bash-3.0.1)
epatch ${FILESDIR}/${P}-invisible.patch
# Patch readline's bind.c so that /etc/inputrc is read as a last resort
@@ -68,6 +69,10 @@ src_unpack() {
# to fix bug 58961 (segfault on local arrays)
epatch ${FILESDIR}/${P}-local-array.patch
+ # Chet Ramey (upstream maintainer) provided this patch to solve
+ # bug 60127 (bash 3 breaks array stripping)
+ epatch ${FILESDIR}/${P}-array-stripping.patch
+
# Enable SSH_SOURCE_BASHRC (#24762)
echo '#define SSH_SOURCE_BASHRC' >> config-top.h
diff --git a/app-shells/bash/files/bash-3.0-array-stripping.patch b/app-shells/bash/files/bash-3.0-array-stripping.patch
new file mode 100644
index 000000000000..a53aa98a7898
--- /dev/null
+++ b/app-shells/bash/files/bash-3.0-array-stripping.patch
@@ -0,0 +1,14 @@
+*** ../bash-3.0/subst.c Sun Jul 4 13:56:13 2004
+--- subst.c Thu Aug 12 13:36:17 2004
+***************
+*** 4892,4896 ****
+ *e1p += len;
+
+! if (*e1p >= len || *e1p < 0)
+ return (-1);
+
+--- 4912,4916 ----
+ *e1p += len;
+
+! if (*e1p > len || *e1p < 0)
+ return (-1);
diff --git a/app-shells/bash/files/digest-bash-3.0-r4 b/app-shells/bash/files/digest-bash-3.0-r5
index b3fb57628169..b3fb57628169 100644
--- a/app-shells/bash/files/digest-bash-3.0-r4
+++ b/app-shells/bash/files/digest-bash-3.0-r5