summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-02-17 23:10:31 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-02-17 23:10:31 +0000
commitb17f6692178b0193e8fc5d1a7bfeb86b50eb43ad (patch)
treef4e30e3bc119cd4b8c309fc122c9274e34ccf51c /app-shells/mpibash
parentVersion bump, adds support for cintiq companion (bug #540204, thanks to Chand... (diff)
downloadgentoo-2-b17f6692178b0193e8fc5d1a7bfeb86b50eb43ad.tar.gz
gentoo-2-b17f6692178b0193e8fc5d1a7bfeb86b50eb43ad.tar.bz2
gentoo-2-b17f6692178b0193e8fc5d1a7bfeb86b50eb43ad.zip
added live version
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'app-shells/mpibash')
-rw-r--r--app-shells/mpibash/ChangeLog7
-rw-r--r--app-shells/mpibash/mpibash-9999.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-shells/mpibash/ChangeLog b/app-shells/mpibash/ChangeLog
index 643d58d1eb84..8f680a36f5cd 100644
--- a/app-shells/mpibash/ChangeLog
+++ b/app-shells/mpibash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/mpibash
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/ChangeLog,v 1.1 2015/02/13 23:26:09 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/ChangeLog,v 1.2 2015/02/17 23:10:31 ottxor Exp $
+
+*mpibash-9999 (17 Feb 2015)
+
+ 17 Feb 2015; Christoph Junghans <ottxor@gentoo.org> +mpibash-9999.ebuild:
+ added live version
*mpibash-1.1 (13 Feb 2015)
diff --git a/app-shells/mpibash/mpibash-9999.ebuild b/app-shells/mpibash/mpibash-9999.ebuild
new file mode 100644
index 000000000000..56644f654c2d
--- /dev/null
+++ b/app-shells/mpibash/mpibash-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/mpibash-9999.ebuild,v 1.1 2015/02/17 23:10:31 ottxor Exp $
+
+EAPI=5
+
+inherit autotools multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/losalamos/MPI-Bash.git http://github.com/losalamos/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/losalamos/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/losalamos/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ [[ "${PV}" = 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf --with-bashdir="${EPREFIX}"/usr/include/bash-plugins \
+ --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
+}
+
+src_install() {
+ default
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}