summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 20:55:03 +0000
commit541f14235634ec9414e89e8089beca533ffca899 (patch)
tree86d726368da8d5082e4e7b43278d3a356de0605c /app-shells
parent*** empty log message *** (diff)
downloadgentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.gz
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.tar.bz2
gentoo-2-541f14235634ec9414e89e8089beca533ffca899.zip
*** empty log message ***
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pdksh/files/digest-pdksh-5.2.14-r22
-rw-r--r--app-shells/pdksh/pdksh-5.2.14-r2.ebuild43
-rw-r--r--app-shells/tcsh/files/digest-tcsh-6.101
-rw-r--r--app-shells/tcsh/tcsh-6.10.ebuild32
4 files changed, 78 insertions, 0 deletions
diff --git a/app-shells/pdksh/files/digest-pdksh-5.2.14-r2 b/app-shells/pdksh/files/digest-pdksh-5.2.14-r2
new file mode 100644
index 000000000000..82565d42669d
--- /dev/null
+++ b/app-shells/pdksh/files/digest-pdksh-5.2.14-r2
@@ -0,0 +1,2 @@
+MD5 871106b3bd937e1afba9f2ef7c43aef3 pdksh-5.2.14.tar.gz
+MD5 c91364eb3de43a052c53d263000fe14c pdksh-5.2.14-patches.1
diff --git a/app-shells/pdksh/pdksh-5.2.14-r2.ebuild b/app-shells/pdksh/pdksh-5.2.14-r2.ebuild
new file mode 100644
index 000000000000..ba2ddf0fae44
--- /dev/null
+++ b/app-shells/pdksh/pdksh-5.2.14-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r2.ebuild,v 1.1 2000/11/26 20:54:17 achim Exp $
+
+P=pdksh-5.2.14
+A="${P}.tar.gz ${P}-patches.1"
+S=${WORKDIR}/${P}
+DESCRIPTION="The Public Domain Korn Shell"
+SRC_URI="ftp://ftp.cs.mun.ca/pub/pdksh/${P}.tar.gz
+ ftp://ftp.cs.mun.ca/pub/pdksh/${P}-patches.1"
+HOMEPAGE="http://ww.cs.mun.ca/~michael/pdksh/"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ patch -p2 < ${DISTDIR}/${P}-patches.1
+}
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin ksh
+ into /usr
+ doman ksh.1
+ dodoc BUG-REPORTS ChangeLog* CONTRIBUTORS LEGAL NEWS NOTES PROJECTS README
+ docinto etc
+ dodoc etc/*
+}
+
+
+
+
+
+
diff --git a/app-shells/tcsh/files/digest-tcsh-6.10 b/app-shells/tcsh/files/digest-tcsh-6.10
new file mode 100644
index 000000000000..a75616c35624
--- /dev/null
+++ b/app-shells/tcsh/files/digest-tcsh-6.10
@@ -0,0 +1 @@
+MD5 f459c423074d85dfaa55439eb908a053 tcsh-6.10.tar.gz
diff --git a/app-shells/tcsh/tcsh-6.10.ebuild b/app-shells/tcsh/tcsh-6.10.ebuild
new file mode 100644
index 000000000000..a3d6efe6fc57
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10.ebuild,v 1.1 2000/11/26 20:54:17 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}.00
+DESCRIPTION="The standard GNU Bourne again shell"
+#ugh, astron.com doesn't support passive ftp... maybe another source?
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/"${A}
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/ --mandir=/usr/man --host=${CHOST}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install install.man
+ try perl tcsh.man2html
+ dosym tcsh /bin/csh
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+ docinto html
+ dodoc tcsh.html/*.html
+}
+
+
+