summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-19 15:34:05 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-19 15:34:05 +0000
commit59bcba2c1845f5c965f8b0c8979c0b1abcded450 (patch)
tree2ca6b82b48eaae5f6d519738e07f983606d3257b /app-shells
parentversion bump (diff)
downloadgentoo-2-59bcba2c1845f5c965f8b0c8979c0b1abcded450.tar.gz
gentoo-2-59bcba2c1845f5c965f8b0c8979c0b1abcded450.tar.bz2
gentoo-2-59bcba2c1845f5c965f8b0c8979c0b1abcded450.zip
hhm, i though repoman would do this for me...
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/bash-completion-20020619.ebuild44
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-200206191
2 files changed, 45 insertions, 0 deletions
diff --git a/app-shells/bash-completion/bash-completion-20020619.ebuild b/app-shells/bash-completion/bash-completion-20020619.ebuild
new file mode 100644
index 000000000000..8c7eba8b52ec
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20020619.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# Author: Thilo Bangert <bangert@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20020619.ebuild,v 1.1 2002/06/19 15:34:05 bangert Exp $
+
+S=${WORKDIR}/bash_completion
+
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.gz"
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+
+RDEPEND=">=sys-apps/bash-2.05a"
+
+LICENSE="GPL-2"
+
+src_install () {
+
+ insinto /etc
+ doins bash_completion
+
+ insinto /etc/bash_completion.d
+
+ doins contrib/dict
+ doins contrib/harbour
+ doins contrib/isql
+ doins contrib/larch
+ doins contrib/lilypond
+ doins contrib/p4
+ doins contrib/ri
+
+ doins ${FILESDIR}/gentoo.completion
+
+ dodoc COPYING Changelog README
+
+}
+
+pkg_postinst() {
+
+ echo
+ einfo "See /usr/share/doc/${P}/README.gz on how to "
+ einfo "add completion support to your bash"
+ echo
+
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20020619 b/app-shells/bash-completion/files/digest-bash-completion-20020619
new file mode 100644
index 000000000000..3720456ac300
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20020619
@@ -0,0 +1 @@
+MD5 e2f462c5ca695c76001a89665a881edd bash-completion-20020619.tar.gz 55821