summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-09-11 17:48:16 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-09-11 17:48:16 +0000
commit7ef0bb3141c37923c4350082c2c800ea07b285f0 (patch)
tree065687c9c83d2b296aa4194d3f8183fe8b0e96c8 /app-shells
parenttaking package mask out of uclibc/embeded/hardened profiles (diff)
downloadgentoo-2-7ef0bb3141c37923c4350082c2c800ea07b285f0.tar.gz
gentoo-2-7ef0bb3141c37923c4350082c2c800ea07b285f0.tar.bz2
gentoo-2-7ef0bb3141c37923c4350082c2c800ea07b285f0.zip
version bump; updated ebuild to use versionator.eclass
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/ChangeLog8
-rw-r--r--app-shells/dash/Manifest2
-rw-r--r--app-shells/dash/dash-0.5.1.3.ebuild40
-rw-r--r--app-shells/dash/files/digest-dash-0.5.1.32
-rw-r--r--app-shells/dash/metadata.xml4
5 files changed, 53 insertions, 3 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index 69da3ddbaeb8..32a052a44c76 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/dash
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.6 2004/08/20 23:04:50 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.7 2004/09/11 17:48:16 ka0ttic Exp $
+
+*dash-0.5.1.3 (11 Sep 2004)
+
+ 11 Sep 2004; Aaron Walker <ka0ttic@gentoo.org> metadata.xml,
+ +dash-0.5.1.3.ebuild:
+ version bump; updated ebuild to use versionator.eclass
*dash-0.5.1.1 (20 Aug 2004)
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
index f538bb469342..ecc93fbe847e 100644
--- a/app-shells/dash/Manifest
+++ b/app-shells/dash/Manifest
@@ -1,4 +1,5 @@
MD5 0599f1e3d5806b2ab0868a9052adca32 dash-0.5.1.1.ebuild 894
+MD5 3529812146beb83ebca4aa6f6551458a dash-0.5.1.3.ebuild 887
MD5 5e5b37401da2dfbb9a1a91af9237fb61 dash-0.4.24.ebuild 958
MD5 cc94088dd92b7d82b897a9d1e15ffe8a dash-0.4.26.ebuild 967
MD5 e33c386d4b67ef074ecba2dbcf0d6323 ChangeLog 1058
@@ -6,3 +7,4 @@ MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 cdb2616f7107463468dc542ffb5c0afe files/digest-dash-0.4.24 63
MD5 350944019b93cf21a674780be34264aa files/digest-dash-0.4.26 63
MD5 115b4f38170f7c82c6c9e3259c55108c files/digest-dash-0.5.1.1 131
+MD5 789070e5451f8e3151926438cfb4744b files/digest-dash-0.5.1.3 131
diff --git a/app-shells/dash/dash-0.5.1.3.ebuild b/app-shells/dash/dash-0.5.1.3.ebuild
new file mode 100644
index 000000000000..33acf8f649ca
--- /dev/null
+++ b/app-shells/dash/dash-0.5.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.1.3.ebuild,v 1.1 2004/09/11 17:48:16 ka0ttic Exp $
+
+inherit eutils versionator
+
+IUSE=""
+
+DEB_P="${PN}_$(replace_version_separator 3 '-')"
+MY_P2="${DEB_P%-*}"
+MY_P=${MY_P2/_/-}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
+SRC_URI="mirror://debian/pool/main/d/dash/${MY_P2}.orig.tar.gz \
+ mirror://debian/pool/main/d/dash/${DEB_P}.diff.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="sys-devel/pmake
+ sys-apps/sed
+ dev-util/yacc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${DEB_P}.diff
+}
+
+src_install() {
+ exeinto /bin
+ newexe src/dash dash
+
+ newman src/dash.1 dash.1
+
+ dodoc COPYING debian/changelog
+}
diff --git a/app-shells/dash/files/digest-dash-0.5.1.3 b/app-shells/dash/files/digest-dash-0.5.1.3
new file mode 100644
index 000000000000..d50e49379717
--- /dev/null
+++ b/app-shells/dash/files/digest-dash-0.5.1.3
@@ -0,0 +1,2 @@
+MD5 8bcc29c879d053fcb9301ccf6fe373ac dash_0.5.1.orig.tar.gz 227723
+MD5 9e9616bb238475bff3cccd6b1f3e5a26 dash_0.5.1-3.diff.gz 20029
diff --git a/app-shells/dash/metadata.xml b/app-shells/dash/metadata.xml
index d8b96be3c5cd..d31152aca840 100644
--- a/app-shells/dash/metadata.xml
+++ b/app-shells/dash/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>bug-wranglers@gentoo.org</email>
- <description>This package lacks a primary herd or maintainer.</description>
+ <email>ka0ttic@gentoo.org</email>
+ <name>Aaron Walker</name>
</maintainer>
</pkgmetadata>