summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-06-23 21:49:22 +0000
committerJon Hood <squinky86@gentoo.org>2004-06-23 21:49:22 +0000
commit23c0fab8034045d7c0e28a3cb8b3eaa3b05eea7d (patch)
tree09b3467b790fe5f86b17c9c1ad5d6b61f1967944 /app-text/bibletime/bibletime-1.4.2_pre1.ebuild
parentversion bump, fixes #48523 (Manifest recommit) (diff)
downloadgentoo-2-23c0fab8034045d7c0e28a3cb8b3eaa3b05eea7d.tar.gz
gentoo-2-23c0fab8034045d7c0e28a3cb8b3eaa3b05eea7d.tar.bz2
gentoo-2-23c0fab8034045d7c0e28a3cb8b3eaa3b05eea7d.zip
version bump to fix #48523
Diffstat (limited to 'app-text/bibletime/bibletime-1.4.2_pre1.ebuild')
-rw-r--r--app-text/bibletime/bibletime-1.4.2_pre1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-text/bibletime/bibletime-1.4.2_pre1.ebuild b/app-text/bibletime/bibletime-1.4.2_pre1.ebuild
new file mode 100644
index 000000000000..e4354cf94e18
--- /dev/null
+++ b/app-text/bibletime/bibletime-1.4.2_pre1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.4.2_pre1.ebuild,v 1.1 2004/06/23 21:49:22 squinky86 Exp $
+
+inherit kde
+need-kde 3
+
+IUSE="curl"
+DESCRIPTION="BibleTime KDE Bible study application using the SWORD library."
+HOMEPAGE="http://bibletime.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+# temporary ebuild to fix #48523
+KEYWORDS="~x86 ~ppc"
+newdepend ">=app-text/sword-1.5.8_pre1
+ >=net-misc/curl-7.10"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ ./autogen.sh
+}
+
+pkg_preinst() {
+ if ! use curl ; then
+ ewarn
+ ewarn "You do not have \"curl\" support enabled in your USE variable."
+ ewarn "This means SWORD may not have been compiled with curl support."
+ ewarn "If you wish to use BibleTime's ability to download modules"
+ ewarn "straight from the SWORD website, please add \"curl\" to your"
+ ewarn "USE variable in /etc/make.conf or make sure app-text/sword was"
+ ewarn "compiled with support for curl:"
+ ewarn " USE=\"curl\" emerge sword"
+ ewarn "Press ctrl+c to abort the merge of BibleTime if you want to"
+ ewarn "recompile SWORD with curl support."
+ ewarn
+ for TICKER in 1 2 3 4 5; do
+ echo -ne "\a" ; sleep 0.1 &>/dev/null ; sleep 0,1 &>/dev/null
+ echo -ne "\a" ; sleep 1
+ done
+ sleep 8
+ fi
+}
+
+pkg_postinst() {
+ if use curl ; then
+ einfo
+ einfo "To use BibleTime's ability to install modules from"
+ einfo "The SWORD Project's website, make sure that SWORD"
+ einfo "was compiled with curl support, either by making"
+ einfo "sure the \"curl\" USE flag is set in /etc/make.conf"
+ einfo "or by installing SWORD with:"
+ einfo " USE=\"curl\" emerge sword"
+ einfo
+ fi
+}