summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 10:09:41 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 10:09:41 +0000
commit354cf9b5b38bae6093e79e23d53a9e6cf2566398 (patch)
tree686693ceef3276a4434d1b1164d4e2c1aa494be5 /app-text/pinfo/pinfo-0.6.8.ebuild
parent(no commit message) (diff)
downloadgentoo-2-354cf9b5b38bae6093e79e23d53a9e6cf2566398.tar.gz
gentoo-2-354cf9b5b38bae6093e79e23d53a9e6cf2566398.tar.bz2
gentoo-2-354cf9b5b38bae6093e79e23d53a9e6cf2566398.zip
*** empty log message ***
Diffstat (limited to 'app-text/pinfo/pinfo-0.6.8.ebuild')
-rw-r--r--app-text/pinfo/pinfo-0.6.8.ebuild25
1 files changed, 9 insertions, 16 deletions
diff --git a/app-text/pinfo/pinfo-0.6.8.ebuild b/app-text/pinfo/pinfo-0.6.8.ebuild
index d7fede75412a..38da14880c12 100644
--- a/app-text/pinfo/pinfo-0.6.8.ebuild
+++ b/app-text/pinfo/pinfo-0.6.8.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.8.ebuild,v 1.1 2003/08/29 23:47:01 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pinfo/pinfo-0.6.8.ebuild,v 1.1.1.1 2005/11/30 10:06:49 chriswhite Exp $
MY_P=${PN}-${PV/_/}
S=${WORKDIR}/${MY_P}
DESCRIPTION="Hypertext info and man viewer based on (n)curses"
-SRC_URI="http://dione.ids.pl/~pborys/software/pinfo/pinfo-${PV}.tar.gz"
HOMEPAGE="http://dione.ids.pl/~pborys/pinfo"
+SRC_URI="http://dione.ids.pl/~pborys/software/pinfo/pinfo-${PV}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ~ppc sparc "
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
IUSE="nls readline"
DEPEND="sys-libs/ncurses
@@ -18,17 +18,10 @@ DEPEND="sys-libs/ncurses
nls? ( sys-devel/gettext )"
src_compile() {
- local myconf
-
- use readline \
- && myconf="${myconf} --with-readline" \
- || myconf="${myconf} --without-readline"
-
- use nls \
- && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
-
- econf ${myconf}
+ econf \
+ $(use_with readline) \
+ $(use_enable nls) \
+ || die "econf failed"
emake || die
}