summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-05-22 14:38:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-05-22 14:38:23 +0000
commitaeb442e2d87bced3103bf046546d036ddb548915 (patch)
tree26912a190b18823be5c7b4b52c1027584d631d5c /app-text/t1utils
parentarm/ia64//s390/sh stable wrt #268858 (diff)
downloadgentoo-2-aeb442e2d87bced3103bf046546d036ddb548915.tar.gz
gentoo-2-aeb442e2d87bced3103bf046546d036ddb548915.tar.bz2
gentoo-2-aeb442e2d87bced3103bf046546d036ddb548915.zip
fix build with glibc 2.10, getline conflicts, bug #270611, by Honza Macháček
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-text/t1utils')
-rw-r--r--app-text/t1utils/ChangeLog9
-rw-r--r--app-text/t1utils/files/t1utils-1.34-glibc-2.10.patch29
-rw-r--r--app-text/t1utils/t1utils-1.34.ebuild10
3 files changed, 45 insertions, 3 deletions
diff --git a/app-text/t1utils/ChangeLog b/app-text/t1utils/ChangeLog
index 04fe728f5492..34f16e086ba7 100644
--- a/app-text/t1utils/ChangeLog
+++ b/app-text/t1utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/t1utils
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/t1utils/ChangeLog,v 1.46 2009/04/16 08:48:55 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/t1utils/ChangeLog,v 1.47 2009/05/22 14:38:23 aballier Exp $
+
+ 22 May 2009; Alexis Ballier <aballier@gentoo.org> t1utils-1.34.ebuild,
+ +files/t1utils-1.34-glibc-2.10.patch:
+ fix build with glibc 2.10, getline conflicts, bug #270611, by Honza
+ Macháček
16 Apr 2009; Alexis Ballier <aballier@gentoo.org> t1utils-1.34.ebuild:
block old freetype:1, they collide, bug #266186
diff --git a/app-text/t1utils/files/t1utils-1.34-glibc-2.10.patch b/app-text/t1utils/files/t1utils-1.34-glibc-2.10.patch
new file mode 100644
index 000000000000..c909c3e56d22
--- /dev/null
+++ b/app-text/t1utils/files/t1utils-1.34-glibc-2.10.patch
@@ -0,0 +1,29 @@
+--- t1utils-1.34/t1asm.c 2008-03-01 17:59:11.000000000 +0000
++++ t1utils-1.34/t1asm.c 2009-05-21 07:47:28.489113686 +0000
+@@ -280,7 +280,7 @@
+ the newline is put into line[]. When terminated by '{', the '{' is not put
+ into line[], and the flag start_charstring is set to 1. */
+
+-static void getline()
++static void t_getline()
+ {
+ int c;
+ char *p = line;
+@@ -721,7 +721,7 @@
+ without /Subrs sections and provided a patch. */
+
+ while (!feof(ifp) && !ferror(ifp)) {
+- getline();
++ t_getline();
+
+ if (!ever_active) {
+ if (strncmp(line, "currentfile eexec", 17) == 0 && isspace(line[17])) {
+@@ -792,7 +792,7 @@
+
+ /* There may be additional code. */
+ while (!feof(ifp) && !ferror(ifp)) {
+- getline();
++ t_getline();
+ eexec_string(line);
+ }
+
diff --git a/app-text/t1utils/t1utils-1.34.ebuild b/app-text/t1utils/t1utils-1.34.ebuild
index 7abae4d68594..78b8e3428989 100644
--- a/app-text/t1utils/t1utils-1.34.ebuild
+++ b/app-text/t1utils/t1utils-1.34.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/t1utils/t1utils-1.34.ebuild,v 1.11 2009/04/16 08:48:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/t1utils/t1utils-1.34.ebuild,v 1.12 2009/05/22 14:38:23 aballier Exp $
+
+inherit eutils
IUSE=""
@@ -15,6 +17,12 @@ DEPEND="virtual/libc"
RDEPEND="${DEPEND}
!<media-libs/freetype-1.4_pre20080316"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/t1utils-1.34-glibc-2.10.patch
+}
+
src_install () {
emake DESTDIR="${D}" install || die "make install failed"
dodoc NEWS README