summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-10-02 14:04:33 +0000
committerMamoru Komachi <usata@gentoo.org>2003-10-02 14:04:33 +0000
commit4aef553d275fd761060771c562faf7ec3fa6478d (patch)
treea0142ea4a61110a472f00fb1ba16dc1474592846 /app-text/yodl/yodl-1.31.18.ebuild
parentNew ebuild. This closes Bug #18726 (diff)
downloadgentoo-2-4aef553d275fd761060771c562faf7ec3fa6478d.tar.gz
gentoo-2-4aef553d275fd761060771c562faf7ec3fa6478d.tar.bz2
gentoo-2-4aef553d275fd761060771c562faf7ec3fa6478d.zip
New ebuild. This closes Bug #18726
Diffstat (limited to 'app-text/yodl/yodl-1.31.18.ebuild')
-rw-r--r--app-text/yodl/yodl-1.31.18.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-text/yodl/yodl-1.31.18.ebuild b/app-text/yodl/yodl-1.31.18.ebuild
new file mode 100644
index 000000000000..2a7c3031a7af
--- /dev/null
+++ b/app-text/yodl/yodl-1.31.18.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/yodl/yodl-1.31.18.ebuild,v 1.1 2003/10/02 14:04:27 usata Exp $
+
+inherit eutils
+
+IUSE=""
+
+HOMEPAGE="http://www.xs4all.nl/~jantien/yodl/"
+SRC_URI="ftp://ftp.lilypond.org/pub/yodl/development/${P}.tar.gz"
+DESCRIPTION="Yet oneOther Document Language"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ sys-apps/diffutils
+ sys-apps/groff
+ dev-lang/python
+ sys-apps/texinfo"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S} || die "pre-patch chdir failed"
+ epatch "${FILESDIR}/bison-configure.patch"
+ #use ia64 && epatch "${FILESDIR}/${P}-compile-fix-ia64.patch"
+ epatch "${FILESDIR}/${P}-debian.patch"
+}
+
+src_compile() {
+ # Avoid a makefile bug if this var is already defined in the environment.
+ unset NAME
+
+ # The auto-dependencies break if ccache is used (for the first compile).
+ export CCACHE_DISABLE=yes
+ econf --datadir=/usr/share/yodl || die "econf failed"
+ make || die "make failed"
+
+ cd Documentation
+ make info || die "make info failed"
+}
+
+src_install() {
+ make prefix="${D}/usr" \
+ datadir="${D}/usr/share/yodl" \
+ mandir="${D}/usr/share/man" \
+ infodir="${D}/usr/share/info" \
+ install || die
+
+ doinfo Documentation/out/*.info*
+ dodoc ANNOUNCE-1.22 ChangeLog-1.22 CHANGES TODO VERSION *.txt
+}