summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-12 17:04:52 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-12 17:04:52 +0000
commit7cf1b1e074a86baf5cfa9f4039d9cdd0941c6cd6 (patch)
tree12cd0c76d2186e5336535423c5517be6667ae887 /app-text
parentsomehow my patch to fix the -f problem got removed. This ebuild has that fix... (diff)
downloadgentoo-2-7cf1b1e074a86baf5cfa9f4039d9cdd0941c6cd6.tar.gz
gentoo-2-7cf1b1e074a86baf5cfa9f4039d9cdd0941c6cd6.tar.bz2
gentoo-2-7cf1b1e074a86baf5cfa9f4039d9cdd0941c6cd6.zip
used perl wrapper script so it should be safer to use
Diffstat (limited to 'app-text')
-rw-r--r--app-text/acroread/ChangeLog14
-rw-r--r--app-text/acroread/acroread-5.05-r5.ebuild4
-rw-r--r--app-text/acroread/acroread-5.05-r6.ebuild73
-rw-r--r--app-text/acroread/files/acroread43
-rw-r--r--app-text/acroread/files/digest-acroread-5.05-r61
5 files changed, 131 insertions, 4 deletions
diff --git a/app-text/acroread/ChangeLog b/app-text/acroread/ChangeLog
index 304412281836..91dfd1709db6 100644
--- a/app-text/acroread/ChangeLog
+++ b/app-text/acroread/ChangeLog
@@ -1,8 +1,18 @@
# ChangeLog for app-text/acroread
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.9 2002/07/07 22:54:12 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.10 2002/07/12 17:04:52 seemant Exp $
-*acroread-5.05-r4 (07 Jul 2002)
+*acroread-5.05-r6 (12 Jul 2002)
+
+ 12 Jul 2002; Seemant Kulleen <seemant@gentoo.org> acroread-5.05-r6.ebuild
+ files/acroread files/digest-acroread-5.05-r6 :
+
+ Used perl wrapper script from securityfocus around this. It is safe from
+ the security bug now, at least somewhat. Suggested by:
+ danielsabo@myrealbox.com (Daniel Sabo) in bug $4688. This package will
+ also be masked.
+
+*acroread-5.05-r5 (07 Jul 2002)
07 Jul 2002; Seemant Kulleen <seemant@gentoo.org> acroread-5.05-r5.ebuild
files/digest-acroread-5.05-r5 :
diff --git a/app-text/acroread/acroread-5.05-r5.ebuild b/app-text/acroread/acroread-5.05-r5.ebuild
index 1805bf43fe69..46a093084671 100644
--- a/app-text/acroread/acroread-5.05-r5.ebuild
+++ b/app-text/acroread/acroread-5.05-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-5.05-r5.ebuild,v 1.1 2002/07/07 22:54:12 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-5.05-r5.ebuild,v 1.2 2002/07/12 17:04:52 seemant Exp $
MY_P=linux-${PV/./}
S=${WORKDIR}
@@ -13,7 +13,7 @@ RDEPEND=">=app-text/xpdf-1.01"
LICENSE="Adobe"
-SLOT=""
+SLOT="0"
KEYWORDS="x86"
INSTALLDIR=/opt/Acrobat5
diff --git a/app-text/acroread/acroread-5.05-r6.ebuild b/app-text/acroread/acroread-5.05-r6.ebuild
new file mode 100644
index 000000000000..2bf83f0a0cdd
--- /dev/null
+++ b/app-text/acroread/acroread-5.05-r6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-5.05-r6.ebuild,v 1.1 2002/07/12 17:04:52 seemant Exp $
+
+MY_P=linux-${PV/./}
+S=${WORKDIR}
+DESCRIPTION="Adobe's PDF reader"
+SRC_URI="ftp://ftp.adobe.com/pub/adobe/acrobatreader/unix/5.x/${MY_P}.tar.gz"
+HOMEPAGE="http://www.adobe.com/products/acrobat/"
+
+DEPEND="virtual/glibc"
+RDEPEND="sys-devel/perl"
+
+LICENSE="Adobe"
+SLOT="0"
+KEYWORDS="x86"
+
+INSTALLDIR=/opt/Acrobat5
+
+pkg_setup() {
+
+ ewarn "Acroread has a MAJOR security flaw, and will thus not be"
+ ewarn "installed. Rather, ghostview is the recommended application"
+ ewarn "to read pdf documents."
+ ewarn "For further details, please consult"
+ ewarn "http://online.securityfocus.com/archive/1/278984"
+ ewarn "for your safety, a wrapper script obtained from the above"
+ ewarn "website will be used"
+}
+
+src_compile () {
+
+ tar xvf LINUXRDR.TAR
+ tar xvf COMMON.TAR
+
+ sed -e "s:REPLACE_ME:${INSTALLDIR}/Reader:" \
+ bin/acroread.sh > acroread
+}
+
+src_install () {
+
+ dodir ${INSTALLDIR}
+ for i in Browsers Reader Resource
+ do
+ chown -R root.root ${i}
+ cp -a ${i} ${D}${INSTALLDIR}
+ done
+
+ mv acroread acroread.real
+ exeinto ${INSTALLDIR}
+ doexe acroread.real
+
+ # wrapper script
+ exeinto ${INSTALLDIR}
+ doexe ${FILESDIR}/acroread
+
+ dodoc README LICREAD.TXT MANIFEST
+ dodir /opt/netscape/plugins
+ dosym ${INSTALLDIR}/Browsers/intellinux/nppdf.so /opt/netscape/plugins
+
+ #dynamic environment by T.Henderson@cs.ucl.ac.uk (Tristan Henderson)
+ dodir /etc/env.d
+ echo -e "PATH=${INSTALLDIR}\nROOTPATH=${INSTALLDIR}" > \
+ ${D}/etc/env.d/10acroread5
+
+ #mozilla compatibility contributed by m3thos@netcabo.pt(Miguel Sousa Filipe)
+ use mozilla && ( \
+ dodir /usr/lib/mozilla/plugins
+ dosym \
+ ${INSTALLDIR}/Browsers/intellinux/nppdf.so \
+ /usr/lib/mozilla/plugins/nppdf.so
+ )
+}
diff --git a/app-text/acroread/files/acroread b/app-text/acroread/files/acroread
new file mode 100644
index 000000000000..98f1f83ae9e0
--- /dev/null
+++ b/app-text/acroread/files/acroread
@@ -0,0 +1,43 @@
+#!/usr/bin/perl --
+
+$PROG = '/usr/share/Acrobat/505/bin/acroread.real';
+$TMPF = "/tmp/AdobeFnt06.lst.$<";
+$MYTD = "$ENV{'HOME'}/.acrobat";
+$MYTF = "$MYTD/AdobeFnt06.lst.$<";
+
+$ENV{'TMPDIR'} = $MYTD;
+
+use Fcntl;
+
+sub checkfix {
+ my ($nam, $msg) = @_;
+ ($dev,$ino,$mode,$nlink,$uid,$gid,@rest) = lstat( $nam );
+ ( -f _ and ! -l _ and ! -d _ ) or die "$msg: $nam is not a file\n";
+ # BEWARE: on some systems, $gid comes from directory
+ ( $uid == $< and $gid == $( ) or die "$msg: $nam is not your own\n";
+ ( $nlink == 1 ) or die "$msg: $nam has hardlinks\n";
+ chmod( 0600, $nam ) or die "$msg: cannot chmod $nam\n";
+}
+
+$< > 99 or die "No daemons\n";
+
+sysopen( F, $TMPF, O_RDWR|O_CREAT|O_EXCL, 0600 )
+ and close( F )
+ #and print "Pre-created $TMPF\n"
+ ;
+
+mkdir( $MYTD, 0700 )
+ #and print "Pre-created $MYTD\n"
+ ;
+sysopen( F, $MYTF, O_RDWR|O_CREAT|O_EXCL, 0600 )
+ and close( F )
+ #and print "Pre-created $MYTF\n"
+ ;
+
+&checkfix( $TMPF, "Tricked" );
+&checkfix( $MYTF, "Tricked" );
+system( $PROG, @ARGV );
+&checkfix( $TMPF, "After acroread" );
+&checkfix( $MYTF, "After acroread" );
+
+#!#
diff --git a/app-text/acroread/files/digest-acroread-5.05-r6 b/app-text/acroread/files/digest-acroread-5.05-r6
new file mode 100644
index 000000000000..1b87e159ed8a
--- /dev/null
+++ b/app-text/acroread/files/digest-acroread-5.05-r6
@@ -0,0 +1 @@
+MD5 5c1cef0b5b1eb75ed01fefb3d6a88ce0 linux-505.tar.gz 9280449