summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-09-09 18:42:40 +0000
committerMike Frysinger <vapier@gentoo.org>2009-09-09 18:42:40 +0000
commit770ab3565874d2f7a83ca9dd6dfb0809c0ee72fc (patch)
tree4ac9d7930dddea43b4171f737326c255cf910bbe /app-text
parentUpdating the haskell-cabal eclass to support the CABAL_FEATURES nocabaldep (diff)
downloadgentoo-2-770ab3565874d2f7a83ca9dd6dfb0809c0ee72fc.tar.gz
gentoo-2-770ab3565874d2f7a83ca9dd6dfb0809c0ee72fc.tar.bz2
gentoo-2-770ab3565874d2f7a83ca9dd6dfb0809c0ee72fc.zip
Fix implicit wait() decl warning.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wdiff/ChangeLog6
-rw-r--r--app-text/wdiff/files/wdiff-0.5-headers.patch13
-rw-r--r--app-text/wdiff/wdiff-0.5-r2.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/app-text/wdiff/ChangeLog b/app-text/wdiff/ChangeLog
index d807a2267cf0..a4e9540b00d8 100644
--- a/app-text/wdiff/ChangeLog
+++ b/app-text/wdiff/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/wdiff
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/ChangeLog,v 1.31 2009/04/13 02:21:27 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/ChangeLog,v 1.32 2009/09/09 18:42:39 vapier Exp $
+
+ 09 Sep 2009; Mike Frysinger <vapier@gentoo.org> wdiff-0.5-r2.ebuild,
+ +files/wdiff-0.5-headers.patch:
+ Fix implicit wait() decl warning.
13 Apr 2009; Jeremy Olexa <darkside@gentoo.org> wdiff-0.5-r2.ebuild:
QA: respect CC, bug 243628
diff --git a/app-text/wdiff/files/wdiff-0.5-headers.patch b/app-text/wdiff/files/wdiff-0.5-headers.patch
new file mode 100644
index 000000000000..a91b1d4c1735
--- /dev/null
+++ b/app-text/wdiff/files/wdiff-0.5-headers.patch
@@ -0,0 +1,13 @@
+wdiff.c: In function ‘complete_input_program’:
+wdiff.c:916: warning: implicit declaration of function ‘wait’
+
+--- wdiff.c
++++ wdiff.c
+@@ -45,6 +45,7 @@
+ # include <stdlib.h>
+ #endif
+
++#include <sys/wait.h>
+ #include <ctype.h>
+ #include <stdio.h>
+
diff --git a/app-text/wdiff/wdiff-0.5-r2.ebuild b/app-text/wdiff/wdiff-0.5-r2.ebuild
index 288c48bcba63..109521155e4f 100644
--- a/app-text/wdiff/wdiff-0.5-r2.ebuild
+++ b/app-text/wdiff/wdiff-0.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/wdiff-0.5-r2.ebuild,v 1.18 2009/04/13 02:21:27 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/wdiff/wdiff-0.5-r2.ebuild,v 1.19 2009/09/09 18:42:39 vapier Exp $
inherit eutils toolchain-funcs
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${WORKDIR}"/${P}-gentoo.diff
+ epatch "${FILESDIR}"/${P}-headers.patch
epatch "${FILESDIR}"/${P}-segfault-fix.diff
epatch "${FILESDIR}"/${P}-avoid-wraps.diff
sed -i 's:-ltermcap:-lncurses:' configure