summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2003-11-30 02:41:34 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2003-11-30 02:41:34 +0000
commit7f687c74474f003105d0dedc321e38339905289b (patch)
tree1b66f2d81c80b8e567a753842d770236b337e713 /app-vim/vimspell
parentversion bump for dmwaters (diff)
downloadgentoo-2-7f687c74474f003105d0dedc321e38339905289b.tar.gz
gentoo-2-7f687c74474f003105d0dedc321e38339905289b.tar.bz2
gentoo-2-7f687c74474f003105d0dedc321e38339905289b.zip
version bump for dmwaters
Diffstat (limited to 'app-vim/vimspell')
-rw-r--r--app-vim/vimspell/ChangeLog7
-rw-r--r--app-vim/vimspell/Manifest4
-rw-r--r--app-vim/vimspell/files/digest-vimspell-1.701
-rw-r--r--app-vim/vimspell/vimspell-1.70.ebuild57
4 files changed, 66 insertions, 3 deletions
diff --git a/app-vim/vimspell/ChangeLog b/app-vim/vimspell/ChangeLog
index f59261a0cc4f..bb69a7244143 100644
--- a/app-vim/vimspell/ChangeLog
+++ b/app-vim/vimspell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/vimspell
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimspell/ChangeLog,v 1.1 2003/11/19 19:35:33 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimspell/ChangeLog,v 1.2 2003/11/30 02:41:29 ciaranm Exp $
+
+*vimspell-1.70 (30 Nov 2003)
+
+ 30 Nov 2003; Ciaran McCreesh <ciaranm@gentoo.org> vimspell-1.70.ebuild:
+ Version bump
*vimspell-1.68 (19 Nov 2003)
diff --git a/app-vim/vimspell/Manifest b/app-vim/vimspell/Manifest
index 752ee1cb5a04..8f82ec5f54a1 100644
--- a/app-vim/vimspell/Manifest
+++ b/app-vim/vimspell/Manifest
@@ -1,6 +1,6 @@
MD5 c46988920a91b396c62abb24653383eb vimspell-1.68.ebuild 2283
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
-MD5 2a94774f509da3fd7af765f7f586741f ChangeLog 349
-MD5 1fa222c0a1743c18241be196ad2552e1 vimspell-1.70.ebuild 2182
+MD5 27a529b2eaa752d6c9757a2f69a4a4f3 ChangeLog 469
+MD5 568f6e5b1819514e34d852d31447da49 vimspell-1.70.ebuild 2283
MD5 584de3c97924b0422303af4e46df9a0d files/digest-vimspell-1.68 65
MD5 6a4ee637c8498ba26e82c61844aa5e55 files/digest-vimspell-1.70 65
diff --git a/app-vim/vimspell/files/digest-vimspell-1.70 b/app-vim/vimspell/files/digest-vimspell-1.70
new file mode 100644
index 000000000000..709240e23d7d
--- /dev/null
+++ b/app-vim/vimspell/files/digest-vimspell-1.70
@@ -0,0 +1 @@
+MD5 43242d1877462076237baa39891bed0f vimspell-1.70.tar.bz2 16998
diff --git a/app-vim/vimspell/vimspell-1.70.ebuild b/app-vim/vimspell/vimspell-1.70.ebuild
new file mode 100644
index 000000000000..2cd049191776
--- /dev/null
+++ b/app-vim/vimspell/vimspell-1.70.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimspell/vimspell-1.70.ebuild,v 1.1 2003/11/30 02:41:29 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: on-the-fly spell checking with aspell"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=465"
+LICENSE="GPL-1 | GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+# In theory, this plugin supports either aspell or ispell. However,
+# virtual/spell has been removed by seemant in favour of just using
+# app-text/aspell:
+# 20:06 <@seemant> ciaranm: I think I might have removed it, come to
+# think of it, because I was on a kick to get everything converted
+# to aspell instead of ispell
+# 20:06 <@seemant> for the simple reason that ispell blows dogs
+# So we'll just force people to use aspell...
+RDEPEND="$RDEPEND app-text/aspell"
+
+function src_unpack() {
+ unpack ${A}
+ cd ${S}/plugin
+
+ # This plugin needs to be told which spell program to use. The default
+ # is hard-coded as 'ispell' in the plugin file. We can fix that with a
+ # bit of sed magic.
+ OLD_DEFAULT='s:SpellGetOption("spell_executable","ispell")'
+ NEW_DEFAULT='s:SpellGetOption("spell_executable","aspell")'
+ sed -e "s/$OLD_DEFAULT/$NEW_DEFAULT/g" \
+ -i vimspell.vim || die "default setting fix failed"
+
+ # This plugin also tries to install its own documentation automatically
+ # upon load. This breaks emerge unmerge, so we'll install the docs
+ # manually.
+ mkdir ${S}/doc || die
+ cd ${S}/doc
+ cp ${S}/plugin/vimspell.vim vimspell.txt
+
+ sed -e "1,/^=== \+START_DOC/d" \
+ -e "/^=== \+END_DOC/,\$d" \
+ -e "s/{{{[1-9]/ /g" \
+ -e "s/#version#/v${PV}/g" \
+ -i vimspell.txt || die "docs failed"
+ echo -ne "\n vim:tw=78:ts=8:ft=help:norl:\n" >> vimspell.txt
+
+ # Unfortunately, there's a rather large logic error in the documentation
+ # installation code. If vim can't write to /usr/share/vim/vimfiles/doc/
+ # then the plugin will try to install a copy of the docs locally, even if
+ # the global directory has an up-to-date copy. To get around this we'll
+ # make the SpellInstallDocumentation function do nothing.
+ cd ${S}/plugin
+ sed -e "/^function! s:SpellInstallDocumentation/a\ return 0" \
+ -i vimspell.vim || die "install fix failed"
+}
+