summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 16:01:17 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 16:01:17 +0000
commite537a235ea5c28d3630245b2c8d22c10e3ad10ba (patch)
treeccd865af25c2d5c77299d70b19eaa2c31e26c4c1 /dev-db/mysql++
parentneed eutils for epatch (diff)
downloadgentoo-2-e537a235ea5c28d3630245b2c8d22c10e3ad10ba.tar.gz
gentoo-2-e537a235ea5c28d3630245b2c8d22c10e3ad10ba.tar.bz2
gentoo-2-e537a235ea5c28d3630245b2c8d22c10e3ad10ba.zip
need eutils for epatch
Diffstat (limited to 'dev-db/mysql++')
-rw-r--r--dev-db/mysql++/mysql++-1.7.9-r1.ebuild19
-rw-r--r--dev-db/mysql++/mysql++-1.7.9.ebuild33
2 files changed, 21 insertions, 31 deletions
diff --git a/dev-db/mysql++/mysql++-1.7.9-r1.ebuild b/dev-db/mysql++/mysql++-1.7.9-r1.ebuild
index 9ddfdc6a49bd..eee34c9b3be2 100644
--- a/dev-db/mysql++/mysql++-1.7.9-r1.ebuild
+++ b/dev-db/mysql++/mysql++-1.7.9-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-1.7.9-r1.ebuild,v 1.5 2003/08/02 19:53:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-1.7.9-r1.ebuild,v 1.6 2003/08/05 16:01:17 vapier Exp $
-S=${WORKDIR}/${P}
+inherit gcc eutils
DESCRIPTION="C++ API interface to the MySQL database"
-
+# This is the download page but includes links to other places
+HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
SRC_URI="http://mysql.he.net/Downloads/${PN}/${P}.tar.gz
http://mysql.adgrafix.com/Downloads/${PN}/${P}.tar.gz
http://mysql.fastmirror.com/Downloads/${PN}/${P}.tar.gz
@@ -13,19 +14,16 @@ SRC_URI="http://mysql.he.net/Downloads/${PN}/${P}.tar.gz
mirror://gentoo/mysql++-gcc-3.0.patch.gz
mirror://gentoo/mysql++-gcc-3.2.patch.gz"
-# This is the download page but includes links to other places
-HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
-
-IUSE=""
+LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="x86 ~alpha ~hppa ~mips ~arm ~sparc ~ppc"
-LICENSE="LGPL-2"
+
DEPEND=">=dev-db/mysql-3.23.49"
src_unpack() {
unpack ${A}
EPATCH_OPTS="-p1 -d ${S}"
- if [[ "${COMPILER}" == "gcc3" ]];then
+ if [ `gcc-major-version` -eq 3 ] ; then
EPATCH_SINGLE_MSG="Patching for gcc 3.0..."
epatch ${DISTDIR}/mysql++-gcc-3.0.patch.gz
EPATCH_SINGLE_MSG="Patching for gcc 3.2..."
@@ -43,7 +41,6 @@ src_unpack() {
}
src_compile() {
-
local myconf
# we want C++ exceptions turned on
myconf="--enable-exceptions"
@@ -61,7 +58,7 @@ src_compile() {
emake || die "unable to make"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
# install the docs and HTML pages
dodoc README LGPL
diff --git a/dev-db/mysql++/mysql++-1.7.9.ebuild b/dev-db/mysql++/mysql++-1.7.9.ebuild
index 66293378793f..faad741fc49f 100644
--- a/dev-db/mysql++/mysql++-1.7.9.ebuild
+++ b/dev-db/mysql++/mysql++-1.7.9.ebuild
@@ -1,36 +1,32 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Ric Messier <kilroy@WasHere.COM>
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-1.7.9.ebuild,v 1.8 2003/06/12 20:29:17 msterret Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-1.7.9.ebuild,v 1.9 2003/08/05 16:01:17 vapier Exp $
-S=${WORKDIR}/${P}
+inherit gcc eutils
DESCRIPTION="C++ API interface to the MySQL database"
-
+# This is the download page but includes links to other places
+HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
SRC_URI="http://mysql.he.net/Downloads/${PN}/${P}.tar.gz
http://mysql.adgrafix.com/Downloads/${PN}/${P}.tar.gz
http://mysql.fastmirror.com/Downloads/${PN}/${P}.tar.gz
http://mysql.oms-net.nl/Downloads/${PN}/${P}.tar.gz
mirror://gentoo/mysql++-gcc-3.0.patch.gz"
-# This is the download page but includes links to other places
-HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
-
-IUSE=""
+LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86"
-LICENSE="LGPL-2"
# Depends on MySQL being installed, duh! :-)
DEPEND="<dev-db/mysql-4.0.0
- >=dev-db/mysql-3.23.49"
+ >=dev-db/mysql-3.23.49"
src_compile() {
- if [[ "${COMPILER}" == "gcc3" ]];then
- patch -p1 < ${DISTDIR}/mysql++-gcc-3.0.patch || die
- patch -p1 < ${FILESDIR}/mysql++-gcc-3.2.patch || die
- fi
- patch -p1 < ${FILESDIR}/mysql++-1.7.9_example.patch || die
+ if [ `gcc-major-version` -eq 3 ] ; then
+ epatch ${DISTDIR}/mysql++-gcc-3.0.patch
+ epatch ${FILESDIR}/mysql++-gcc-3.2.patch
+ fi
+ epatch ${FILESDIR}/mysql++-1.7.9_example.patch
# not including the directives to where MySQL is because it seems to find it
# just fine without
@@ -45,11 +41,8 @@ src_compile() {
emake || die "unable to make"
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
- # install the docs and HTML pages
dodoc doc/*
dohtml doc/man-html/*
-
}