summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2005-10-27 22:17:31 +0000
committerFrancesco Riosa <vivo@gentoo.org>2005-10-27 22:17:31 +0000
commit20d25609427869dbb317bb7275383dcffbe923b5 (patch)
treeb6fc5a92aa9b994ad4db0c645200212ba7775408 /dev-db/mysql
parentVersion bump. Closes bug #110647. (diff)
downloadgentoo-2-20d25609427869dbb317bb7275383dcffbe923b5.tar.gz
gentoo-2-20d25609427869dbb317bb7275383dcffbe923b5.tar.bz2
gentoo-2-20d25609427869dbb317bb7275383dcffbe923b5.zip
fix bug #110553, removed duplicate code
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/ChangeLog7
-rw-r--r--dev-db/mysql/mysql-4.0.25-r2.ebuild34
-rw-r--r--dev-db/mysql/mysql-4.0.26.ebuild35
-rw-r--r--dev-db/mysql/mysql-4.1.14.ebuild40
-rw-r--r--dev-db/mysql/mysql-4.1.15.ebuild39
-rw-r--r--dev-db/mysql/mysql-5.0.13_rc.ebuild39
-rw-r--r--dev-db/mysql/mysql-5.0.15.ebuild39
7 files changed, 103 insertions, 130 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 228dae494a3b..e5d019e58684 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.256 2005/10/25 17:50:45 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.257 2005/10/27 22:17:31 vivo Exp $
+
+ 27 Oct 2005; Francesco Riosa <vivo@gentoo.org> mysql-4.0.25-r2.ebuild,
+ mysql-4.0.26.ebuild, mysql-4.1.14.ebuild, mysql-4.1.15.ebuild,
+ mysql-5.0.13_rc.ebuild, mysql-5.0.15.ebuild:
+ fix bug #110553, removed duplicate code
25 Oct 2005; Francesco Riosa <vivo@gentoo.org> mysql-4.1.14.ebuild:
Backport fixes from 4.1.15, fix Bug 110442
diff --git a/dev-db/mysql/mysql-4.0.25-r2.ebuild b/dev-db/mysql/mysql-4.0.25-r2.ebuild
index aba88505e6a3..b43b8265ae72 100644
--- a/dev-db/mysql/mysql-4.0.25-r2.ebuild
+++ b/dev-db/mysql/mysql-4.0.25-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.25-r2.ebuild,v 1.23 2005/10/22 14:29:44 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.25-r2.ebuild,v 1.24 2005/10/27 22:17:31 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -370,6 +370,18 @@ pkg_preinst() {
pkg_postinst() {
mysql_get_datadir
+ # mind at FEATURES=collision-protect before to remove this
+ #empty dirs...
+ [ -d "${ROOT}/var/log/mysql" ] \
+ || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
+
+ #secure the logfiles... does this bother anybody?
+ touch ${ROOT}/var/log/mysql/mysql.{log,err}
+ chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
+ chmod 0660 ${ROOT}/var/log/mysql/mysql*
+ # secure some directories
+ chmod 0750 ${ROOT}/var/log/mysql
+
if ! useq minimal; then
# your friendly public service announcement...
einfo
@@ -398,7 +410,7 @@ pkg_config() {
local pwd2="b"
local maxtry=5
- if [[ -d "${DATADIR}/mysql" ]] ; then
+ if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then
ewarn "You have already a MySQL database in place."
ewarn "Please rename it or delete it if you wish to replace it."
die "MySQL database already exists!"
@@ -421,7 +433,7 @@ pkg_config() {
${ROOT}/usr/bin/mysql_install_db || die "MySQL databases not installed"
# MySQL 5.0 don't ned this
- chown -R mysql:mysql ${DATADIR}
+ chown -R mysql:mysql ${ROOT}/${DATADIR}
chmod 0750 ${ROOT}/${DATADIR}
# now we can set the password
@@ -429,7 +441,7 @@ pkg_config() {
local mysqld="${ROOT}/usr/sbin/mysqld \
--skip-grant-tables \
--basedir=${ROOT}/usr \
- --datadir=${ROOT}/var/lib/mysql \
+ --datadir=${ROOT}/${DATADIR} \
--skip-innodb \
--skip-bdb \
--max_allowed_packet=8M \
@@ -461,17 +473,3 @@ pkg_config() {
einfo "done"
}
-pkg_postinst() {
- # mind at FEATURES=collision-protect before to remove this
- #empty dirs...
- [ -d "${ROOT}/var/log/mysql" ] \
- || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
-
- #secure the logfiles... does this bother anybody?
- touch ${ROOT}/var/log/mysql/mysql.{log,err}
- chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
- chmod 0660 ${ROOT}/var/log/mysql/mysql*
- # secure some directories
- chmod 0750 ${ROOT}/var/log/mysql
-}
-
diff --git a/dev-db/mysql/mysql-4.0.26.ebuild b/dev-db/mysql/mysql-4.0.26.ebuild
index 705b7683e5a0..671d5bf994ec 100644
--- a/dev-db/mysql/mysql-4.0.26.ebuild
+++ b/dev-db/mysql/mysql-4.0.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.26.ebuild,v 1.13 2005/10/22 16:51:04 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.26.ebuild,v 1.14 2005/10/27 22:17:31 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -391,6 +391,18 @@ pkg_preinst() {
pkg_postinst() {
mysql_get_datadir
+ # mind at FEATURES=collision-protect before to remove this
+ #empty dirs...
+ [ -d "${ROOT}/var/log/mysql" ] \
+ || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
+
+ #secure the logfiles... does this bother anybody?
+ touch ${ROOT}/var/log/mysql/mysql.{log,err}
+ chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
+ chmod 0660 ${ROOT}/var/log/mysql/mysql*
+ # secure some directories
+ chmod 0750 ${ROOT}/var/log/mysql
+
if ! useq minimal; then
# your friendly public service announcement...
einfo
@@ -419,7 +431,7 @@ pkg_config() {
local pwd2="b"
local maxtry=5
- if [[ -d "${DATADIR}/mysql" ]] ; then
+ if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then
ewarn "You have already a MySQL database in place."
ewarn "Please rename it or delete it if you wish to replace it."
die "MySQL database already exists!"
@@ -442,7 +454,7 @@ pkg_config() {
${ROOT}/usr/bin/mysql_install_db || die "MySQL databases not installed"
# MySQL 5.0 don't ned this
- chown -R mysql:mysql ${DATADIR}
+ chown -R mysql:mysql ${ROOT}/${DATADIR}
chmod 0750 ${ROOT}/${DATADIR}
# now we can set the password
@@ -450,7 +462,7 @@ pkg_config() {
local mysqld="${ROOT}/usr/sbin/mysqld \
--skip-grant-tables \
--basedir=${ROOT}/usr \
- --datadir=${ROOT}/var/lib/mysql \
+ --datadir=${ROOT}/${DATADIR} \
--skip-innodb \
--skip-bdb \
--max_allowed_packet=8M \
@@ -481,18 +493,3 @@ pkg_config() {
einfo "done"
}
-
-pkg_postinst() {
- # mind at FEATURES=collision-protect before to remove this
- #empty dirs...
- [ -d "${ROOT}/var/log/mysql" ] \
- || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
-
- #secure the logfiles... does this bother anybody?
- touch ${ROOT}/var/log/mysql/mysql.{log,err}
- chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
- chmod 0660 ${ROOT}/var/log/mysql/mysql*
- # secure some directories
- chmod 0750 ${ROOT}/var/log/mysql
-}
-
diff --git a/dev-db/mysql/mysql-4.1.14.ebuild b/dev-db/mysql/mysql-4.1.14.ebuild
index 662e4b932c7a..82344f2b9ddc 100644
--- a/dev-db/mysql/mysql-4.1.14.ebuild
+++ b/dev-db/mysql/mysql-4.1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.21 2005/10/25 17:50:45 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.22 2005/10/27 22:17:31 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -361,7 +361,7 @@ src_test() {
local retstatus
addpredict /this-dir-does-not-exist/t9.MYI
- # Temporary removed, 4.1.14 use mysql-test-run.pl instead
+ # Temporary removed, 4.1.14 use mysql-test-run.pl instead
# of mysql-test-run, thus failing on test that should be
# skipped.
#version_is_at_least "5.0.6_beta" \
@@ -488,24 +488,6 @@ pkg_preinst() {
pkg_postinst() {
mysql_get_datadir
- if ! useq minimal; then
- # your friendly public service announcement...
- einfo
- einfo "You might want to run:"
- einfo "\"emerge --config =${PF}\""
- einfo "if this is a new install."
- einfo
- if [[ "${PREVIOUS_DATADIR}" == "yes" ]] ; then
- ewarn "Previous datadir found, it's YOUR job to change"
- ewarn "ownership and have care of it"
- fi
- fi
-
- mysql_upgrade_warning
- einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
-}
-
-pkg_postinst() {
# mind at FEATURES=collision-protect before to remove this
#empty dirs...
[ -d "${ROOT}/var/log/mysql" ] \
@@ -517,6 +499,18 @@ pkg_postinst() {
chmod 0660 ${ROOT}/var/log/mysql/mysql*
# secure some directories
chmod 0750 ${ROOT}/var/log/mysql
+
+ if ! useq minimal; then
+ # your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"emerge --config =${PF}\""
+ einfo "if this is a new install."
+ einfo
+ fi
+
+ mysql_upgrade_warning
+ einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
}
pkg_config() {
@@ -534,7 +528,7 @@ pkg_config() {
local pwd2="b"
local maxtry=5
- if [[ -d "${DATADIR}/mysql" ]] ; then
+ if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then
ewarn "You have already a MySQL database in place."
ewarn "Please rename it or delete it if you wish to replace it."
die "MySQL database already exists!"
@@ -557,7 +551,7 @@ pkg_config() {
${ROOT}/usr/bin/mysql_install_db || die "MySQL databases not installed"
# MySQL 5.0 don't need this
- chown -R mysql:mysql ${DATADIR}
+ chown -R mysql:mysql ${ROOT}/${DATADIR}
chmod 0750 ${ROOT}/${DATADIR}
local options=""
@@ -582,7 +576,7 @@ pkg_config() {
${options} \
--skip-grant-tables \
--basedir=${ROOT}/usr \
- --datadir=${ROOT}/var/lib/mysql \
+ --datadir=${ROOT}/${DATADIR} \
--skip-innodb \
--skip-bdb \
--max_allowed_packet=8M \
diff --git a/dev-db/mysql/mysql-4.1.15.ebuild b/dev-db/mysql/mysql-4.1.15.ebuild
index 67625cee1a5c..5995746d891a 100644
--- a/dev-db/mysql/mysql-4.1.15.ebuild
+++ b/dev-db/mysql/mysql-4.1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.15.ebuild,v 1.3 2005/10/24 17:00:19 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.15.ebuild,v 1.4 2005/10/27 22:17:31 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -485,24 +485,6 @@ pkg_preinst() {
pkg_postinst() {
mysql_get_datadir
- if ! useq minimal; then
- # your friendly public service announcement...
- einfo
- einfo "You might want to run:"
- einfo "\"emerge --config =${PF}\""
- einfo "if this is a new install."
- einfo
- if [[ "${PREVIOUS_DATADIR}" == "yes" ]] ; then
- ewarn "Previous datadir found, it's YOUR job to change"
- ewarn "ownership and have care of it"
- fi
- fi
-
- mysql_upgrade_warning
- einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
-}
-
-pkg_postinst() {
# mind at FEATURES=collision-protect before to remove this
#empty dirs...
[ -d "${ROOT}/var/log/mysql" ] \
@@ -514,8 +496,19 @@ pkg_postinst() {
chmod 0660 ${ROOT}/var/log/mysql/mysql*
# secure some directories
chmod 0750 ${ROOT}/var/log/mysql
-}
+ if ! useq minimal; then
+ # your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"emerge --config =${PF}\""
+ einfo "if this is a new install."
+ einfo
+ fi
+
+ mysql_upgrade_warning
+ einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
+}
pkg_config() {
mysql_get_datadir
@@ -532,7 +525,7 @@ pkg_config() {
local pwd2="b"
local maxtry=5
- if [[ -d "${DATADIR}/mysql" ]] ; then
+ if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then
ewarn "You have already a MySQL database in place."
ewarn "Please rename it or delete it if you wish to replace it."
die "MySQL database already exists!"
@@ -555,7 +548,7 @@ pkg_config() {
${ROOT}/usr/bin/mysql_install_db || die "MySQL databases not installed"
# MySQL 5.0 don't need this
- chown -R mysql:mysql ${DATADIR}
+ chown -R mysql:mysql ${ROOT}/${DATADIR}
chmod 0750 ${ROOT}/${DATADIR}
local options=""
@@ -580,7 +573,7 @@ pkg_config() {
${options} \
--skip-grant-tables \
--basedir=${ROOT}/usr \
- --datadir=${ROOT}/var/lib/mysql \
+ --datadir=${ROOT}/${DATADIR} \
--skip-innodb \
--skip-bdb \
--max_allowed_packet=8M \
diff --git a/dev-db/mysql/mysql-5.0.13_rc.ebuild b/dev-db/mysql/mysql-5.0.13_rc.ebuild
index b15e8940656d..3c47ab6a63f6 100644
--- a/dev-db/mysql/mysql-5.0.13_rc.ebuild
+++ b/dev-db/mysql/mysql-5.0.13_rc.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.13_rc.ebuild,v 1.8 2005/10/24 17:00:19 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.13_rc.ebuild,v 1.9 2005/10/27 22:17:31 vivo Exp $
inherit eutils flag-o-matic versionator
@@ -484,6 +484,18 @@ pkg_preinst() {
pkg_postinst() {
mysql_get_datadir
+ # mind at FEATURES=collision-protect before to remove this
+ #empty dirs...
+ [ -d "${ROOT}/var/log/mysql" ] \
+ || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
+
+ #secure the logfiles... does this bother anybody?
+ touch ${ROOT}/var/log/mysql/mysql.{log,err}
+ chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
+ chmod 0660 ${ROOT}/var/log/mysql/mysql*
+ # secure some directories
+ chmod 0750 ${ROOT}/var/log/mysql
+
if ! useq minimal; then
# your friendly public service announcement...
einfo
@@ -491,10 +503,6 @@ pkg_postinst() {
einfo "\"emerge --config =${PF}\""
einfo "if this is a new install."
einfo
- if [[ "${PREVIOUS_DATADIR}" == "yes" ]] ; then
- ewarn "Previous datadir found, it's YOUR job to change"
- ewarn "ownership and have care of it"
- fi
fi
mysql_upgrade_warning
@@ -516,7 +524,7 @@ pkg_config() {
local pwd2="b"
local maxtry=5
- if [[ -d "${DATADIR}/mysql" ]] ; then
+ if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then
ewarn "You have already a MySQL database in place."
ewarn "Please rename it or delete it if you wish to replace it."
die "MySQL database already exists!"
@@ -539,7 +547,7 @@ pkg_config() {
${ROOT}/usr/bin/mysql_install_db || die "MySQL databases not installed"
# MySQL 5.0 don't need this
- chown -R mysql:mysql ${DATADIR}
+ chown -R mysql:mysql ${ROOT}/${DATADIR}
chmod 0750 ${ROOT}/${DATADIR}
local options=""
@@ -564,7 +572,7 @@ pkg_config() {
${options} \
--skip-grant-tables \
--basedir=${ROOT}/usr \
- --datadir=${ROOT}/var/lib/mysql \
+ --datadir=${ROOT}/${DATADIR} \
--skip-innodb \
--skip-bdb \
--max_allowed_packet=8M \
@@ -600,18 +608,3 @@ pkg_config() {
rm "${sqltmp}"
einfo "done"
}
-
-pkg_postinst() {
- # mind at FEATURES=collision-protect before to remove this
- #empty dirs...
- [ -d "${ROOT}/var/log/mysql" ] \
- || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
-
- #secure the logfiles... does this bother anybody?
- touch ${ROOT}/var/log/mysql/mysql.{log,err}
- chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
- chmod 0660 ${ROOT}/var/log/mysql/mysql*
- # secure some directories
- chmod 0750 ${ROOT}/var/log/mysql
-}
-
diff --git a/dev-db/mysql/mysql-5.0.15.ebuild b/dev-db/mysql/mysql-5.0.15.ebuild
index 60afb78139de..64383e284347 100644
--- a/dev-db/mysql/mysql-5.0.15.ebuild
+++ b/dev-db/mysql/mysql-5.0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.15.ebuild,v 1.1 2005/10/24 17:00:19 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.15.ebuild,v 1.2 2005/10/27 22:17:31 vivo Exp $
inherit eutils flag-o-matic versionator
@@ -491,24 +491,6 @@ pkg_preinst() {
pkg_postinst() {
mysql_get_datadir
- if ! useq minimal; then
- # your friendly public service announcement...
- einfo
- einfo "You might want to run:"
- einfo "\"emerge --config =${PF}\""
- einfo "if this is a new install."
- einfo
- if [[ "${PREVIOUS_DATADIR}" == "yes" ]] ; then
- ewarn "Previous datadir found, it's YOUR job to change"
- ewarn "ownership and have care of it"
- fi
- fi
-
- mysql_upgrade_warning
- einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
-}
-
-pkg_postinst() {
# mind at FEATURES=collision-protect before to remove this
#empty dirs...
[ -d "${ROOT}/var/log/mysql" ] \
@@ -520,6 +502,18 @@ pkg_postinst() {
chmod 0660 ${ROOT}/var/log/mysql/mysql*
# secure some directories
chmod 0750 ${ROOT}/var/log/mysql
+
+ if ! useq minimal; then
+ # your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"emerge --config =${PF}\""
+ einfo "if this is a new install."
+ einfo
+ fi
+
+ mysql_upgrade_warning
+ einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
}
pkg_config() {
@@ -537,7 +531,7 @@ pkg_config() {
local pwd2="b"
local maxtry=5
- if [[ -d "${DATADIR}/mysql" ]] ; then
+ if [[ -d "${ROOT}/${DATADIR}/mysql" ]] ; then
ewarn "You have already a MySQL database in place."
ewarn "Please rename it or delete it if you wish to replace it."
die "MySQL database already exists!"
@@ -560,7 +554,7 @@ pkg_config() {
${ROOT}/usr/bin/mysql_install_db || die "MySQL databases not installed"
# MySQL 5.0 don't need this
- chown -R mysql:mysql ${DATADIR}
+ chown -R mysql:mysql ${ROOT}/${DATADIR}
chmod 0750 ${ROOT}/${DATADIR}
local options=""
@@ -585,7 +579,7 @@ pkg_config() {
${options} \
--skip-grant-tables \
--basedir=${ROOT}/usr \
- --datadir=${ROOT}/var/lib/mysql \
+ --datadir=${ROOT}/${DATADIR} \
--skip-innodb \
--skip-bdb \
--max_allowed_packet=8M \
@@ -621,4 +615,3 @@ pkg_config() {
rm "${sqltmp}"
einfo "done"
}
-