summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-12-01 20:25:33 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-12-01 20:25:33 +0000
commit527136fcd544723773b342ab019134dda23aeb1a (patch)
tree3eb04eddb837d6221fe37f93f8f53105dc410e5b /dev-db
parentversion bump (diff)
downloadgentoo-2-527136fcd544723773b342ab019134dda23aeb1a.tar.gz
gentoo-2-527136fcd544723773b342ab019134dda23aeb1a.tar.bz2
gentoo-2-527136fcd544723773b342ab019134dda23aeb1a.zip
added gtk support. Fixes #34650
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/unixODBC/ChangeLog5
-rw-r--r--dev-db/unixODBC/Manifest4
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.6.ebuild26
3 files changed, 30 insertions, 5 deletions
diff --git a/dev-db/unixODBC/ChangeLog b/dev-db/unixODBC/ChangeLog
index 4df814926389..7b455345b974 100644
--- a/dev-db/unixODBC/ChangeLog
+++ b/dev-db/unixODBC/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/unixODBC
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.13 2003/11/21 19:16:19 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/ChangeLog,v 1.14 2003/12/01 20:25:28 rphillips Exp $
+
+ 01 Dec 2003; <rphillips@gentoo.org> unixODBC-2.2.6.ebuild:
+ Added Jonathan Nall's gtk enabled ebuild.
*unixODBC-2.2.6 (21 Nov 2003)
diff --git a/dev-db/unixODBC/Manifest b/dev-db/unixODBC/Manifest
index ec1b7571c140..3af7cc95dccb 100644
--- a/dev-db/unixODBC/Manifest
+++ b/dev-db/unixODBC/Manifest
@@ -1,7 +1,7 @@
MD5 2352820d0c329b031a28ed77cd6be6d3 unixODBC-2.2.2.ebuild 1297
MD5 0bd88c25618464c75595f9e0e39195ff unixODBC-2.0.8.ebuild 1108
-MD5 bce7742b423efcd78fb836b84c822c8a unixODBC-2.2.6.ebuild 952
-MD5 b2e3dd45ad9c661f62edf96865878c7d ChangeLog 1858
+MD5 32ef688c525493a9240667b601fde6d2 unixODBC-2.2.6.ebuild 1339
+MD5 c26007c8888bf2b1a1ed33786ccf1c91 ChangeLog 1964
MD5 059733ad92a101895ce18a1120b6eb55 metadata.xml 225
MD5 ffd3cee4e2a1f6dffc130557ccda934b files/gentoo-yac.diff 316
MD5 f383c7806ba5f687ba55d5f1bc6a36aa files/digest-unixODBC-2.0.8 67
diff --git a/dev-db/unixODBC/unixODBC-2.2.6.ebuild b/dev-db/unixODBC/unixODBC-2.2.6.ebuild
index 08104864729d..7d77dc00974f 100644
--- a/dev-db/unixODBC/unixODBC-2.2.6.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6.ebuild,v 1.1 2003/11/21 19:16:19 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6.ebuild,v 1.2 2003/12/01 20:25:28 rphillips Exp $
DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.unixodbc.org/"
@@ -9,7 +9,7 @@ SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~hppa ~alpha amd64"
-IUSE="qt"
+IUSE="qt gtk"
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
@@ -32,11 +32,33 @@ src_compile() {
${myconf} || die
make || die
+
+ if [ "`use gtk`" ]
+ then
+ cd gODBCConfig
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ # not sure why these symlinks are needed. busted configure, i guess...
+ ln -s ../depcomp .
+ ln -s ../libtool .
+ make || die
+ cd ..
+ fi
}
src_install() {
make DESTDIR=${D} install || die
+ if [ "`use gtk`" ]
+ then
+ cd gODBCConfig
+ make DESTDIR=${D} install || die
+ cd ..
+ fi
+
dodoc AUTHORS COPYING ChangeLog NEWS README*
find doc/ -name "Makefile*" -exec rm '{}' \;
dohtml doc/*