summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-28 13:59:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-28 13:59:31 +0000
commit6428f8bc358e190d2ec9c19def2d06e93ecde0fd (patch)
tree4774b82d3d55cd370f9b583a4c47afe66503ab38 /dev-games/guichan
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-6428f8bc358e190d2ec9c19def2d06e93ecde0fd.tar.gz
gentoo-2-6428f8bc358e190d2ec9c19def2d06e93ecde0fd.tar.bz2
gentoo-2-6428f8bc358e190d2ec9c19def2d06e93ecde0fd.zip
EAPI=2; re-roll patch so it applies
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'dev-games/guichan')
-rw-r--r--dev-games/guichan/ChangeLog6
-rw-r--r--dev-games/guichan/files/guichan-0.8.1-as-needed.patch19
-rw-r--r--dev-games/guichan/guichan-0.8.1.ebuild13
3 files changed, 19 insertions, 19 deletions
diff --git a/dev-games/guichan/ChangeLog b/dev-games/guichan/ChangeLog
index 4b89f6a51c57..9ecf1d9cee9a 100644
--- a/dev-games/guichan/ChangeLog
+++ b/dev-games/guichan/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/guichan
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.14 2009/01/28 11:30:23 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.15 2009/01/28 13:59:31 mr_bones_ Exp $
+
+ 28 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ files/guichan-0.8.1-as-needed.patch, guichan-0.8.1.ebuild:
+ EAPI=2; re-roll patch so it applies
28 Jan 2009; Alfredo Tupone <tupone@gentoo.org>
+files/guichan-0.8.1-as-needed.patch, guichan-0.8.1.ebuild:
diff --git a/dev-games/guichan/files/guichan-0.8.1-as-needed.patch b/dev-games/guichan/files/guichan-0.8.1-as-needed.patch
index 3908f6956a53..24f1c993bb96 100644
--- a/dev-games/guichan/files/guichan-0.8.1-as-needed.patch
+++ b/dev-games/guichan/files/guichan-0.8.1-as-needed.patch
@@ -1,13 +1,12 @@
---- src/sdl/Makefile.am.old 2009-01-28 11:45:52.000000000 +0100
-+++ src/sdl/Makefile.am 2009-01-28 11:57:39.000000000 +0100
+diff -ru guichan-0.8.1.orig/src/sdl/Makefile.am guichan-0.8.1/src/sdl/Makefile.am
+--- guichan-0.8.1.orig/src/sdl/Makefile.am 2008-04-12 07:57:57.000000000 -0400
++++ guichan-0.8.1/src/sdl/Makefile.am 2009-01-28 08:53:53.000000000 -0500
@@ -6,6 +6,8 @@
-
- libguichan_sdl_la_LDFLAGS = -no-undefined -release $(LT_RELEASE)
--version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
+
+ libguichan_sdl_la_LDFLAGS = -no-undefined -release $(LT_RELEASE) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+
+libguichan_sdl_la_LIBADD = -lSDL_image -L$(top_srcdir)/src -lguichan
+
- libguichan_sdl_la_SOURCES = \
- sdl.cpp \
- sdlgraphics.cpp \
-
+ libguichan_sdl_la_SOURCES = \
+ sdl.cpp \
+ sdlgraphics.cpp \
diff --git a/dev-games/guichan/guichan-0.8.1.ebuild b/dev-games/guichan/guichan-0.8.1.ebuild
index 2b16d7ad3996..568ea471f977 100644
--- a/dev-games/guichan/guichan-0.8.1.ebuild
+++ b/dev-games/guichan/guichan-0.8.1.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.2 2009/01/28 11:30:23 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.1.ebuild,v 1.3 2009/01/28 13:59:31 mr_bones_ Exp $
+EAPI=2
inherit eutils autotools
DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
@@ -20,22 +21,18 @@ DEPEND="allegro? ( media-libs/allegro )
media-libs/sdl-image
)"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-as-needed.patch
eautoreconf
}
-src_compile() {
+src_configure() {
econf \
--disable-dependency-tracking \
$(use_enable allegro) \
$(use_enable opengl) \
$(use_enable sdl) \
- $(use_enable sdl sdlimage) \
- || die
- emake || die "emake failed"
+ $(use_enable sdl sdlimage)
}
src_install() {