summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-09 17:26:13 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-09 17:26:13 +0000
commit67d49cdd06fe9635bdd306d32276264480c243e1 (patch)
treef69f44ae19526ec33e0e53580a21d6b8ac875ee6 /dev-games/ogre
parentapp-text/dos2unix: Cleaned old (diff)
downloadgentoo-2-67d49cdd06fe9635bdd306d32276264480c243e1.tar.gz
gentoo-2-67d49cdd06fe9635bdd306d32276264480c243e1.tar.bz2
gentoo-2-67d49cdd06fe9635bdd306d32276264480c243e1.zip
fix build with USE=gles2 wrt #435560
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-games/ogre')
-rw-r--r--dev-games/ogre/ChangeLog8
-rw-r--r--dev-games/ogre/files/ogre-1.8.1-gles2.patch22
-rw-r--r--dev-games/ogre/ogre-1.8.1.ebuild7
3 files changed, 32 insertions, 5 deletions
diff --git a/dev-games/ogre/ChangeLog b/dev-games/ogre/ChangeLog
index c6128c950a59..9b707c31f7fe 100644
--- a/dev-games/ogre/ChangeLog
+++ b/dev-games/ogre/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/ogre
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.91 2012/12/14 12:53:39 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.92 2013/01/09 17:26:13 hasufell Exp $
+
+ 09 Jan 2013; Julian Ospald <hasufell@gentoo.org> ogre-1.8.1.ebuild,
+ +files/ogre-1.8.1-gles2.patch:
+ fix build with USE=gles2 wrt #435560
14 Dec 2012; Agostino Sarubbo <ago@gentoo.org> ogre-1.8.1.ebuild:
Stable for x86, wrt bug #447160
diff --git a/dev-games/ogre/files/ogre-1.8.1-gles2.patch b/dev-games/ogre/files/ogre-1.8.1-gles2.patch
new file mode 100644
index 000000000000..6c9a3f33b2a5
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.8.1-gles2.patch
@@ -0,0 +1,22 @@
+https://bitbucket.org/sinbad/ogre/commits/6e2e797877491fa9bea169e063a9663834977d8e
+
+--- RenderSystems/GLES2/src/GLSLES/src/OgreGLSLESProgramPipeline.cpp
++++ RenderSystems/GLES2/src/GLSLES/src/OgreGLSLESProgramPipeline.cpp
+@@ -138,7 +138,7 @@
+ GLint binaryLength = 0;
+
+ #if GL_OES_get_program_binary
+- glGetProgramiv(mGLHandle, GL_PROGRAM_BINARY_LENGTH_OES, &binaryLength);
++ glGetProgramiv(mGLProgramHandle, GL_PROGRAM_BINARY_LENGTH_OES, &binaryLength);
+ GL_CHECK_ERROR;
+ #endif
+
+@@ -148,7 +148,7 @@
+
+ #if GL_OES_get_program_binary
+ // Get binary
+- glGetProgramBinaryOES(mGLHandle, binaryLength, NULL, (GLenum *)newMicrocode->getPtr(), newMicrocode->getPtr() + sizeof(GLenum));
++ glGetProgramBinaryOES(mGLProgramHandle, binaryLength, NULL, (GLenum *)newMicrocode->getPtr(), newMicrocode->getPtr() + sizeof(GLenum));
+ GL_CHECK_ERROR;
+ #endif
+
diff --git a/dev-games/ogre/ogre-1.8.1.ebuild b/dev-games/ogre/ogre-1.8.1.ebuild
index 55ba0955f38a..1818f3e54772 100644
--- a/dev-games/ogre/ogre-1.8.1.ebuild
+++ b/dev-games/ogre/ogre-1.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.8.1.ebuild,v 1.4 2012/12/14 12:53:39 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.8.1.ebuild,v 1.5 2013/01/09 17:26:13 hasufell Exp $
EAPI=4
inherit eutils cmake-utils
@@ -45,7 +45,8 @@ S=${WORKDIR}/${PN}_src_v${MY_PV}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-threading.patch \
- "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-gles2.patch
sed -i \
-e "s:share/OGRE/docs:share/doc/${PF}:" \
Docs/CMakeLists.txt || die