summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-20 19:13:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-20 19:13:09 +0000
commitf2a8ed95b2be0f529a925c48ea613b54bd951171 (patch)
tree693886ca33e8703ed385b5ec27929c2cbc3c0c56 /dev-games
parentVersion bump. (diff)
downloadgentoo-2-f2a8ed95b2be0f529a925c48ea613b54bd951171.tar.gz
gentoo-2-f2a8ed95b2be0f529a925c48ea613b54bd951171.tar.bz2
gentoo-2-f2a8ed95b2be0f529a925c48ea613b54bd951171.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/mygui/ChangeLog7
-rw-r--r--dev-games/mygui/files/mygui-3.2.0-FHS.patch63
-rw-r--r--dev-games/mygui/files/mygui-3.2.0-build.patch72
-rw-r--r--dev-games/mygui/files/mygui-3.2.0-underlinking.patch20
-rw-r--r--dev-games/mygui/mygui-3.2.0-r1.ebuild126
5 files changed, 6 insertions, 282 deletions
diff --git a/dev-games/mygui/ChangeLog b/dev-games/mygui/ChangeLog
index 3a47de55948b..62ff58649ce8 100644
--- a/dev-games/mygui/ChangeLog
+++ b/dev-games/mygui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/mygui
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/mygui/ChangeLog,v 1.12 2015/04/19 10:06:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/mygui/ChangeLog,v 1.13 2015/04/20 19:13:09 mr_bones_ Exp $
+
+ 20 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/mygui-3.2.0-FHS.patch, -files/mygui-3.2.0-build.patch,
+ -files/mygui-3.2.0-underlinking.patch, -mygui-3.2.0-r1.ebuild:
+ old
19 Apr 2015; Agostino Sarubbo <ago@gentoo.org> mygui-3.2.2.ebuild:
Stable for x86, wrt bug #545890
diff --git a/dev-games/mygui/files/mygui-3.2.0-FHS.patch b/dev-games/mygui/files/mygui-3.2.0-FHS.patch
deleted file mode 100644
index 7c0c88a2caa7..000000000000
--- a/dev-games/mygui/files/mygui-3.2.0-FHS.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sat Oct 27 22:39:31 UTC 2012
-Subject: FHS
-
-paths hardcoded until upstream fixed the logic
-
---- Common/Base/Ogre/BaseManager.cpp
-+++ Common/Base/Ogre/BaseManager.cpp
-@@ -47,14 +47,14 @@
- mWindow(nullptr),
- mExit(false),
- mPluginCfgName("plugins.cfg"),
-- mResourceXMLName("resources.xml"),
-+ mResourceXMLName("/etc/MYGUI/resources.xml"),
- mResourceFileName("MyGUI_Core.xml"),
- mNode(nullptr)
- {
- #if MYGUI_PLATFORM == MYGUI_PLATFORM_APPLE
- mResourcePath = macBundlePath() + "/Contents/Resources/";
- #else
-- mResourcePath = "";
-+ mResourcePath = "/etc/MYGUI/";
- #endif
- }
-
-@@ -65,12 +65,16 @@
- bool BaseManager::create()
- {
- Ogre::String pluginsPath;
-+ char *homedir;
-+ homedir = getenv("HOME");
-+ std::string homePath;
-+ homePath = homedir;
-
- #ifndef OGRE_STATIC_LIB
- pluginsPath = mResourcePath + mPluginCfgName;
- #endif
-
-- mRoot = new Ogre::Root(pluginsPath, mResourcePath + "ogre.cfg", mResourcePath + "Ogre.log");
-+ mRoot = new Ogre::Root(pluginsPath, homePath + "/mygui-ogre.cfg", homePath + "/mygui-Ogre.log");
-
- setupResources();
-
---- CMake/InstallResources.cmake
-+++ CMake/InstallResources.cmake
-@@ -24,7 +24,7 @@
- else ()
- install(FILES
- ${MYGUI_BINARY_DIR}/bin/${FILENAME}
-- DESTINATION "bin"
-+ DESTINATION "/etc/MYGUI"
- )
- endif ()
- endfunction(install_file)
-@@ -51,7 +51,7 @@
- if (WIN32)
- set(MYGUI_MEDIA_DIR "../../Media")
- elseif (UNIX)
-- set(MYGUI_MEDIA_DIR "../share/MYGUI/Media")
-+ set(MYGUI_MEDIA_DIR "${CMAKE_INSTALL_PREFIX}/share/MYGUI/Media")
- else ()
- set(MYGUI_MEDIA_DIR "../../Media")
- endif ()
diff --git a/dev-games/mygui/files/mygui-3.2.0-build.patch b/dev-games/mygui/files/mygui-3.2.0-build.patch
deleted file mode 100644
index f1f0f1cc94e3..000000000000
--- a/dev-games/mygui/files/mygui-3.2.0-build.patch
+++ /dev/null
@@ -1,72 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Fri Jun 15 21:58:45 UTC 2012
-
-use proper destinations and allow Gentoo build type
-rename demo targets to avoid confusion
-
---- CMake/Utils/MyGUIConfigTargets.cmake
-+++ CMake/Utils/MyGUIConfigTargets.cmake
-@@ -1,6 +1,8 @@
- # Configure settings and install targets
- # FIXME: Copypasted from Ogre and need lots of changes
-
-+include(GNUInstallDirs)
-+
- if (WIN32)
- set(MYGUI_RELEASE_PATH "/Release")
- set(MYGUI_RELWDBG_PATH "/RelWithDebInfo")
-@@ -56,6 +58,12 @@
- # install targets according to current build type
- function(mygui_install_target TARGETNAME SUFFIX)
- install(TARGETS ${TARGETNAME}
-+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}" CONFIGURATIONS Gentoo ""
-+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
-+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
-+ FRAMEWORK DESTINATION "${MYGUI_FRAMEWORK_PATH}" CONFIGURATIONS Gentoo ""
-+ )
-+ install(TARGETS ${TARGETNAME}
- RUNTIME DESTINATION "bin${MYGUI_RELEASE_PATH}" CONFIGURATIONS Release None ""
- LIBRARY DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
- ARCHIVE DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
-@@ -170,7 +178,13 @@
- endif ()
- add_executable(${PROJECTNAME} ${MYGUI_EXEC_TYPE} ${HEADER_FILES} ${SOURCE_FILES})
- endif ()
-- set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
-+
-+ # rename demo target
-+ if (${SOLUTIONFOLDER} STREQUAL "Demos")
-+ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER} OUTPUT_NAME MYGUI-${PROJECTNAME})
-+ else()
-+ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
-+ endif()
-
- add_dependencies(${PROJECTNAME} MyGUIEngine Common)
-
-@@ -326,4 +340,4 @@
- INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
- set_property(TARGET ${PROJECTNAME} PROPERTY INSTALL_RPATH_USE_LINK_PATH TRUE)
- endif ()
--endfunction(mygui_config_sample)
-\ No newline at end of file
-+endfunction(mygui_config_sample)
---- CMake/ConfigureBuild.cmake
-+++ CMake/ConfigureBuild.cmake
-@@ -4,6 +4,8 @@
- # also prepare package files for pkg-config and CMake.
- #######################################################################
-
-+include(GNUInstallDirs)
-+
- # should we build static libs?
- if (MYGUI_STATIC)
- set(MYGUI_LIB_TYPE STATIC)
-@@ -47,7 +49,7 @@
- else ()
- configure_file(${MYGUI_TEMPLATES_DIR}/MYGUI.pc.in ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc @ONLY)
- endif ()
-- install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION lib/pkgconfig)
-+ install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
- # configure additional packages
-
diff --git a/dev-games/mygui/files/mygui-3.2.0-underlinking.patch b/dev-games/mygui/files/mygui-3.2.0-underlinking.patch
deleted file mode 100644
index 2d1026856f03..000000000000
--- a/dev-games/mygui/files/mygui-3.2.0-underlinking.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Fri Jun 15 10:42:42 UTC 2012
-Subject: build system
-
-fix underlinking
-
---- MyGUIEngine/CMakeLists.txt
-+++ MyGUIEngine/CMakeLists.txt
-@@ -48,7 +48,10 @@
- if (MYGUI_USE_FREETYPE)
- target_link_libraries(${PROJECTNAME}
- ${FREETYPE_LIBRARIES}
-- )
-+ dl)
-+else()
-+ target_link_libraries(${PROJECTNAME}
-+ dl)
- endif()
-
- # platform specific dependencies
diff --git a/dev-games/mygui/mygui-3.2.0-r1.ebuild b/dev-games/mygui/mygui-3.2.0-r1.ebuild
deleted file mode 100644
index b5a6e0f3f9f0..000000000000
--- a/dev-games/mygui/mygui-3.2.0-r1.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/mygui/mygui-3.2.0-r1.ebuild,v 1.5 2014/03/08 23:17:25 hasufell Exp $
-
-EAPI=5
-CMAKE_REMOVE_MODULES="yes"
-CMAKE_REMOVE_MODULES_LIST="FindFreetype"
-inherit eutils cmake-utils flag-o-matic multilib
-
-MY_PN=MyGUI
-MY_P=${MY_PN}_${PV}
-
-DESCRIPTION="A library for creating GUIs for games"
-HOMEPAGE="http://mygui.info/"
-SRC_URI="mirror://sourceforge/my-gui/${MY_PN}/${MY_P}/${MY_P}.zip"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug doc plugins samples static-libs test tools linguas_ru"
-
-RDEPEND="dev-games/ogre:=[freeimage,opengl]
- media-libs/freetype:2
- samples? ( dev-games/ois )
- tools? ( dev-games/ois )"
-DEPEND="${RDEPEND}
- app-arch/unzip
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-S=${WORKDIR}/${MY_P}
-STATIC_BUILD=${WORKDIR}/${P}_build_static
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-underlinking.patch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-FHS.patch
-}
-
-src_configure() {
- use debug && append-cppflags -DDEBUG
-
- local mycmakeargs=()
-
- # static configuration
- if use static-libs ; then
- mycmakeargs=( -DMYGUI_STATIC=ON
- -DMYGUI_BUILD_DOCS=OFF
- -DMYGUI_INSTALL_DOCS=OFF
- -DMYGUI_USE_FREETYPE=ON
- $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
- -DMYGUI_BUILD_DEMOS=OFF
- -DMYGUI_INSTALL_SAMPLES=OFF
- -DMYGUI_BUILD_TOOLS=OFF
- -DMYGUI_INSTALL_TOOLS=OFF
- -DMYGUI_BUILD_WRAPPER=OFF
- -DMYGUI_RENDERSYSTEM=2 )
-
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_configure
- unset mycmakeargs
- fi
-
- # main configuration
- mycmakeargs=( -DMYGUI_STATIC=OFF
- $(cmake-utils_use doc MYGUI_BUILD_DOCS)
- $(cmake-utils_use doc MYGUI_INSTALL_DOCS)
- -DMYGUI_USE_FREETYPE=ON
- $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
- $(cmake-utils_use samples MYGUI_BUILD_DEMOS)
- $(cmake-utils_use samples MYGUI_INSTALL_SAMPLES)
- $(cmake-utils_use tools MYGUI_BUILD_TOOLS)
- $(cmake-utils_use tools MYGUI_INSTALL_TOOLS)
- -DMYGUI_BUILD_WRAPPER=OFF
- -DMYGUI_RENDERSYSTEM=2 )
-
- if use tools || use samples ; then
- mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=ON )
- else
- mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=OFF )
- fi
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- # build system does not support building static and shared at once,
- # run a double build
- if use static-libs ; then
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_compile
- fi
-
- cmake-utils_src_compile
-
- use doc && emake -C "${CMAKE_BUILD_DIR}"/Docs api-docs
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use static-libs ; then
- find "${STATIC_BUILD}" -name "*.a" \! -name "libCommon.a" -exec dolib.a '{}' \;
- insinto /usr/$(get_libdir)/pkgconfig
- doins "${STATIC_BUILD}"/pkgconfig/MYGUIStatic.pc
- fi
-
- if use doc ; then
- dohtml -r "${CMAKE_BUILD_DIR}"/Docs/html/*
-
- if use linguas_ru ; then
- docompress -x /usr/share/doc/${PF}/Papers
- dodoc -r Docs/Papers
- fi
- fi
-
- # test media not needed at runtime
- rm -rf "${D}"/usr/share/MYGUI/Media/UnitTests
- # wrapper not available for linux, remove related media
- rm -rf "${D}"/usr/share/MYGUI/Media/Wrapper
-}
-
-pkg_postinst() {
- einfo
- elog "ogre.cfg and Ogre.log are created as"
- elog "~/mygui-ogre.cfg and ~/mygui-Ogre.log"
- einfo
-}