summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-03-10 12:38:13 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-03-10 12:38:13 +0000
commitb77861a777179a56fff0c270c8f04858ed4aa40f (patch)
tree328587d48599b99ac30e01afe9bce227638487c9 /dev-haskell/wash/wash-2.0.6.ebuild
parentmark stable on x86. (diff)
downloadgentoo-2-b77861a777179a56fff0c270c8f04858ed4aa40f.tar.gz
gentoo-2-b77861a777179a56fff0c270c8f04858ed4aa40f.tar.bz2
gentoo-2-b77861a777179a56fff0c270c8f04858ed4aa40f.zip
New wash-2.0.6 release added. Removed wash-2.0.5 releases. Fixed path bug
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-haskell/wash/wash-2.0.6.ebuild')
-rw-r--r--dev-haskell/wash/wash-2.0.6.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/wash/wash-2.0.6.ebuild b/dev-haskell/wash/wash-2.0.6.ebuild
new file mode 100644
index 000000000000..5f3dfaff8109
--- /dev/null
+++ b/dev-haskell/wash/wash-2.0.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wash/wash-2.0.6.ebuild,v 1.1 2005/03/10 12:38:13 araujo Exp $
+
+inherit ghc-package
+
+# the installation bundle is called WashNGo
+MY_P="WashNGo"
+MY_PV=${MY_P}-${PV}
+
+DESCRIPTION="WASH is a family of embedded domain-specific languages for programming Web applications"
+HOMEPAGE="http://www.informatik.uni-freiburg.de/~thiemann/haskell/WASH/"
+SRC_URI="http://www.informatik.uni-freiburg.de/~thiemann/haskell/WASH/${MY_PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc postgres"
+
+DEPEND=">=virtual/ghc-6.2
+ postgres? ( dev-haskell/c2hs
+ >=dev-db/postgresql-7.4.3 )"
+
+S=${WORKDIR}/${MY_PV}
+
+src_compile() {
+ local myopts
+ myopts="${myopts} `use_enable postgres dbconnect`"
+ myopts="${myopts} `use_enable doc build-docs`"
+ ./configure \
+ --prefix="${D}usr" \
+ --host=${CHOST} \
+ --libdir=${D}/$(ghc-libdir) \
+ ${myopts} \
+ --enable-register-package="${S}/$(ghc-localpkgconf)" \
+ || die "configure failed"
+ make depend || die "make depend failed"
+ make all || die "make all failed"
+}
+
+src_install() {
+ ghc-setup-pkg
+ make exec_prefix=${D}/usr install || die "make install failed"
+ ghc-install-pkg
+ dodoc README
+ if use doc; then
+ cp -r Examples ${D}/usr/share/doc/${PF}
+ cd doc
+ dohtml -r *
+ fi
+}