summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-25 22:17:07 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-25 22:17:07 +0000
commit4ecd62c0a0881caf6a943ceb1060b9c39b166368 (patch)
tree403a0bf22781e4a485842ee478afe81a4c628c6d /dev-java/commons-el
parentMarked stable on hppa. (diff)
downloadgentoo-2-4ecd62c0a0881caf6a943ceb1060b9c39b166368.tar.gz
gentoo-2-4ecd62c0a0881caf6a943ceb1060b9c39b166368.tar.bz2
gentoo-2-4ecd62c0a0881caf6a943ceb1060b9c39b166368.zip
Initial Import, on we go for a tomcat source ebuild.
Diffstat (limited to 'dev-java/commons-el')
-rw-r--r--dev-java/commons-el/ChangeLog8
-rw-r--r--dev-java/commons-el/Manifest2
-rw-r--r--dev-java/commons-el/commons-el-1.0.ebuild49
-rw-r--r--dev-java/commons-el/files/digest-commons-el-1.01
-rw-r--r--dev-java/commons-el/metadata.xml5
5 files changed, 65 insertions, 0 deletions
diff --git a/dev-java/commons-el/ChangeLog b/dev-java/commons-el/ChangeLog
new file mode 100644
index 000000000000..796c1e2680ef
--- /dev/null
+++ b/dev-java/commons-el/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-java/commons-el
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/ChangeLog,v 1.1 2004/02/25 22:17:07 zx Exp $
+
+ 28 Feb 2004; Chris Aniszczyk <zx@gentoo.org> metadata.xml:
+ Initial Import.
+ Thanks to Greg Bowyer <bg115@gre.ac.uk> for the initial ebuild. Closes #37924
+
diff --git a/dev-java/commons-el/Manifest b/dev-java/commons-el/Manifest
new file mode 100644
index 000000000000..3c1e23e8b4c3
--- /dev/null
+++ b/dev-java/commons-el/Manifest
@@ -0,0 +1,2 @@
+MD5 e7bf9f50759d68b1e4b2bdb5e15624cc commons-el-1.0.ebuild 1294
+MD5 35c69c54a30e1f87340edb6d13bc529b files/digest-commons-el-1.0 69
diff --git a/dev-java/commons-el/commons-el-1.0.ebuild b/dev-java/commons-el/commons-el-1.0.ebuild
new file mode 100644
index 000000000000..f5deb4eea750
--- /dev/null
+++ b/dev-java/commons-el/commons-el-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-el/commons-el-1.0.ebuild,v 1.1 2004/02/25 22:17:07 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="EL is the JSP 2.0 Expression Language Interpreter from Apache."
+HOMEPAGE="http://jakarta.apache.org/commons/el.html"
+SRC_URI="mirror://apache/jakarta/commons/el/source/${P}-src.tar.gz"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="jikes"
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/servletapi-2.4
+ >=dev-java/ant-1.5
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jdk-1.4"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv build.properties build.properties.old
+
+ local SAPI="`java-config -p servletapi-2.4`"
+ echo "servlet-api.jar=${SAPI/*:/}" >> build.properties
+ echo "jsp-api.jar=${SAPI/:*/}" >> build.properties
+ echo "junit.jar = `java-config --classpath=junit`" >> build.properties
+ echo "servletapi.build.notrequired = true" >> build.properties
+ echo "jspapi.build.notrequired = true" >> build.properties
+
+ # Build.xml is broken, fix it
+ sed -i "s:../LICENSE:./LICENSE.txt:" build.xml
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="{antflags} -Dbuild.compiler=jikes"
+ ant ${antflags}
+}
+
+src_install () {
+ java-pkg_dojar dist/${PN}.jar || die "Unable to install"
+ dodoc LICENSE.txt RELEASE-NOTES.txt
+ dohtml STATUS.html PROPOSAL.html
+}
+
diff --git a/dev-java/commons-el/files/digest-commons-el-1.0 b/dev-java/commons-el/files/digest-commons-el-1.0
new file mode 100644
index 000000000000..8c71540ed219
--- /dev/null
+++ b/dev-java/commons-el/files/digest-commons-el-1.0
@@ -0,0 +1 @@
+MD5 25038283a0b5f638db5e891295d20020 commons-el-1.0-src.tar.gz 64009
diff --git a/dev-java/commons-el/metadata.xml b/dev-java/commons-el/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-el/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>