summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-04 14:03:26 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2004-12-04 14:03:26 +0000
commit7af7f69fe6e3c3fa08f10ef916499fb6c3bd0c11 (patch)
tree11349301e18570a28d079853387665576d0a2d53 /dev-java/fesi
parentFix typo, bug 72783 (Manifest recommit) (diff)
downloadgentoo-2-7af7f69fe6e3c3fa08f10ef916499fb6c3bd0c11.tar.gz
gentoo-2-7af7f69fe6e3c3fa08f10ef916499fb6c3bd0c11.tar.bz2
gentoo-2-7af7f69fe6e3c3fa08f10ef916499fb6c3bd0c11.zip
Initial import. Fixes #63296.
Diffstat (limited to 'dev-java/fesi')
-rw-r--r--dev-java/fesi/ChangeLog9
-rw-r--r--dev-java/fesi/Manifest5
-rw-r--r--dev-java/fesi/fesi-1.1.8.ebuild57
-rw-r--r--dev-java/fesi/files/digest-fesi-1.1.81
-rw-r--r--dev-java/fesi/files/fesibuild.patch75
-rw-r--r--dev-java/fesi/metadata.xml16
6 files changed, 163 insertions, 0 deletions
diff --git a/dev-java/fesi/ChangeLog b/dev-java/fesi/ChangeLog
new file mode 100644
index 000000000000..6bfe304ee740
--- /dev/null
+++ b/dev-java/fesi/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/fesi
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed unde the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fesi/ChangeLog,v 1.12 2004/12/04 14:03:26 karltk Exp $
+
+*fesi-1.1.8 (04 Dec 2004)
+
+ 04 Dec 2004; Karl Trygve Kalleberg <karltk@gentoo.org> fesi-1.1.8.ebuild:
+ Initial import. Ebuild submitted by Jan Brinkmann <lucky@the-luckduck.de>.
+ Fixes #63296.
diff --git a/dev-java/fesi/Manifest b/dev-java/fesi/Manifest
new file mode 100644
index 000000000000..e205a62f2799
--- /dev/null
+++ b/dev-java/fesi/Manifest
@@ -0,0 +1,5 @@
+MD5 a6fe7499daf0ce33f862032212096c4f fesi-1.1.8.ebuild 1254
+MD5 960f69b7fc61e696f6c24bcf21430b4d ChangeLog 317
+MD5 0637a933ecb6e8cedfc4ddfcf3491728 metadata.xml 310
+MD5 6298e6801fb87ff37447cca4d20feba8 files/digest-fesi-1.1.8 70
+MD5 6606050081debeafe38715c2cbe219ea files/fesibuild.patch 3292
diff --git a/dev-java/fesi/fesi-1.1.8.ebuild b/dev-java/fesi/fesi-1.1.8.ebuild
new file mode 100644
index 000000000000..97dfad752d9d
--- /dev/null
+++ b/dev-java/fesi/fesi-1.1.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fesi/fesi-1.1.8.ebuild,v 1.1 2004/12/04 14:03:26 karltk Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="JavaScript Interpreter written in Java"
+SRC_URI="http://dev.gentoo.org/~karltk/projects/java/distfiles/${P}.gentoo.tar.bz2"
+HOMEPAGE="http://www.lugrin.ch/fesi"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86" #karltk: ~amd64 is missing bsf-2.3"
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ jikes? ( >=dev-java/jikes-1.21 )
+ >=dev-java/ant-core-1.4
+ =dev-java/bsf-2.3*
+ =dev-java/oro-2.0*
+ >=dev-java/javacc-3.2"
+RDEPEND=">=virtual/jdk-1.3
+ =dev-java/gnu-regexp-1.1*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/fesibuild.patch
+
+ bf=build.properties
+ cd ant/
+ echo "javaccdir=`java-config -p javacc`" > ${bf}
+ echo "ororegexp=`java-config -p oro`" >> ${bf}
+ echo "gnuregexp=`java-config -p gnu-regexp-1`" >> ${bf}
+ echo "bsfdir=`java-config -p bsf-2.3`" >> ${bf}
+}
+
+src_compile() {
+ cd ant/
+
+ local antflags="jars"
+ if use doc; then
+ antflags="${antflags} docs"
+ fi
+ if use jikes; then
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
+ ant ${antflags} || die "failed to build"
+}
+
+src_install() {
+ java-pkg_dojar lib/fesi.jar
+
+ dodoc License.txt Readme.txt
+ if use doc; then
+ java-pkg_dohtml -r doc/html/*
+ fi
+}
diff --git a/dev-java/fesi/files/digest-fesi-1.1.8 b/dev-java/fesi/files/digest-fesi-1.1.8
new file mode 100644
index 000000000000..f36594ebaf30
--- /dev/null
+++ b/dev-java/fesi/files/digest-fesi-1.1.8
@@ -0,0 +1 @@
+MD5 8e2a31a28938bbe9ae89f0e403babb7d fesi-1.1.8.gentoo.tar.bz2 808213
diff --git a/dev-java/fesi/files/fesibuild.patch b/dev-java/fesi/files/fesibuild.patch
new file mode 100644
index 000000000000..9318ac3c6047
--- /dev/null
+++ b/dev-java/fesi/files/fesibuild.patch
@@ -0,0 +1,75 @@
+diff -uprN fesi-1.1.8.orig/ant/build.xml fesi-1.1.8/ant/build.xml
+--- fesi-1.1.8.orig/ant/build.xml 2003-09-29 11:08:58.000000000 +0200
++++ fesi-1.1.8/ant/build.xml 2004-11-21 23:43:20.519967656 +0100
+@@ -6,20 +6,7 @@
+ <property name="version.level" value="1.1.8"/>
+ <property name="version.date" value="29-Sep-2003"/>
+
+-
+- <!-- Allows us to use the IzPack Ant task -->
+- <taskdef name="izpack" classpath="${basedir}/lib/compiler.jar"
+- classname="com.izforge.izpack.ant.IzPackTask"/>
+-
+-
+- <!-- Referenced libraries -->
+- <property name="javaccdir" location = "C:/javadev/TOOLS/javacc-3.2/bin/lib/javacc.jar"/>
+- <property name="ororegexp" location="c:/javadev/LIBS/jakarta-oro-2.0.7/jakarta-oro-2.0.7.jar"/>
+- <property name="gnuregexp" location="c:/javadev/LIBS/gnu.regexp-1.1.4/lib/gnu-regexp-1.1.4.jar"/>
+-
+- <property name="bsfdir" location = "C:/javadev/LIBS/bsf-2.3.0/lib/bsf.jar"/>
+-
+- <property name="izpackdir" location = "C:/program files/IzPack"/>
++ <property file="ant/build.properties" />
+
+ <!-- Source content directory structure -->
+ <property name="src" location="src"/>
+@@ -143,7 +130,11 @@
+ <!-- Compile the java code from ${src} into ${build} -->
+ <target name="compile" depends="init"
+ description="compile the source " >
+- <javac srcdir="${src}" destdir="${build}" debug="true">
++ <javac srcdir="${src}"
++ destdir="${build}"
++ debug="true"
++ source="1.3"
++ target="1.3">
+ <classpath refid="project.compile.class.path"/>
+ </javac>
+ </target>
+@@ -170,6 +161,7 @@
+ <doctitle><![CDATA[<h1>Test</h1>]]></doctitle>
+ <bottom><![CDATA[<i>Copyright &#169; 2003 Jean-Marc Lugrin. All Rights Reserved. Licensed under LGPL</i>]]></bottom>
+ <link href="http://java.sun.com/j2se/1.4.2/docs/api/"/>
++ <classpath refid="project.compile.class.path"/>
+ </javadoc>
+ </target>
+
+diff -uprN fesi-1.1.8.orig/src/FESI/Interpreter/Version.in fesi-1.1.8/src/FESI/Interpreter/Version.in
+--- fesi-1.1.8.orig/src/FESI/Interpreter/Version.in 2003-08-26 17:38:56.000000000 +0200
++++ fesi-1.1.8/src/FESI/Interpreter/Version.in 1970-01-01 01:00:00.000000000 +0100
+@@ -1,25 +0,0 @@
+-// EcmaScriptEvaluateVisitor.java
+-// FESI Copyright (c) Jean-Marc Lugrin, 1999
+-//
+-// This program is free software; you can redistribute it and/or
+-// modify it under the terms of the GNU Lesser General Public
+-// License as published by the Free Software Foundation; either
+-// version 2 of the License, or (at your option) any later version.
+-
+-// This program is distributed in the hope that it will be useful,
+-// but WITHOUT ANY WARRANTY; without even the implied warranty of
+-// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+-// Lesser General Public License for more details.
+-
+-// You should have received a copy of the GNU Lesser General Public
+-// License along with this library; if not, write to the Free Software
+-// Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+-package FESI.Interpreter;
+-
+-/**
+- * Contains version identification
+- */
+-public class Version {
+- public static final String Level = "@VERSION.LEVEL@";
+- public static final String Date = "@VERSION.DATE@";
+-}
diff --git a/dev-java/fesi/metadata.xml b/dev-java/fesi/metadata.xml
new file mode 100644
index 000000000000..07afc222fffa
--- /dev/null
+++ b/dev-java/fesi/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+
+The library can be used to extend the capabilities of the EcmaScript
+interpreter, allowing a Java program to create an interpreter, to evaluate
+scripts, and to set and get properties of EcmaScript objects. It is largely
+compatible with the Netscape JSObject and JSExeption classes, simplifying the
+development of common code.
+
+</longdescription>
+</pkgmetadata>