summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-10-25 06:29:18 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-10-25 06:29:18 +0000
commit3ec5b1ea47b083525c11ea3eee3036d0d3ed27e0 (patch)
tree995f58144682d05b37544268f95849fffe99e89b /dev-java/icu4j
parentVersion bump #526688 by Hanno Boeck. (diff)
downloadgentoo-2-3ec5b1ea47b083525c11ea3eee3036d0d3ed27e0.tar.gz
gentoo-2-3ec5b1ea47b083525c11ea3eee3036d0d3ed27e0.tar.bz2
gentoo-2-3ec5b1ea47b083525c11ea3eee3036d0d3ed27e0.zip
Version bump to 54.1.1 (bug #526104)
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/icu4j')
-rw-r--r--dev-java/icu4j/ChangeLog7
-rw-r--r--dev-java/icu4j/icu4j-54.1.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index b6d33f425e26..e99a028279fe 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/icu4j
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.64 2014/08/10 20:15:08 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.65 2014/10/25 06:29:18 ercpe Exp $
+
+*icu4j-54.1.1 (25 Oct 2014)
+
+ 25 Oct 2014; Johann Schmitz <ercpe@gentoo.org> +icu4j-54.1.1.ebuild:
+ Version bump to 54.1.1 (bug #526104)
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> icu4j-3.8.1-r1.ebuild,
icu4j-4.0.1.1.ebuild, icu4j-4.2.1.1.ebuild, icu4j-4.4.1.1.ebuild,
diff --git a/dev-java/icu4j/icu4j-54.1.1.ebuild b/dev-java/icu4j/icu4j-54.1.1.ebuild
new file mode 100644
index 000000000000..e72d18ed9636
--- /dev/null
+++ b/dev-java/icu4j/icu4j-54.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-54.1.1.ebuild,v 1.1 2014/10/25 06:29:18 ercpe Exp $
+
+EAPI="5"
+
+# testdata.jar, icudata.jar and icutzdata.jar do not contain *.class files
+# but *.res files. These *.res data files are needed to build the final jar.
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A set of Java libraries providing Unicode and Globalization support"
+HOMEPAGE="http://www.icu-project.org/"
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${PV//./_}.tgz"
+
+LICENSE="icu"
+SLOT="52"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+# Beware of jdk version dependant code #361593
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+JAVA_PKG_BSFIX_NAME+=" common-targets.xml"
+
+EANT_DOC_TARGET="docs"
+EANT_TEST_TARGET="check"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dojar ${PN}-charset.jar
+ java-pkg_dojar ${PN}-localespi.jar
+
+ dohtml readme.html
+
+ use doc && java-pkg_dojavadoc doc
+ use examples && java-pkg_doexamples demos samples
+ use source && java-pkg_dosrc main/classes/*/src/com
+}