summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-06-04 17:48:28 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-06-04 17:48:28 +0000
commit21bbdf31d43400e038358247089fd70ccded80da (patch)
tree3ad2c363080b327a97336148fa5501c3fbe8c4da /dev-java/jansi
parentVersion bump. Switch to autotools-utils and EAPI5 (diff)
downloadgentoo-2-21bbdf31d43400e038358247089fd70ccded80da.tar.gz
gentoo-2-21bbdf31d43400e038358247089fd70ccded80da.tar.bz2
gentoo-2-21bbdf31d43400e038358247089fd70ccded80da.zip
Version bumped to 1.11; dropped keywords amd64-linux ppc ppc-macos x86-linux x86-macos as java-native doesn't have these, see bug #472322.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/jansi')
-rw-r--r--dev-java/jansi/ChangeLog12
-rw-r--r--dev-java/jansi/files/jansi-1.11-build.xml298
-rw-r--r--dev-java/jansi/jansi-1.11.ebuild50
3 files changed, 357 insertions, 3 deletions
diff --git a/dev-java/jansi/ChangeLog b/dev-java/jansi/ChangeLog
index 1628a08c8f61..150a18dad9b1 100644
--- a/dev-java/jansi/ChangeLog
+++ b/dev-java/jansi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jansi
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jansi/ChangeLog,v 1.4 2011/08/13 07:07:41 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jansi/ChangeLog,v 1.5 2013/06/04 17:48:28 tomwij Exp $
+
+*jansi-1.11 (04 Jun 2013)
+
+ 04 Jun 2013; Tom Wijsman <TomWij@gentoo.org> +files/jansi-1.11-build.xml,
+ +jansi-1.11.ebuild:
+ Version bumped to 1.11; dropped keywords amd64-linux ppc ppc-macos x86-linux
+ x86-macos as java-native doesn't have these, see bug #472322.
13 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> jansi-1.1.ebuild:
ppc stable wrt #348255
@@ -16,4 +23,3 @@
24 May 2010; Jean-Noël Rivasseau <elvanor@gentoo.org> +jansi-1.1.ebuild,
+metadata.xml:
Initial import.
-
diff --git a/dev-java/jansi/files/jansi-1.11-build.xml b/dev-java/jansi/files/jansi-1.11-build.xml
new file mode 100644
index 000000000000..058559ce0847
--- /dev/null
+++ b/dev-java/jansi/files/jansi-1.11-build.xml
@@ -0,0 +1,298 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/4/13 7:11 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jansi-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jansi-1.11"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.7/junit-4.7.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test.java"/>
+ <exclude name="**/Abstract*.java"/>
+ <exclude name="**/Test*.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/Abstract*.java"/>
+ <exclude name="**/Test*.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"
+ dest="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5"/>
+ <get src="http://repo.maven.apache.org/maven2/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"
+ dest="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.7"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.7/junit-4.7.jar"
+ dest="${maven.repo.local}/junit/junit/4.7/junit-4.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jansi/jansi-1.11.ebuild b/dev-java/jansi/jansi-1.11.ebuild
new file mode 100644
index 000000000000..b5892f484c0f
--- /dev/null
+++ b/dev-java/jansi/jansi-1.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jansi/jansi-1.11.ebuild,v 1.1 2013/06/04 17:48:28 tomwij Exp $
+
+EAPI="5"
+
+# TODO: Get tests (misses junit jar) and doc (missing classpath entries) working.
+JAVA_PKG_IUSE="source test"
+RESTRICT="test"
+
+inherit vcs-snapshot java-pkg-2 java-ant-2
+
+DESCRIPTION="Jansi is a small java library that allows you to use ANSI escape sequences in your console output"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/tarball/${PN}-project-${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/jansi-native:0"
+
+DEPEND="${CDEPEND}
+ test? ( dev-java/junit:4 )
+ >=virtual/jdk-1.5"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+S="${WORKDIR}/${P}/jansi"
+
+EANT_GENTOO_CLASSPATH="jansi-native"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+EANT_TEST_GENTOO_CLASSPATH="junit-4"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use source && java-pkg_dosrc src/main/java/org
+}