summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-19 21:48:49 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-19 21:48:49 +0000
commit082af620d0854759c806dbe2ca1df6f408ca1e9f (patch)
tree950bd3399aeb81d9c888c874c757d90fc10f1b8c /dev-java/javacup/javacup-0.10k.ebuild
parentadd security patch , mark x86 (Manifest recommit) (diff)
downloadgentoo-2-082af620d0854759c806dbe2ca1df6f408ca1e9f.tar.gz
gentoo-2-082af620d0854759c806dbe2ca1df6f408ca1e9f.tar.bz2
gentoo-2-082af620d0854759c806dbe2ca1df6f408ca1e9f.zip
initial import, ebuild created me, as a dep
Diffstat (limited to 'dev-java/javacup/javacup-0.10k.ebuild')
-rw-r--r--dev-java/javacup/javacup-0.10k.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/javacup/javacup-0.10k.ebuild b/dev-java/javacup/javacup-0.10k.ebuild
new file mode 100644
index 000000000000..5caa4754f481
--- /dev/null
+++ b/dev-java/javacup/javacup-0.10k.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/javacup/javacup-0.10k.ebuild,v 1.1 2004/09/19 21:48:49 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="CUP Parser Generator for Java"
+
+HOMEPAGE="http://www.cs.princeton.edu/~appel/modern/java/CUP/"
+SRC_URI="http://www.cs.princeton.edu/~appel/modern/java/CUP/java_cup_v10k.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="virtual/jdk"
+RDEPEND="virtual/jre"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ find . -name "*.class" -exec rm -f {} \;
+}
+
+src_compile() {
+ javac java_cup/*.java java_cup/runtime/*.java || die "failed to compile"
+ find java_cup -name "*.class" | xargs jar -cvf ${PN}.jar
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ dodoc CHANGELOG README LICENSE
+ dohtml manual.html
+}