summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-12-28 12:55:12 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-12-28 12:55:12 +0000
commit11fc53f6f404f83fbf4a19965b499a3c4e52b389 (patch)
tree9419224500ab2590c19c30f76aac012b1f3c72e6 /dev-java/libgconf-java
parentUpdated changelog (diff)
downloadgentoo-2-11fc53f6f404f83fbf4a19965b499a3c4e52b389.tar.gz
gentoo-2-11fc53f6f404f83fbf4a19965b499a3c4e52b389.tar.bz2
gentoo-2-11fc53f6f404f83fbf4a19965b499a3c4e52b389.zip
make it find jni.h
Diffstat (limited to 'dev-java/libgconf-java')
-rw-r--r--dev-java/libgconf-java/ChangeLog5
-rw-r--r--dev-java/libgconf-java/Manifest2
-rw-r--r--dev-java/libgconf-java/libgconf-java-2.8.2.ebuild19
3 files changed, 15 insertions, 11 deletions
diff --git a/dev-java/libgconf-java/ChangeLog b/dev-java/libgconf-java/ChangeLog
index dedd86961692..8aed17864935 100644
--- a/dev-java/libgconf-java/ChangeLog
+++ b/dev-java/libgconf-java/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/libgconf-java
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/ChangeLog,v 1.3 2004/12/21 20:07:25 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/ChangeLog,v 1.4 2004/12/28 12:55:12 axxo Exp $
+
+ 28 Dec 2004; Thomas Matthijs <axxo@gentoo.org> libgconf-java-2.8.2.ebuild:
+ make it find jni.h
04 Dec 2004; Karl Trygve Kalleberg <karltk@gentoo.org> :
Initial import. Fixes #70562.
diff --git a/dev-java/libgconf-java/Manifest b/dev-java/libgconf-java/Manifest
index ebecff35c550..afbf12dbd1bd 100644
--- a/dev-java/libgconf-java/Manifest
+++ b/dev-java/libgconf-java/Manifest
@@ -1,5 +1,5 @@
MD5 2ecd005a12bfdb7f4ce94b8d2570dffe ChangeLog 663
-MD5 bff9bb45e1b3add0e17e671ca1a71bfa libgconf-java-2.8.2.ebuild 3248
+MD5 670c6ab75d6c31b434248ee191ccf8ab libgconf-java-2.8.2.ebuild 3274
MD5 2e1952c33e5bcce8813dec9d43203e29 metadata.xml 1042
MD5 f68363dbf78345af0bea956d309d2f66 files/digest-libgconf-java-2.8.2 71
MD5 03c4b5ccb943b51e5259e5046ff30719 files/libgconf-java-2.8.2_gentoo-PN-SLOT.patch 994
diff --git a/dev-java/libgconf-java/libgconf-java-2.8.2.ebuild b/dev-java/libgconf-java/libgconf-java-2.8.2.ebuild
index 11544c9b1727..7971dbf554b5 100644
--- a/dev-java/libgconf-java/libgconf-java-2.8.2.ebuild
+++ b/dev-java/libgconf-java/libgconf-java-2.8.2.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.8.2.ebuild,v 1.1 2004/12/04 13:34:12 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.8.2.ebuild,v 1.2 2004/12/28 12:55:12 axxo Exp $
#
-# WARNING: Because java-gnome is a set of bindings to native GNOME libraries,
-# it has, like any GNOME project, a massive autoconf setup, and unlike many
+# WARNING: Because java-gnome is a set of bindings to native GNOME libraries,
+# it has, like any GNOME project, a massive autoconf setup, and unlike many
# other java libraries, it has its own [necessary] `make install` step.
# As a result, this ebuild is VERY sensitive to the internal layout of the
# upstream project. Because these issues are currently evolving upstream,
# simply version bumping this ebuild is not likely to work but FAILURES WILL
# BE VERY SUBTLE IF IT DOESN NOT WORK.
-#
+#
inherit eutils gnome.org
@@ -21,7 +21,7 @@ RDEPEND=">=gnome-base/gconf-2.8.0
>=virtual/jre-1.2"
#
-# Unfortunately we need to run autogen to do the variable substitutions, so
+# Unfortunately we need to run autogen to do the variable substitutions, so
# regardless of whether or not there is an upstream ./configure [at time of
# writing there isn't] we need to recreate it
#
@@ -44,6 +44,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/libgconf-java-2.8.2_gentoo-PN-SLOT.patch
+ sed -i "s|^\(JAVA_INCLUDES = \)|\1 -I\${JDK_HOME}/include -I\${JDK_HOME}/include/linux/|" src/Makefile.in || die "sed failed"
}
src_compile() {
@@ -54,7 +55,7 @@ src_compile() {
cd ${S}
#
- # Ordinarily, moving things around post `make install` would do
+ # Ordinarily, moving things around post `make install` would do
# the trick, but there are paths hard coded in .pc files and in the
# `make install` step itself that need to be influenced.
#
@@ -63,7 +64,7 @@ src_compile() {
--host=${CHOST} \
--prefix=/usr \
${conf} || die "./configure failed"
- make || die
+ make || die "compile failed"
}
src_install() {
@@ -81,7 +82,7 @@ src_install() {
# the upstream install scatters things around a bit. The following cleans
# that up to make it policy compliant.
- # I originally tried java-pkg_dojar here, but it has a few glitches
+ # I originally tried java-pkg_dojar here, but it has a few glitches
# like not copying symlinks as symlinks which makes a mess.
dodir /usr/share/${PN}-${SLOT}/lib
@@ -92,7 +93,7 @@ src_install() {
cd ${S}/src/java
zip -r ${D}/usr/share/${PN}-${SLOT}/src/libgconf-java-${PV}.src.zip *
- # again, with dojar misbehaving, better do to this manually for the
+ # again, with dojar misbehaving, better do to this manually for the
# time being. Yes, this is bad hard coding, but what in this ebuild isn't?
# karltk: Missing generation of dependencies, should be fixed.