summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2004-06-17 10:45:08 +0000
committerLim Swee Tat <st_lim@gentoo.org>2004-06-17 10:45:08 +0000
commit0a0341ebd1ec4a27e7b50931c9de7c7a265c14d9 (patch)
tree15cc6ab4fa96285812a594d448e6864359657b6d /dev-java/rhino
parentQA - inherit eutils, don't assign default S. (Manifest recommit) (diff)
downloadgentoo-2-0a0341ebd1ec4a27e7b50931c9de7c7a265c14d9.tar.gz
gentoo-2-0a0341ebd1ec4a27e7b50931c9de7c7a265c14d9.tar.bz2
gentoo-2-0a0341ebd1ec4a27e7b50931c9de7c7a265c14d9.zip
Fixed up the proxy problem with a rather dirty sed script. It should work. Do tell me if it does not.
Diffstat (limited to 'dev-java/rhino')
-rw-r--r--dev-java/rhino/rhino-1.5-r5.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-java/rhino/rhino-1.5-r5.ebuild b/dev-java/rhino/rhino-1.5-r5.ebuild
index 739233408d48..e7e2f27dcbe7 100644
--- a/dev-java/rhino/rhino-1.5-r5.ebuild
+++ b/dev-java/rhino/rhino-1.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.5-r5.ebuild,v 1.3 2004/05/09 22:04:01 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.5-r5.ebuild,v 1.4 2004/06/17 10:45:08 st_lim Exp $
inherit java-pkg
@@ -21,6 +21,12 @@ RESTRICT="nomirror"
src_compile() {
local antflags="jar"
+
+ [ -n $http_proxy ] && proxyhost=`echo $http_proxy | sed -e "s/^\(.*\):\([0-9]*\)/\1/g" ` && \
+ proxyport=`echo $http_proxy | sed -e "s/^\(.*\):\([0-9]*\)/\2/g" ` && \
+ sed -e "s:<target name=\"get-swing-ex\" unless=\"swing-ex-available\">:&\n<setproxy proxyhost=\"${proxyhost}\" proxyport=\"${proxyport}\" />:g" \
+ -i toolsrc/build.xml
+
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant ${antflags} || die "compilation error"
}