summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J. Cohen <mjc@gentoo.org>2002-06-23 05:27:41 +0000
committerMichael J. Cohen <mjc@gentoo.org>2002-06-23 05:27:41 +0000
commitb2c9d540616975d06cf9ff0d1a6182fc999958f6 (patch)
treef8635e4ea09da3c2c629939450cd7473b6d20e50 /dev-java
parentCardoe's -r4 finally works. (diff)
downloadgentoo-2-b2c9d540616975d06cf9ff0d1a6182fc999958f6.tar.gz
gentoo-2-b2c9d540616975d06cf9ff0d1a6182fc999958f6.tar.bz2
gentoo-2-b2c9d540616975d06cf9ff0d1a6182fc999958f6.zip
Cardoe's -r4 works, woohoo.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.0-r4.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.0-r4.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.0-r4.ebuild
new file mode 100644
index 000000000000..2b6bb3e82d48
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.4.0-r4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Daniel Mettler <mettlerd@icu.unizh.ch>
+# /space/gentoo/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.0-r3.ebuild,v 1.1 2002/06/16 00:24:09 rphillips Exp
+
+At="j2sdk-1_4_0_01-linux-i586.bin"
+S=${WORKDIR}/j2sdk1.4.0_01
+SRC_URI=""
+DESCRIPTION="Sun's J2SE Development Kit, version 1.4.0"
+HOMEPAGE="http://java.sun.com/j2se/1.4/download.html"
+LICENSE="SUN Binary"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ >=dev-java/java-config-0.1.3"
+RDEPEND="$DEPEND"
+
+PROVIDE="virtual/jre-1.4
+ virtual/jdk-1.4
+ virtual/java-scheme-2"
+
+src_unpack() {
+ if [ ! -f ${DISTDIR}/${At} ] ; then
+ die "Please download ${At} from ${HOMEPAGE} (select the \"Linux GNUZIP Tar shell script\" package format of the SDK) and move it to ${DISTDIR}"
+ fi
+ tail +336 ${DISTDIR}/${At} > install.sfx
+ chmod +x install.sfx
+ ./install.sfx || die
+ rm install.sfx
+}
+
+src_install () {
+ local dirs="bin include jre lib"
+ dodir /opt/${P}
+
+
+ for i in $dirs ; do
+ cp -a $i ${D}/opt/${P}/
+ done
+
+ dodoc COPYRIGHT README LICENSE
+ dohtml README.html
+
+ doman man/man1/*.1
+
+ dodir /opt/${P}/share/
+ cp -a demo src.zip ${D}/opt/${P}/share/
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/${P}/jre/plugin/i386/ns610/libjavaplugin_oji.so /usr/lib/mozilla/plugins/
+ fi
+
+ dodir /etc/env.d/java
+ sed \
+ -e "s/@P@/${P}/g" \
+ -e "s/@PV@/${PV}/g" \
+ -e "s/@PF@/${PF}/g" \
+ < ${FILESDIR}/sun-jdk-${PV} \
+ > ${D}/etc/env.d/java/20sun-jdk-${PV}
+}
+
+pkg_postinst () {
+ if [ "`use mozilla`" ] ; then
+ einfo "The Mozilla browser plugin has been installed as /usr/lib/mozilla/plugins/libjavaplugin_oji140.so"
+ else
+ einfo "To install the Java plugin for Mozilla manually, do:"
+ einfo "ln -s /opt/${P}/jre/plugin/i386/ns610/libjavaplugin_oji140.so /usr/lib/mozilla/plugins/"
+ einfo "(Make certain the directory /usr/lib/mozilla/plugins exists first)"
+ fi
+}