summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-05-02 14:50:50 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-05-02 14:50:50 +0000
commitb9508260e544cbf56ecb528f4644b7f164c1e4be (patch)
tree52078a1e6f60719b2cfd601360a06711627cbc96 /dev-lang/ghc-bin/ghc-bin-6.4.ebuild
parentghc-bin-6.4 remains masked as long as ghc-6.4 is masked. (diff)
downloadgentoo-2-b9508260e544cbf56ecb528f4644b7f164c1e4be.tar.gz
gentoo-2-b9508260e544cbf56ecb528f4644b7f164c1e4be.tar.bz2
gentoo-2-b9508260e544cbf56ecb528f4644b7f164c1e4be.zip
Added a binary version of ghc-6.4 for x86 (hardmasked for now).
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lang/ghc-bin/ghc-bin-6.4.ebuild')
-rw-r--r--dev-lang/ghc-bin/ghc-bin-6.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-lang/ghc-bin/ghc-bin-6.4.ebuild b/dev-lang/ghc-bin/ghc-bin-6.4.ebuild
new file mode 100644
index 000000000000..a03ee14cf481
--- /dev/null
+++ b/dev-lang/ghc-bin/ghc-bin-6.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-6.4.ebuild,v 1.1 2005/05/02 14:50:50 kosmikus Exp $
+
+IUSE="" # use the non-binary version if you want to have more choice
+
+DESCRIPTION="Glasgow Haskell Compiler"
+# list all arches for proper digest building:
+SRC_URI="x86? ( mirror://gentoo/${P}-x86.tbz2 )"
+HOMEPAGE="http://www.haskell.org"
+
+LICENSE="as-is"
+KEYWORDS="~x86 -amd64 -ppc -sparc -alpha"
+SLOT="0"
+
+RESTRICT="nostrip" # already stripped
+
+LOC="/opt/ghc"
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.6.1
+ >=sys-devel/gcc-2.95.3
+ =sys-libs/readline-5*"
+
+PROVIDE="virtual/ghc"
+
+S="${WORKDIR}"
+
+src_compile() {
+ sed -i "s|/usr|${LOC}|g" usr/bin/* usr/lib/ghc-${PV}/package.conf
+ mkdir -p ./${LOC}
+ mv usr/* ./${LOC}
+}
+
+src_install () {
+ cp -pr * ${D}
+ insinto /etc/env.d
+ doins ${FILESDIR}/10ghc
+}