summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-25 01:57:00 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-25 01:57:00 +0000
commit2cdbef36f10621021fa601f66dbdf36ff96a6f32 (patch)
tree7517bba3fc3f6588dd5bb9d30d745fd8182ea6b6 /dev-lang/lua/lua-4.0.ebuild
parentPatched Ebuild (diff)
downloadgentoo-2-2cdbef36f10621021fa601f66dbdf36ff96a6f32.tar.gz
gentoo-2-2cdbef36f10621021fa601f66dbdf36ff96a6f32.tar.bz2
gentoo-2-2cdbef36f10621021fa601f66dbdf36ff96a6f32.zip
New package
Diffstat (limited to 'dev-lang/lua/lua-4.0.ebuild')
-rw-r--r--dev-lang/lua/lua-4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lang/lua/lua-4.0.ebuild b/dev-lang/lua/lua-4.0.ebuild
new file mode 100644
index 000000000000..4a330465761e
--- /dev/null
+++ b/dev-lang/lua/lua-4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Larry Cow <larrycow@free.fr>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-4.0.ebuild,v 1.1 2002/04/25 01:57:00 rphillips Exp $
+
+P="lua"
+S=${WORKDIR}/${P}
+DESCRIPTION="A powerful light-weight programming language designed for extending applications."
+SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.lua.org/"
+
+DEPEND="virtual/glibc"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ patch < ${FILESDIR}/lua-4.0-config.patch
+
+ emake || die
+ make so || die
+}
+
+src_install () {
+ make \
+ INSTALL_BIN=${D}/usr/bin \
+ INSTALL_MAN=${D}/usr/share/man/man1 \
+ INSTALL_INC=${D}/usr/include \
+ INSTALL_LIB=${D}/usr/lib \
+ install || die
+}