summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-17 01:41:25 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-17 01:41:25 +0000
commit61be87bbb968da081958ce586b0cc595ad833875 (patch)
tree38b004962c51823385f1fe88abe8c5e2bf1e280f /dev-lang/mosml
parentStable for HPPA (bug #280393). (diff)
downloadgentoo-2-61be87bbb968da081958ce586b0cc595ad833875.tar.gz
gentoo-2-61be87bbb968da081958ce586b0cc595ad833875.tar.bz2
gentoo-2-61be87bbb968da081958ce586b0cc595ad833875.zip
Respecting CPP
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-lang/mosml')
-rw-r--r--dev-lang/mosml/ChangeLog6
-rw-r--r--dev-lang/mosml/mosml-2.01-r1.ebuild5
-rw-r--r--dev-lang/mosml/mosml-2.01.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/dev-lang/mosml/ChangeLog b/dev-lang/mosml/ChangeLog
index c60cf0924ab7..38c674559958 100644
--- a/dev-lang/mosml/ChangeLog
+++ b/dev-lang/mosml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mosml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/ChangeLog,v 1.11 2009/07/23 23:14:32 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/ChangeLog,v 1.12 2009/08/17 01:41:25 vostorga Exp $
+
+ 17 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> mosml-2.01.ebuild,
+ mosml-2.01-r1.ebuild:
+ Respecting CPP
23 Jul 2009; Víctor Ostorga <vostorga@gentoo.org> mosml-2.01.ebuild,
mosml-2.01-r1.ebuild:
diff --git a/dev-lang/mosml/mosml-2.01-r1.ebuild b/dev-lang/mosml/mosml-2.01-r1.ebuild
index ecbd7e7e4af5..9f44f1538f0b 100644
--- a/dev-lang/mosml/mosml-2.01-r1.ebuild
+++ b/dev-lang/mosml/mosml-2.01-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01-r1.ebuild,v 1.3 2009/07/23 23:14:32 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01-r1.ebuild,v 1.4 2009/08/17 01:41:25 vostorga Exp $
inherit eutils
@@ -27,7 +27,8 @@ src_unpack() {
}
src_compile() {
- emake CC=$(tc-getCC) MOSMLHOME=/opt/mosml world || die
+ emake CC=$(tc-getCC) CPP="$(tc-getCPP) -P -traditional -Dunix -Umsdos" \
+ MOSMLHOME=/opt/mosml world || die
}
src_install () {
diff --git a/dev-lang/mosml/mosml-2.01.ebuild b/dev-lang/mosml/mosml-2.01.ebuild
index ac63e354c5f2..3f89322138d6 100644
--- a/dev-lang/mosml/mosml-2.01.ebuild
+++ b/dev-lang/mosml/mosml-2.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01.ebuild,v 1.8 2009/07/23 23:14:32 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01.ebuild,v 1.9 2009/08/17 01:41:25 vostorga Exp $
inherit toolchain-funcs
@@ -17,7 +17,8 @@ DEPEND=""
RDEPEND=""
src_compile() {
- emake CC="$(tc-getCC)" MOSMLHOME=/opt/mosml world || die
+ emake CC=$(tc-getCC) CPP="$(tc-getCPP) -P -traditional -Dunix -Umsdos" \
+ MOSMLHOME=/opt/mosml world || die
}
src_install () {