summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-06-17 19:01:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-06-17 19:01:32 +0000
commit1c857824571d8e3c7deed912a4266e42956cf542 (patch)
treee26c57bdf4f3bb74aa98d7d9210b8d2f23695cf1 /dev-lang/nasm
parentversion bump (diff)
downloadgentoo-2-1c857824571d8e3c7deed912a4266e42956cf542.tar.gz
gentoo-2-1c857824571d8e3c7deed912a4266e42956cf542.tar.bz2
gentoo-2-1c857824571d8e3c7deed912a4266e42956cf542.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/nasm')
-rw-r--r--dev-lang/nasm/nasm-2.03.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-lang/nasm/nasm-2.03.ebuild b/dev-lang/nasm/nasm-2.03.ebuild
deleted file mode 100644
index d845f7686ba5..000000000000
--- a/dev-lang/nasm/nasm-2.03.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-2.03.ebuild,v 1.1 2008/06/10 16:44:49 mr_bones_ Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="groovy little assembler"
-HOMEPAGE="http://nasm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nasm/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
-IUSE="doc build"
-
-DEPEND="!build? ( dev-lang/perl )
- doc? ( virtual/ghostscript sys-apps/texinfo )"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- if [ "$(gcc-major-version)" -eq "2" ] ; then
- cd "${S}"
- sed -i \
- -e 's:-std=c99::g' \
- configure \
- || die "sed failed"
- fi
-}
-
-src_compile() {
- strip-flags
- econf || die
-
- if use build; then
- emake nasm || die "emake failed"
- else
- emake all || die "emake failed"
- emake rdf || die "emake failed"
- if use doc ; then
- emake doc || die "emake failed"
- fi
- fi
-}
-
-src_install() {
- if use build; then
- dobin nasm || die "dobin failed"
- else
- dobin nasm ndisasm rdoff/{ldrdf,rdf2bin,rdf2ihx,rdfdump,rdflib,rdx} \
- || die "dobin failed"
- dosym /usr/bin/rdf2bin /usr/bin/rdf2com
- doman nasm.1 ndisasm.1
- dodoc AUTHORS CHANGES ChangeLog README TODO
- if use doc; then
- doinfo doc/info/*
- dohtml doc/html/*
- dodoc doc/nasmdoc.*
- fi
- fi
-}