summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-10-29 17:38:45 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-10-29 17:38:45 +0000
commit623bce4613cadae55efb74cda7eae17b029296eb (patch)
treef2a30d09e5debde3a5c5f9766688f460f7b558b4 /dev-lang/prc-tools/files
parentVersion bump. (diff)
downloadgentoo-2-623bce4613cadae55efb74cda7eae17b029296eb.tar.gz
gentoo-2-623bce4613cadae55efb74cda7eae17b029296eb.tar.bz2
gentoo-2-623bce4613cadae55efb74cda7eae17b029296eb.zip
Version bump.
Diffstat (limited to 'dev-lang/prc-tools/files')
-rw-r--r--dev-lang/prc-tools/files/digest-prc-tools-2.35
-rw-r--r--dev-lang/prc-tools/files/prc-tools-2.3-compilefix.patch292
2 files changed, 297 insertions, 0 deletions
diff --git a/dev-lang/prc-tools/files/digest-prc-tools-2.3 b/dev-lang/prc-tools/files/digest-prc-tools-2.3
new file mode 100644
index 000000000000..4de07be0bcd0
--- /dev/null
+++ b/dev-lang/prc-tools/files/digest-prc-tools-2.3
@@ -0,0 +1,5 @@
+MD5 038a42a71a984fee6f906abc85a032ec prc-tools-2.3.tar.gz 333417
+MD5 2da8def15d28af3ec6af0982709ae90a binutils-2.14.tar.bz2 10921504
+MD5 70e4ade69a2dff2c7b9af9a4ef44798f gdb-5.3.tar.bz2 11198721
+MD5 1135a104e9fa36fdf7c663598fab5c40 gcc-3.3.1.tar.bz2 23544362
+MD5 87ee083a830683e2aaa57463940a0c3c gcc-2.95.3.tar.bz2 9848842
diff --git a/dev-lang/prc-tools/files/prc-tools-2.3-compilefix.patch b/dev-lang/prc-tools/files/prc-tools-2.3-compilefix.patch
new file mode 100644
index 000000000000..ef22d41d3ff6
--- /dev/null
+++ b/dev-lang/prc-tools/files/prc-tools-2.3-compilefix.patch
@@ -0,0 +1,292 @@
+--- prc-tools-2.3/binutils/configure.in 2003-06-12 15:33:14.000000000 +0100
++++ prc-tools-2.3/binutils/configure.in.plasmaroo.sandboxSafe 2003-10-27 19:23:34.000000000 +0000
+@@ -945,36 +945,37 @@
+ fi
+ fi
+
+-# Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while test $# != 0 ; do
+- if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if test -d $2 ; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++## Handle ${copy_dirs}
++## *** DISABLED *** for happy sandboxing!
++#set fnord ${copy_dirs}
++#shift
++#while test $# != 0 ; do
++# if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if test -d $2 ; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Work in distributions that contain no compiler tools, like Autoconf.
+ tentative_cc=""
+--- prc-tools-2.3/gcc/configure.in 2003-10-27 19:02:11.000000000 +0000
++++ prc-tools-2.3/gcc/configure.in.plasmaroo.sandboxSafe 2003-10-27 19:25:39.000000000 +0000
+@@ -905,36 +905,37 @@
+ fi
+ fi
+
+-# Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while test $# != 0 ; do
+- if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if test -d $2 ; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++## Handle ${copy_dirs}
++## *** DISABLED *** for happy sandboxing!
++#set fnord ${copy_dirs}
++#shift
++#while test $# != 0 ; do
++# if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if test -d $2 ; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Work in distributions that contain no compiler tools, like Autoconf.
+ tentative_cc=""
+--- prc-tools-2.3/gcc295/configure.in 2002-05-15 00:47:22.000000000 +0100
++++ prc-tools-2.3/gcc295/configure.in 2003-07-01 22:02:49.000000000 +0100
+@@ -470,36 +470,39 @@
+ esac
+ fi
+
+ # Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while [ $# != 0 ]; do
+- if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if [ -d $2 ]; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++### DISABLED ---> plasmaroo@plasmaroo.squirrelserver.co.uk
++### prc-tools compile fix to prevent sandbox
++### errors
++#set fnord ${copy_dirs}
++#shift
++#while [ $# != 0 ]; do
++# if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if [ -d $2 ]; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Configure extra directories which are host specific
+
+--- prc-tools-2.3/gdb/configure.in 2002-12-10 21:34:10.000000000 +0000
++++ prc-tools-2.3/gdb/configure.in 2003-07-03 17:49:38.000000000 +0100
+@@ -909,35 +909,38 @@
+ fi
+
+ # Handle ${copy_dirs}
+-set fnord ${copy_dirs}
+-shift
+-while test $# != 0 ; do
+- if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
+- :
+- else
+- echo Copying $1 to $2
+-
+- # Use the install script to create the directory and all required
+- # parent directories.
+- if test -d $2 ; then
+- :
+- else
+- echo >config.temp
+- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
+- fi
+-
+- # Copy the directory, assuming we have tar.
+- # FIXME: Should we use B in the second tar? Not all systems support it.
+- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
+-
+- # It is the responsibility of the user to correctly adjust all
+- # symlinks. If somebody can figure out how to handle them correctly
+- # here, feel free to add the code.
+-
+- echo $1 > $2/COPIED
+- fi
+- shift; shift
+-done
++### DISABLED ---> plasmaroo@plasmaroo.squirrelserver.co.uk
++### prc-tools compile fix to prevent sandbox
++### errors
++# set fnord ${copy_dirs}
++# shift
++# while test $# != 0 ; do
++# if test -f $2/COPIED && test x"`cat $2/COPIED`" = x"$1" ; then
++# :
++# else
++# echo Copying $1 to $2
++#
++# # Use the install script to create the directory and all required
++# # parent directories.
++# if test -d $2 ; then
++# :
++# else
++# echo >config.temp
++# ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
++# fi
++#
++# # Copy the directory, assuming we have tar.
++# # FIXME: Should we use B in the second tar? Not all systems support it.
++# (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
++#
++# # It is the responsibility of the user to correctly adjust all
++# # symlinks. If somebody can figure out how to handle them correctly
++# # here, feel free to add the code.
++#
++# echo $1 > $2/COPIED
++# fi
++# shift; shift
++#done
+
+ # Work in distributions that contain no compiler tools, like Autoconf.
+ tentative_cc=""
+--- prc-tools-2.3/doc/Makefile.in 2003-09-07 17:53:54.000000000 +0100
++++ prc-tools-2.3/doc/Makefile.in.plasmaroo.sandboxSafe 2003-10-27 19:31:06.000000000 +0000
+@@ -17,7 +17,7 @@
+ palmdev_prefix = @palmdev_prefix@
+ infodir = @infodir@
+ mandir = @mandir@
+-htmldir = @htmldocs_prefix@
++htmldir = ${D}/@htmldocs_prefix@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@