summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-07-06 20:40:57 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-07-06 20:40:57 +0000
commit4533f1b09546448d5766eb88249ddb0dfe6135f5 (patch)
tree92c7e82d9eab9f2f4213dc417235ee4792f8c328 /dev-lang
parentAdd fileselect dialog patch from Ximian/Suse. (Manifest recommit) (diff)
downloadgentoo-2-4533f1b09546448d5766eb88249ddb0dfe6135f5.tar.gz
gentoo-2-4533f1b09546448d5766eb88249ddb0dfe6135f5.tar.bz2
gentoo-2-4533f1b09546448d5766eb88249ddb0dfe6135f5.zip
Move 3.07 to stable on x86, and add script to ease the 3.06 -> 3.07 transition
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/files/ocaml-rebuild.sh45
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild15
3 files changed, 63 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 5a22f4223380..952330467218 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.31 2004/07/02 04:29:48 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.32 2004/07/06 20:40:57 mattam Exp $
+
+ 06 Jul 2004; Matthieu Sozeau <mattam@gentoo.org> +files/ocaml-rebuild.sh,
+ ocaml-3.07-r1.ebuild:
+ Move to stable on x86, adding a rebuilding script.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> ocaml-3.06-r1.ebuild,
ocaml-3.06-r2.ebuild, ocaml-3.06.ebuild, ocaml-3.07-r1.ebuild,
diff --git a/dev-lang/ocaml/files/ocaml-rebuild.sh b/dev-lang/ocaml/files/ocaml-rebuild.sh
new file mode 100644
index 000000000000..bb01c31c46cb
--- /dev/null
+++ b/dev-lang/ocaml/files/ocaml-rebuild.sh
@@ -0,0 +1,45 @@
+#!/bin/sh
+# run like this: ocaml-rebuild.sh [emerge_options]
+
+emerge=/usr/bin/emerge
+qpkg=/usr/bin/qpkg
+
+if [ ! -x $qpkg ]
+then
+ echo "You need to emerge gentoolkit for this script to work"
+ exit 1
+fi
+
+deps=`$qpkg -nc -n -q -I dev-lang/ocaml-3.06 | grep -v -e "\(DEPEND.*\)\|\(dev-lang.*\)" | sort | uniq`
+toclean=""
+
+for dep in $deps
+ do
+ dirs=`find /var/db/pkg/ -name ${dep}`
+
+ for dir in $dirs
+ do
+ if [ -d $dir ]
+ then
+ ocamldep=`grep dev-lang/ocaml $dir/DEPEND > /dev/null`
+ if [[ $ocamldep -eq 0 ]]
+ then
+ SLOT=`cat $dir/SLOT`
+ if [[ "$SLOT" = "" || "$SLOT" = "0" ]]
+ then
+ category=`cat $dir/CATEGORY`
+ toclean="=$category/$dep $toclean"
+ fi
+ fi
+ fi
+ done
+done
+
+if [ "$toclean" != "" ]
+then
+ cmd="$emerge $@ $toclean"
+ #echo "Debug:" $cmd
+ $cmd
+else
+ echo "Nothing to update"
+fi
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index eac8f4c036ab..dfe28676a3a9 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.12 2004/07/02 04:29:48 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.13 2004/07/06 20:40:57 mattam Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc alpha ~ia64 -amd64 hppa"
+KEYWORDS="x86 ~sparc ~ppc alpha ~ia64 -amd64 hppa"
IUSE="tcltk"
DEPEND="virtual/libc
@@ -63,3 +63,14 @@ src_install() {
# documentation
dodoc Changes INSTALL LICENSE README Upgrading
}
+
+pkg_postinst() {
+ echo
+ einfo "OCaml is not binary compatible from version to version,"
+ einfo "so you (may) need to rebuild all packages depending on it that"
+ einfo "are actually installed on your system."
+ einfo "To do so, you can run: "
+ einfo "sh ${FILESDIR}/ocaml-rebuild.sh [emerge options]"
+ einfo "Which will call emerge on all old packages with the given options"
+ echo
+} \ No newline at end of file