summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-15 01:27:50 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-15 01:27:50 +0000
commit99121f71a5120446a6945ab1902f8b07efbef0a5 (patch)
tree02027e017a18cc2ee856114bd34ab2ff406a93fa /dev-lang
parentinitial commit (diff)
downloadgentoo-2-99121f71a5120446a6945ab1902f8b07efbef0a5.tar.gz
gentoo-2-99121f71a5120446a6945ab1902f8b07efbef0a5.tar.bz2
gentoo-2-99121f71a5120446a6945ab1902f8b07efbef0a5.zip
bumped up release numbers of packages that were updated with the tcl/tk
update
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/entity/entity-0.7.2-r1.ebuild99
-rw-r--r--dev-lang/entity/files/digest-entity-0.7.2-r11
-rw-r--r--dev-lang/python/files/digest-python-2.0-r72
-rw-r--r--dev-lang/python/files/digest-python-2.1.1-r42
-rw-r--r--dev-lang/python/files/digest-python-2.2-r4 (renamed from dev-lang/python/files/digest-python-2.2-r3)0
-rw-r--r--dev-lang/python/python-2.0-r7.ebuild160
-rw-r--r--dev-lang/python/python-2.1.1-r4.ebuild124
-rw-r--r--dev-lang/python/python-2.2-r4.ebuild (renamed from dev-lang/python/python-2.2-r3.ebuild)2
-rw-r--r--dev-lang/swig/files/digest-swig-1.3.10-r1 (renamed from dev-lang/swig/files/digest-swig-1.3.10)0
-rw-r--r--dev-lang/swig/swig-1.3.10-r1.ebuild (renamed from dev-lang/swig/swig-1.3.10.ebuild)2
10 files changed, 390 insertions, 2 deletions
diff --git a/dev-lang/entity/entity-0.7.2-r1.ebuild b/dev-lang/entity/entity-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..9799ecad7aa0
--- /dev/null
+++ b/dev-lang/entity/entity-0.7.2-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/entity/entity-0.7.2-r1.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An XML Framework"
+SRC_URI="http://www.entity.cx/Download/files/${P}.tar.gz"
+HOMEPAGE="http://www.entity.cx"
+
+DEPEND=">=media-libs/imlib-1.9.10-r1
+ >=dev-libs/libpcre-3.2
+ tcltk? ( >=dev-lang/tk-8.1.1 )
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0-r4 )
+ sdl? ( >=media-libs/libsdl-1.1.7 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ opengl? ( >=x11-libs/gtkglarea-1.2.2 )
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 )"
+
+RDEPEND=">=media-libs/imlib-1.9.10-r1
+ >=dev-libs/libpcre-3.2
+ tcltk? ( >=dev-lang/tk-8.1.1 )
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0i-r4 )
+ sdl? ( >=media-libs/libsdl-1.1.7 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ opengl? ( >=x11-libs/gtkglarea-1.2.2-r1 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use tcltk`" ]
+ then
+ myconf="--enable-tcl=module --with-tcl=/usr/lib"
+ else
+ myconf="--enable-tcl=no"
+ fi
+ if [ "`use perl`" ]
+ then
+ myconf="$myconf --enable-perl=static"
+ else
+ myconf="$myconf --enable-perl=no"
+ fi
+ if [ "`use python`" ]
+ then
+ myconf="$myconf --enable-python=static"
+ else
+ myconf="$myconf --enable-python=no"
+ fi
+ if [ "`use ssl`" ]
+ then
+ myconf="$myconf --enable-openssl"
+ fi
+ if [ "`use sdl`" ]
+ then
+ myconf="$myconf --enable-sdl"
+ fi
+ if [ "`use gnome`" ]
+ then
+ myconf="$myconf --enable-gnome --enable-gdkimlib"
+ fi
+ if [ "`use opengl`" ]
+ then
+ myconf="$myconf --enable-gtkgl"
+ fi
+ try DEBIAN_ENTITY_MAGIC="voodoo" CFLAGS="$CFLAGS -I/usr/X11R6/include" ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ --enable-exec-class=yes \
+ --enable-gtk=module \
+ --enable-c=module $myconf \
+ --enable-javascript=yes --with-included-njs --enable-csinc
+ try make LDFLAGS="-L/usr/lib/python2.0/config/ -lpython2.0 `python-config --libs`"
+}
+
+src_install () {
+ make DESTDIR=${D} LD_LIBRARY_PATH=${D}/usr/lib install
+ insinto /usr/share/entity/stembuilder
+ doins stembuilder/*.e
+ chmod +x ${D}/usr/share/entity/stembuilder/stembuilder.e
+ insinto /usr/share/entity/apps
+ doins apps/*.e
+ chmod +x ${D}/usr/share/entity/apps/{enview,ev}.e
+ exeinto /usr/share/entity/examples
+ doexe examples/*.e
+ insinto /usr/share/entity/stembuilder/images
+ doins stembuilder/images/*.xpm
+
+ dodoc AUTHORS COPYING ChangeLog LICENSE NEWS README TODO
+ docinto txt
+ dodoc docs/README* docs/*.txt docs/*.ascii
+ docinto html
+ dodoc docs/*.html
+ docinto print
+ dodoc docs/*.ps
+ docinto sgml
+ dodoc docs/*.sgml
+}
+
diff --git a/dev-lang/entity/files/digest-entity-0.7.2-r1 b/dev-lang/entity/files/digest-entity-0.7.2-r1
new file mode 100644
index 000000000000..fc05108ce791
--- /dev/null
+++ b/dev-lang/entity/files/digest-entity-0.7.2-r1
@@ -0,0 +1 @@
+MD5 e3c99f264d40c7ae822033d2f77be293 entity-0.7.2.tar.gz 806912
diff --git a/dev-lang/python/files/digest-python-2.0-r7 b/dev-lang/python/files/digest-python-2.0-r7
new file mode 100644
index 000000000000..40b50e8ae750
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.0-r7
@@ -0,0 +1,2 @@
+MD5 4751f4619eda0b5ade9d9dd017e7c1ef BeOpen-Python-2.0.tar.bz2 3424256
+MD5 7c99113a11b03599d8494638f6d90b56 python-fchksum-1.1.tar.gz 32768
diff --git a/dev-lang/python/files/digest-python-2.1.1-r4 b/dev-lang/python/files/digest-python-2.1.1-r4
new file mode 100644
index 000000000000..68061e8232e1
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.1.1-r4
@@ -0,0 +1,2 @@
+MD5 eb34371c49b271abc74b42572883e1b4 Python-2.1.1.tgz 6189056
+MD5 03be17baafacc3508224d9542c0a61b3 python-fchksum-1.6.tar.gz 36864
diff --git a/dev-lang/python/files/digest-python-2.2-r3 b/dev-lang/python/files/digest-python-2.2-r4
index 0d73e1a12a91..0d73e1a12a91 100644
--- a/dev-lang/python/files/digest-python-2.2-r3
+++ b/dev-lang/python/files/digest-python-2.2-r4
diff --git a/dev-lang/python/python-2.0-r7.ebuild b/dev-lang/python/python-2.0-r7.ebuild
new file mode 100644
index 000000000000..a0f827c52819
--- /dev/null
+++ b/dev-lang/python/python-2.0-r7.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# Modified Tod M. Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r4.ebuild,v 1.1 2001/06/04 19:49:02 drobbins Exp
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.0-r7.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
+
+
+S=${WORKDIR}/Python-2.0
+S2=${WORKDIR}/python-fchksum-1.1
+DESCRIPTION="A really great language"
+SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
+ http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
+
+HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
+
+#tcltk depends is = becasue need to automate tcltk version number below
+DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ berkdb? ( >=sys-libs/db-3 )
+ tcltk? ( >=dev-lang/tk-8.0 )"
+
+RDEPEND="$DEPEND"
+PROVIDE="virtual/python-2.0"
+
+src_unpack() {
+ local mylibs
+ unpack BeOpen-Python-2.0.tar.bz2
+ cd ${S}/Modules
+ if [ "`use readline`" ]
+ then
+ sed -e 's/#readline/readline/' -e 's/-lreadline -ltermcap/-lreadline/' \
+ -e 's/#_curses _cursesmodule.c -lcurses -ltermcap/_curses _cursesmodule.c -lncurses/' \
+ -e 's/#crypt/crypt/' -e 's/# -lcrypt/-lcrypt/' \
+ Setup.in > Setup.new
+ mv Setup.new Setup.in
+ mylibs="-lreadline -lncurses -lcrypt"
+ fi
+
+#Added check for tcltk USE variable, if set build _tkinter
+#Need to automate tk and tcl version determination
+ if [ "`use tcltk`" ]
+ then
+
+#Determine tcl version by greping tcl.h
+#Probably don't need same for tk, but play it safe
+ local tcl_version
+ local tk_version
+
+ tcl_version=$(grep TCL_VERSION /usr/include/tcl.h | \
+ sed -e 's/.*\([0-9]\.[0-9]\).*/\1/')
+
+ tk_version=$(grep TK_VERSION /usr/include/tk.h | \
+ sed -e 's/.*\([0-9]\.[0-9]\).*/\1/')
+
+ sed -e 's:# _tkinter:_tkinter:' \
+ -e 's:#[[:blank:]]*-I/usr/local/include:-I/usr/include:' \
+ -e 's:#[[:blank:]]*-I/usr/X11R6/include:-I/usr/X11R6/include:' \
+ -e 's:#[[:blank:]]*-L/usr/local/lib:-L/usr/lib:' \
+ -e 's:#[[:blank:]]*-ltk8.0 -ltcl8.0:-ltk'${tk_version}' -ltcl'${tcl_version}':' \
+ -e 's:#[[:blank:]]*-L/usr/X11R6/lib:-L/usr/X11R6/lib:' \
+ -e 's:#[[:blank:]]-lX11:-lX11:' \
+ Setup.in > Setup.new
+ mv Setup.new Setup.in
+ mylibs="$mylibs -ltk${tk_version} -ltcl${tcl_version} -L/usr/X11R6/lib -lX11"
+ fi
+
+ if [ "`use berkdb`" ]
+ then
+ sed -e 's:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:' \
+ Setup.in > Setup.new
+ mv Setup.new Setup.in
+ mylibs="$mylibs -ldb-3.2"
+ fi
+
+#Removed the commenting out of TKPATH
+ sed -e 's/#_locale/_locale/' \
+ -e 's/#syslog/syslog/' \
+ -e 's:#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz:zlib zlibmodule.c -lz:' \
+ -e 's:^#termios:termios:' -e 's:^#resource:resource:' \
+ Setup.in > Setup
+ echo "fchksum fchksum.c md5_2.c" >> Setup
+ mylibs="-lpython2.0 $mylibs -lz -lutil"
+ cd ${S}/Modules
+
+ if [ "`use berkdb`" ]
+ then
+ #patch the dbmmodule to use db3's dbm compatibility code. That way, we're depending on db3 rather than
+ #old db1. We'll link with db3, of course.
+ cp dbmmodule.c dbmmodule.c.orig
+ sed -e '10,25d' -e '26i\' -e '#define DB_DBM_HSEARCH 1\' -e 'static char *which_dbm = "BSD db";\' -e '#include <db3/db.h>' dbmmodule.c.orig > dbmmodule.c
+ fi
+
+ cp ${FILESDIR}/pfconfig.h .
+ unpack python-fchksum-1.1.tar.gz
+
+ cd python-fchksum-1.1
+ mv md5.h ../md5_2.h
+ sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
+ sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
+
+ #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
+ cd ${S}/Python
+ cp pythonrun.c pythonrun.c.orig
+ sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
+
+ cat <<END > ${S}/python-config
+#!/bin/sh
+echo -lm $mylibs
+END
+
+}
+
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --without-libdb
+ #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
+ #included with python is for db 1.85 only.
+ cp Makefile Makefile.orig
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/Modules
+ cp Makefile.pre Makefile.orig
+ sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
+ Makefile.orig > Makefile.pre
+
+ # Parallel make does not work
+ cd ${S}
+ try make
+}
+
+src_install() {
+ dodir /usr
+ try make install prefix=${D}/usr
+ rm ${D}/usr/bin/python
+ dosym python2.0 /usr/bin/python
+ exeinto /usr/bin
+ doexe python-config
+ dodoc README
+
+#Change OPT setting in /usr/lib/python2.0/config/Makefile
+#to CFLAG from /etc/make.conf so optimaization is set for
+#subsequent module installs using distutil.
+#There is probably a better way :)
+ cd ${D}/usr/lib/python2.0/config
+ sed -e "s/OPT=[[:blank:]]*-g -O2 -Wall -Wstrict-prototypes/OPT= ${CFLAGS}/" \ Makefile > Makefile.new
+ mv Makefile.new Makefile
+
+#If USE tcltk lets install idle
+#Need to script the python version in the path
+ if [ "`use tcltk`" ]
+ then
+ mkdir ${D}/usr/lib/python2.0/tools
+ cd ${S}
+ mv Tools/idle ${D}/usr/lib/python2.0/tools/
+#don't quit understand dosym; put idle in PATH
+ ln -s /usr/lib/python2.0/tools/idle/idle.py ${D}/usr/bin/idle.py
+ fi
+}
+
diff --git a/dev-lang/python/python-2.1.1-r4.ebuild b/dev-lang/python/python-2.1.1-r4.ebuild
new file mode 100644
index 000000000000..ccdf39ee3cdd
--- /dev/null
+++ b/dev-lang/python/python-2.1.1-r4.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.1.1-r4.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
+
+S=${WORKDIR}/Python-${PV}
+FCHKSUM="python-fchksum-1.6"
+DESCRIPTION="A really great language"
+SRC_URI="http://www.python.org/ftp/python/${PV}/Python-${PV}.tgz
+ http://www.azstarnet.com/~donut/programs/fchksum/${FCHKSUM}.tar.gz"
+
+HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
+
+DEPEND="virtual/glibc >=sys-libs/zlib-1.1.3
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )
+ berkdb? ( >=sys-libs/db-3 )
+ tcltk? ( >=dev-lang/tk-8.0 )"
+
+RDEPEND="$DEPEND"
+PROVIDE="virtual/python-2.1"
+
+src_unpack() {
+ # unpack python
+ unpack Python-${PV}.tgz
+ # unpack fchksum and move pieces into Modules subdir
+ cd ${S}/Modules
+ unpack ${FCHKSUM}.tar.gz
+ cd ${FCHKSUM}
+ cp md5.h ../md5_2.h
+ cp cksum.[ch] sum.[ch] fchksum.h ..
+ sed 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
+ sed 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
+ # add fchksum configuration to Setup
+ cd ${S}
+ echo "fchksum fchksum.c md5_2.c cksum.c sum.c" >> Modules/Setup.dist
+
+ # adjust makefile to install pydoc into ${D} correctly
+ t=${S}/Makefile.pre.in
+ cp $t $t.orig || die
+ sed 's:install-platlib.*:& --install-scripts=$(BINDIR):' $t.orig > $t
+}
+
+src_compile() {
+ # python's config seems to ignore CFLAGS
+ export OPT=$CFLAGS
+
+ # configure fchksum
+ cd ${S}/Modules/${FCHKSUM}
+ ./configure
+ cp pfconfig.h ..
+
+ # adjust Setup to include the various modules we need
+ cd ${S}
+ scmd=""
+ # adjust for USE readline
+ if use readline; then
+ scmd="$scmd s:#\(readline .*\) -ltermcap:\1:;"
+ scmd="$scmd s:#\(_curses .*\) -lcurses -ltermcap:\1 -lncurses:;"
+ fi
+ # adjust for USE tcltk
+ if use tcltk; then
+ # Find the version of tcl/tk that has headers installed.
+ # This will be the most recently merged, not necessarily the highest
+ # version number.
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ tkv=$( grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+ # adjust Setup to match
+ scmd="$scmd s:# \(_tkinter \):\1:;"
+ scmd="$scmd s:#\(\t-ltk[0-9.]* -ltcl[0-9.]*\):\t-ltk$tkv -ltcl$tclv:;"
+ scmd="$scmd s:#\(\t-L/usr/X11R6/lib\):\1:;"
+ scmd="$scmd s:#\(\t-lX11.*\):\1:;"
+ fi
+ # adjust for USE berkdb
+ if use berkdb; then
+ # patch the dbmmodule to use db3's dbm compatibility code. That way,
+ # we're depending on db3 rather than old db1.
+ t=Modules/dbmmodule.c
+ cp $t $t.orig || die
+ sed \
+ -e '10,25d' \
+ -e '26i\' \
+ -e '#define DB_DBM_HSEARCH 1\' \
+ -e 'static char *which_dbm = "BSD db";\' \
+ -e '#include <db3/db.h>' \
+ $t.orig > $t
+ # now fix Setup
+ scmd="$scmd s:#dbm.*:dbm dbmmodule.c -I/usr/include/db3 -ldb-3.2:;"
+ fi
+ # no USE vars to switch off these adjustments:
+ scmd="$scmd s:#\(_locale .*\):\1:;" # access to ISO C locale support
+ scmd="$scmd s:#\(syslog .*\):\1:;" # syslog daemon interface
+ scmd="$scmd s:#\(zlib .*\):\1:;" # This require zlib 1.1.3 (or later).
+ scmd="$scmd s:#\(termios .*\):\1:;" # Steen Lumholt's termios module
+ scmd="$scmd s:#\(resource .*\):\1:;" # Jeremy Hylton's rlimit interface
+ sed "$scmd" Modules/Setup.dist > Modules/Setup
+
+ ./configure \
+ --prefix=/usr \
+ --without-libdb \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man
+ assert "Configure failed"
+ emake || die "Parallel make failed"
+}
+
+src_install() {
+ dodir /usr
+ make install prefix=${D}/usr || die
+ rm "${D}/usr/bin/python"
+ dosym python2.1 /usr/bin/python
+ dodoc README
+
+ # install our own custom python-config
+ exeinto /usr/bin
+ doexe ${FILESDIR}/python-config
+
+ # If USE tcltk lets install idle
+ # Need to script the python version in the path
+ if use tcltk; then
+ mkdir "${D}/usr/lib/python2.1/tools"
+ mv "${S}/Tools/idle" "${D}/usr/lib/python2.1/tools/"
+ dosym /usr/lib/python2.1/tools/idle/idle.py /usr/bin/idle.py
+ fi
+}
diff --git a/dev-lang/python/python-2.2-r3.ebuild b/dev-lang/python/python-2.2-r4.ebuild
index cf09963e7d85..0f4fd2b6c01a 100644
--- a/dev-lang/python/python-2.2-r3.ebuild
+++ b/dev-lang/python/python-2.2-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r3.ebuild,v 1.2 2002/01/15 00:32:54 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2-r4.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
PYVER="`echo ${PV} | cut -d '.' -f 1,2`"
S=${WORKDIR}/Python-${PV}
diff --git a/dev-lang/swig/files/digest-swig-1.3.10 b/dev-lang/swig/files/digest-swig-1.3.10-r1
index 8737067d2f52..8737067d2f52 100644
--- a/dev-lang/swig/files/digest-swig-1.3.10
+++ b/dev-lang/swig/files/digest-swig-1.3.10-r1
diff --git a/dev-lang/swig/swig-1.3.10.ebuild b/dev-lang/swig/swig-1.3.10-r1.ebuild
index 3bbfb7c54bf9..b7a7cf713336 100644
--- a/dev-lang/swig/swig-1.3.10.ebuild
+++ b/dev-lang/swig/swig-1.3.10-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Tools Team <tools@gentoo.org>
# Author: Karl Trygve Kalleberg <karltk@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.10.ebuild,v 1.2 2002/01/15 00:32:54 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.10-r1.ebuild,v 1.1 2002/01/15 01:27:50 gbevin Exp $
S=${WORKDIR}/SWIG-${PV}
DESCRIPTION="Simplied Wrapper and Interface Generator"