summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-13 20:23:46 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-04-13 20:23:46 +0000
commitb1e26c152d8bbc80abd1157adf53a01b191e07d6 (patch)
tree06ec8df7a08e870c5a4e0417ab290cc8bd249971 /dev-lang
parentfix0r (diff)
downloadgentoo-2-b1e26c152d8bbc80abd1157adf53a01b191e07d6.tar.gz
gentoo-2-b1e26c152d8bbc80abd1157adf53a01b191e07d6.tar.bz2
gentoo-2-b1e26c152d8bbc80abd1157adf53a01b191e07d6.zip
Fixes #1687
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/icc/ChangeLog17
-rw-r--r--dev-lang/icc/files/digest-icc-5.0.11
-rw-r--r--dev-lang/icc/icc-5.0.1.ebuild79
3 files changed, 97 insertions, 0 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
new file mode 100644
index 000000000000..2b01b2665626
--- /dev/null
+++ b/dev-lang/icc/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for dev-lang/icc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.1 2002/04/13 20:23:46 karltk Exp $
+
+*icc-5.0.1 (12 Apr 2002)
+
+ 12 Apr 2002; William McArthur <Leknor@Leknor.com> ChangeLog :
+
+ Initial Gentoo package. The install from Intel is RPM based so I extract
+ the i386 RPMs manually using rpm2cpio and cpio. (Idea taken from the
+ realplayer ebuild) Other than running rpm for you the install script just
+ replaces some stings in a few files with sed, so I copied and mangled the
+ relavent lines from their install and use them. I also correct a typo
+ descriped on Intel's web site. This fix should be removed at next icc upgrade.
+ The install is a simple copy and adding one file to /etc/env.d to set up a few
+ enviroment settings icc needs. After the package is merged I inform the user
+ where to get a license key and where to put it.
diff --git a/dev-lang/icc/files/digest-icc-5.0.1 b/dev-lang/icc/files/digest-icc-5.0.1
new file mode 100644
index 000000000000..3301a7f4e997
--- /dev/null
+++ b/dev-lang/icc/files/digest-icc-5.0.1
@@ -0,0 +1 @@
+MD5 2dc0ec729168ef1b768415919d38b829 cc010911rh71.tar 33669120
diff --git a/dev-lang/icc/icc-5.0.1.ebuild b/dev-lang/icc/icc-5.0.1.ebuild
new file mode 100644
index 000000000000..e4c1be990cfb
--- /dev/null
+++ b/dev-lang/icc/icc-5.0.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: William McArthur <Leknor@Leknor.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-5.0.1.ebuild,v 1.1 2002/04/13 20:23:46 karltk Exp $
+
+S=${WORKDIR}
+
+DESCRIPTION="Intel C++ Compiler - The Pentium optimized compiler for linux"
+
+#SRC_URI="cc010911rh71.tar"
+#RESTRICT="fetch"
+
+SRC_URI="http://www.intel.com/software/products/downloads/cc010911rh71.tar"
+
+HOMEPAGE="http://www.intel.com/software/products/compilers/c50/linux/"
+
+# Orginally I included app-shells/tcsh because there is one shell script that
+# uses it but I found there is alse a ksh/bash version of that script provided
+# but what documentation I read only referenced the tcsh version.
+DEPEND=">=sys-kernel/linux-sources-2.4
+ >=sys-libs/glibc-2.2.2
+ sys-apps/cpio
+ app-arch/rpm"
+
+RDEPEND=">=sys-kernel/linux-sources-2.4
+ >=sys-libs/glibc-2.2.2"
+
+src_compile() {
+ mkdir opt
+
+ for x in intel-subh-5.0.1-118.i386.rpm intel-icc-5.0.1-129.i386.rpm intel-ldb-5.0.1-119.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+
+ SD=${S}/opt/intel
+ RD=/opt/intel
+ for FILE in $(ls $SD/compiler50/ia??/bin/*vars* 2>/dev/null) \
+ $(ls $SD/compiler50/ia??/bin/*.cfg 2>/dev/null) \
+ $(ls $SD/compiler50/ia??/bin/*.pcl 2>/dev/null) \
+ $(ls $SD/compiler50/docs/*support* 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g $FILE>${FILE}.abs
+ mv -f ${FILE}.abs $FILE
+ chmod 755 $FILE
+ done
+
+ # This should be for version 010911 only. More info at:
+ # http://support.intel.com/support/performancetools/c/v5/linux/tti/csh.htm
+ FILE="${S}/opt/intel/compiler50/ia32/bin/iccvars.csh"
+ sed -e "s/=/ /" ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs $FILE
+ chmod 755 $FILE
+}
+
+src_install () {
+ dodoc lgpltext
+ dodoc clicense
+ cp -a opt ${D}
+
+ # icc enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc
+}
+
+pkg_postinst () {
+ einfo
+ einfo "http://www.intel.com/software/products/compilers/c50/linux/71non_linuxlic.htm"
+ einfo "From the above url you can get a free, non-time limited, non-commercial"
+ einfo "personal use license key that comes with no support. You will need to read"
+ einfo "and agree to the license and then fill in your info to have one emailed to"
+ einfo "you. Read the website for the details."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler50/doc/ ."
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/ ."
+ einfo
+}