summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-12-22 00:10:44 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-12-22 00:10:44 +0000
commitf3a8ef4ed03f1208c82154c7b0505bea431c7819 (patch)
treed3587632c46edf353cf8e3c34cc5c4e23945461e /dev-lang
parentVersion bump. (diff)
downloadgentoo-2-f3a8ef4ed03f1208c82154c7b0505bea431c7819.tar.gz
gentoo-2-f3a8ef4ed03f1208c82154c7b0505bea431c7819.tar.bz2
gentoo-2-f3a8ef4ed03f1208c82154c7b0505bea431c7819.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/ChangeLog7
-rw-r--r--dev-lang/ispc/ispc-1.6.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index 10c7615f3cd7..ac357909f625 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ispc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.13 2013/11/08 04:01:16 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.14 2013/12/22 00:10:44 ottxor Exp $
+
+*ispc-1.6.0 (22 Dec 2013)
+
+ 22 Dec 2013; Christoph Junghans <ottxor@gentoo.org> +ispc-1.6.0.ebuild:
+ version bump
*ispc-1.5.0 (08 Nov 2013)
*ispc-1.4.4 (08 Nov 2013)
diff --git a/dev-lang/ispc/ispc-1.6.0.ebuild b/dev-lang/ispc/ispc-1.6.0.ebuild
new file mode 100644
index 000000000000..89ede0a84438
--- /dev/null
+++ b/dev-lang/ispc/ispc-1.6.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.6.0.ebuild,v 1.1 2013/12/22 00:10:44 ottxor Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit base toolchain-funcs python-any-r1
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="http://ispc.github.com/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=sys-devel/clang-3.0
+ >=sys-devel/llvm-3.0
+ "
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+}
+
+src_install() {
+ dobin ispc
+ dodoc README.rst
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}