summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-12 16:30:04 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-12 16:30:04 +0000
commit595324ad6ea0d182c572fc9153171e00fb455371 (patch)
tree84913c1cf05caca3ebfa97b29d10f16a3199734d /dev-libs/DirectFB
parentdo or die instead of try (diff)
downloadgentoo-2-595324ad6ea0d182c572fc9153171e00fb455371.tar.gz
gentoo-2-595324ad6ea0d182c572fc9153171e00fb455371.tar.bz2
gentoo-2-595324ad6ea0d182c572fc9153171e00fb455371.zip
Update (avifile and libmpeg3 use options currently untested)
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.7.ebuild67
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.71
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.7.ebuild b/dev-libs/DirectFB/DirectFB-0.9.7.ebuild
new file mode 100644
index 000000000000..54efd307ed91
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-0.9.7.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.7.ebuild,v 1.1 2001/11/12 16:30:04 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="DirectFB is a thin library on top of the Linux fb devices"
+SRC_URI="http://www.directfb.org/download/DirectFB/${A}"
+HOMEPAGE="http://www.directfb.org"
+
+DEPEND="virtual/glibc sys-devel/perl >=media-libs/freetype-2.0.1 >=media-libs/jpeg-6
+ >=media-libs/libpng-1.0.10 >=media-libs/libflash-0.4.10
+ avifile? ( >=media-video/avifile-0.6.0 )
+ libmpeg3? ( >=media-libs/libmpeg3-1.2.3 )"
+
+RDEPEND="virtual/glibc >=media-libs/freetype-2.0.1 >=media-libs/jpeg-6
+ >=media-libs/libpng-1.0.10 >=media-libs/libflash-0.4.10
+ avifile? ( >=media-video/avifile-0.6.0 )
+ libmpeg3? ( >=media-libs/libmpeg3-1.2.3 )"
+
+src_compile() {
+ if [ "`use mmx`" ] ; then
+ myconf="--enable-mmx"
+ else
+ myconf="--disable-mmx"
+ fi
+ if [ "`use avifile`" ] ; then
+ myconf="$myconf --enable-avifile"
+ else
+ myconf="$myconf --disable-avifile"
+ fi
+ if [ "`use libmpeg3`" ] ; then
+ myconf="$myconf --with-libmpeg3=/usr/include/libmpeg3"
+ mkdir ${S}/interfaces/IDirectFBVideoProvider/no
+ cp /usr/lib/libmpeg3.a ${S}/interfaces/IDirectFBVideoProvider/no
+ else
+ myconf="$myconf --disable-libmpeg3"
+ fi
+ if [ "$DEBUG" ] ; then
+ myconf="$myconf --enable-debug"
+ else
+ myconf="$myconf --disable-debug"
+ fi
+ ./configure --prefix=/usr --host=${CHOST} $myconf \
+ --enable-jpeg --enable-png --enable-gif || die
+# cp Makefile Makefile.orig
+# sed -e "s:examples::" Makefile.orig > Makefile
+ if [ "`use libmpeg3`" ] ; then
+ make LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3 || die
+ else
+ make || die
+ fi
+
+}
+
+src_install () {
+ if [ "`use libmpeg3`" ] ; then
+ make LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3 DESTDIR=${D} install || die
+ else
+ make DESTDIR=${D} install || die
+ fi
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+ docinto html
+ dodoc docs/html/*.{png,html}
+}
+
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.7 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.7
new file mode 100644
index 000000000000..131cad60c2a5
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-0.9.7
@@ -0,0 +1 @@
+MD5 754e9a68d30decdf69bdc21f0d82f201 DirectFB-0.9.7.tar.gz 1261568