summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-10-22 04:03:30 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-10-22 04:03:30 +0000
commitab9a883333ffbdffbd2baa82416d2e7aef8961f6 (patch)
tree6a6936f17b6bcebefec477e2c0c67ae88215e80b /dev-libs/boost/boost-1.29.0.ebuild
parentpatch from airsnort to allow our pcmcia-cs to work with kismet (bug 7242) (diff)
downloadgentoo-2-ab9a883333ffbdffbd2baa82416d2e7aef8961f6.tar.gz
gentoo-2-ab9a883333ffbdffbd2baa82416d2e7aef8961f6.tar.bz2
gentoo-2-ab9a883333ffbdffbd2baa82416d2e7aef8961f6.zip
new version
Diffstat (limited to 'dev-libs/boost/boost-1.29.0.ebuild')
-rw-r--r--dev-libs/boost/boost-1.29.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/boost/boost-1.29.0.ebuild b/dev-libs/boost/boost-1.29.0.ebuild
new file mode 100644
index 000000000000..c669fc179e7c
--- /dev/null
+++ b/dev-libs/boost/boost-1.29.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.29.0.ebuild,v 1.1 2002/10/22 04:03:30 blizzy Exp $
+
+MY_V="${PV//\./_}"
+
+DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
+HOMEPAGE="http://www.boost.org"
+SRC_URI="http://boost.sourceforge.net/release/boost_${MY_V}.tar.gz"
+LICENSE="freedist"
+KEYWORDS="~x86"
+SLOT="1"
+IUSE=""
+
+RDEPEND=">=dev-util/yacc-1.9.1-r1
+ >=dev-lang/python-2.2.1"
+
+S="${WORKDIR}/boost_${MY_V}"
+
+src_compile() {
+ # first compile jam (the boost build tool)
+ cd ${S}/tools/build/jam_src
+ emake || die "couldn't build jam"
+
+ # now build boost libraries
+ cd ${S}
+ ./tools/build/jam_src/bin.linuxx86/bjam -j2 \
+ -sBOOST_ROOT=${S} \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=2.2 \
+ -sTOOLS=gcc || die "build error"
+}
+
+src_install () {
+ # jam does not provide smth like 'make install' :(
+
+ cd ${S}
+ # install libraries
+ find libs -type f -name \*.a -exec dolib.a {} \;
+ find libs -type f -name \*.so -exec dolib.so {} \;
+
+ # install source/header files
+ find boost -type f -exec install -D -m0644 {} ${D}/usr/include/{} \;
+
+ # install documentation
+ dodoc README
+
+ # this part should really use dohtml -- karltk
+ for i in htm html jpg jpeg gif css
+ do
+ find . -type f -name "*.${i}" -exec \
+ install -D -m0644 {} ${D}/usr/share/doc/${P}/html/{} \;
+ done
+}