summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-11-08 16:50:19 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-11-08 16:50:19 +0000
commitb89835448d4fdf7ae5ce32321d6c5e431b8fd9fd (patch)
tree3e5698be40e6e2a8a53975b2801689632e8b57e3 /dev-libs/dmalloc/dmalloc-5.2.3.ebuild
parentversion bump (diff)
downloadgentoo-2-b89835448d4fdf7ae5ce32321d6c5e431b8fd9fd.tar.gz
gentoo-2-b89835448d4fdf7ae5ce32321d6c5e431b8fd9fd.tar.bz2
gentoo-2-b89835448d4fdf7ae5ce32321d6c5e431b8fd9fd.zip
version bump
Diffstat (limited to 'dev-libs/dmalloc/dmalloc-5.2.3.ebuild')
-rw-r--r--dev-libs/dmalloc/dmalloc-5.2.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/dmalloc/dmalloc-5.2.3.ebuild b/dev-libs/dmalloc/dmalloc-5.2.3.ebuild
new file mode 100644
index 000000000000..8afa85d69e99
--- /dev/null
+++ b/dev-libs/dmalloc/dmalloc-5.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.2.3.ebuild,v 1.1 2003/11/08 16:50:13 liquidx Exp $
+
+inherit debug
+
+DESCRIPTION="A Debug Malloc Library"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://dmalloc.com/"
+
+IUSE=""
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc "
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ econf --enable-threads --enable-shlib || die "configure failed"
+ emake all threads shlib tests || die "emake failed"
+}
+
+src_install () {
+ # install extra docs
+ dodoc ChangeLog INSTALL TODO NEWS NOTES README
+ dohtml Release.html dmalloc.html
+
+ make prefix=${D}/usr install installth installsl
+ doinfo dmalloc.info
+}